Jump to content

Firefox 24 - 52 for ME and 98

Recommended Posts

Hi Wunderbar98, my real name is Markus, as I said my lowest start was with ME, IE6SP1, DirectX9c and KernelEX with the latest update files - not more. A test without IE6SP1 and DirectX is still pending. looking4awayout states DX9c is necessary for his patches. Mozilla gives XPSP2, CPU with SSE2, 512MB RAM and 200MB hard drive space. But yes, FF31.8 doesn't run perfect, it happens that it freezes or crashes on some websites, but it is much better than Opera 12.02 or FF24 here. By now too many pages are no longer opened and give errors like

Unable to complete secure transaction
Show Details

Secure connection: fatal error (40) from server.

Of course, there are differences between 98 and ME. Just recently, I wanted to focus the investigation more on the hardware.

Link to comment
Share on other sites

Thank-you for the information Markus. Good luck with your testing, would be nice for Windows 9x users to have something more modern that can run error free. My modern web broswer emulation project, the browsers appeared to work fine but emulation needed too much overhead. The Firefox v31.8 crashes are only JavaScript related though? My impression from your posts is a lengthy browsing session with JavaScript fully disabled, everything is fine and error free, including GUI functions, bookmarks, etc. RetroZilla with the tweaks rarely gives secure connection errors, the problem is page layout and presentation, something that would work much better on a newer browser. All the best.

Link to comment
Share on other sites

I added another 31.8esr portable with extensions CTR, PlainOldFav and the switcher QuickJava (javascript, style, Image ...) to the first post. QuickJava makes it easy and fast to toggle between enabled and disabled.  There are many other JS switcher extensions,  which may also be interesting.

I tested many prefs, but so far, I have little to report. The UOC Patch is optimised for P3 systems and for speed, but less for stability. On my systems FF isn't slow in any case. The settings I tried generally had no effect.

The Adobe Flash plugin must be disabled, otherwise FF will crash. Tested with FlashPlayer I also installed and tried without success. This version doesn't work in old FF versions, too, on ME/98.

Link to comment
Share on other sites

On 5/31/2020 at 8:48 PM, schwups said:

The Adobe Flash plugin must be disabled, otherwise FF will crash. Tested with FlashPlayer

I found this: The Flash plugin npswf works with plugin container deactivated:

dom.ipc.plugins.enabled;false and dom.ipc.plugins.timeoutSecs;-1

Link to comment
Share on other sites

Set OMTC "layers.offmainthreadcomposition.enabled" to false solves glitch of FF 33 -35, that the window is not completely displayed. This setting seems to make FF very unstable while scrolling. That needs more testing.

Edited by schwups
Link to comment
Share on other sites

On 4/21/2020 at 8:11 PM, jumper said:

In addition to these new issues, how well are history, bookmarks, and printing working?


I fetched the printer out of the basement, connected it to the test machine and installed the driver. The cartridges don't work, but basic function tests are possible. System WinME, latest KernelEx core updates and both aux dll files. (No ComDlgKs.dll)

FF31.8 (mode - XPSP3) crashes if I try to print! At the latest when I press OK. Sometimes the Print Preview worked.


Datum 06/18/2020 Uhrzeit 17:17
FIREFOX verursachte einen Fehler durch eine ungültige Seite
in Modul KERNEL32.DLL bei 0177:bff7834f.
EAX=c002fa54 CS=0177 EIP=bff7834f EFLGS=00010216
EBX=0067f514 SS=017f ESP=0057ffb8 EBP=00580024
ECX=005801d8 DS=017f ESI=82eb27c0 FS=3947
EDX=bff6682d ES=017f EDI=00580200 GS=0000
Bytes bei CS:EIP:
53 56 57 8b 30 83 7d 10 01 8b 4e 38 89 4d f8 75

Later I got this error, too:

Datum 06/18/2020 Uhrzeit 19:52
FIREFOX verursachte einen Fehler durch eine ungültige Seite
in Modul <Unbekannt> bei c1e0:2e352e32.
EAX=0067f93c CS=0177 EIP=2e352e32 EFLGS=00010246
EBX=0067f93c SS=017f ESP=00580000 EBP=00580020
ECX=005800a4 DS=017f ESI=82eea7ac FS=3c67
EDX=bff6682d ES=017f EDI=005800cc GS=0000
Bytes bei CS:EIP:

bff66821 005800cc 0067f93c 005800e8 005800a4 005801d8 bff6682d 0067f93c 005800b4 bff7845a 005800cc 0067f93c 005800e8 005800a4 2e352e32 00580290

Jumper, is there a special setting I can try? You added different experimental print modes (but ME & 2K). I think these are meant for FF 3 up to 9 and other programs.

Link to comment
Share on other sites

Today I tested Firefox 35 and 31esr without any ME updates. This means without DirectX and IE 6 SP1 - Not even KernelEx Auxiliary DLL Updates (psapi.dll, uxtheme.dll). Only KernelEX + latest Core Updates. And indeed it started and ran! So far I don't testet on 98/98SE.

About config: I tried hundreds of settings without further improvements.

Printing: First tests failed. It crashed immediately. Modified Core.ini: I changed experimental win2k modes to WinXPSP2.

*** KernelEx 4.5.2016.20i ***



desc=WINXP2_PD1: PrintDlgExW_1, PrintDlgW_1


desc=WINXP2_PD2: PrintDlgExW_2, PrintDlgW_2



desc=WINXP2_PD3: PrintDlgW_3


desc=WINXP2_PD4: PrintDlgW_fwd



Something else about K Meleon:

74(Gecko), 75.0, 75.1, KG76.2(Pro and roytam's - Goanna) require the GDIPlus.dll (XP or Vista version).

They also need the msvcrt.dll update. msvcrt => msvcr70 (_except_handler4_common) Sorry, this update isn't a requirement. My wrong assumption was caused by the AVM software (FritzBox Firewall). The AVM installer paste following files msvcr70.dll, msvcp71.dll, msvcr71.dll in the system folder. The error didn't occur anymore after uninstalling AVM and removing these files.

Edited by schwups
Link to comment
Share on other sites

Switching "gfx.content.azure.enabled" to false solves the my tab glitch of Version 27. Apparently there is a problem with the cairo backend. Removing cairo from string "gfx.content.azure.backends" fixes it, too.

Edited by schwups
Link to comment
Share on other sites

The Boolean "gfx.content.azure.enabled" doesn't exist in FF28 and higher anymore. Creating "gfx.content.azure.enabled" = false or removing cairo from string "gfx.content.azure.backends" has no effect. Also a user.js with these entries don't help against these persistent and stubborn programming. Troubleshooting Information > graphics > AzureContentBackend  = cairo. For comparison > FF27 > AzureContentBackend  =  none

Edited by schwups
Link to comment
Share on other sites

This evening I tried to run Thunderbird portable 24, 31 and 38 on WinME. 38 already crashes while opening the GUI. 24 and 31 freeze on start, because the account wizard "Welcome to Thunderbird window" doesn't open. I found an inconvenient method to bypass it by adding these lines to the prefs.js:

user_pref("mail.account.account1.identities", "id1");
user_pref("mail.account.account1.server", "server1");
user_pref("mail.account.account2.server", "server2");
user_pref("mail.account.lastKey", 2);
user_pref("mail.accountmanager.accounts", "account1,account2");
user_pref("mail.accountmanager.defaultaccount", "account1");
user_pref("mail.accountmanager.localfoldersserver", "server2");
user_pref("mail.append_preconfig_smtpservers.version", 2);
user_pref("mail.server.server2.directory", "...Path ...\\ThunderbirdPortable\\Data\\profile\\Mail\\Local Folders");
user_pref("mail.server.server2.directory-rel", "[ProfD]Mail/Local Folders");
user_pref("mail.server.server2.hostname", "Local Folders");
user_pref("mail.server.server2.name", "Local Folders");
user_pref("mail.server.server2.storeContractID", "@mozilla.org/msgstore/berkeleystore;1");
user_pref("mail.server.server2.type", "none");
user_pref("mail.server.server2.userName", "nobody");

Maybe not all lines are needed and most probably there are smarter ways. Another big problem is that I can't add a Mail Account on ME. TB crashes immediately. One minor thing is that it continues to run in the background after closing. The upshot, today I must run and configure it on XP to use Thunderbird 24 or 31 on WinME afterwards.

Supplement Thunderbird 45: It starts with XUL.dll KernelEX mode WinXPSP2. And see additional requirements of Firefox 42 - 48. The account wizard doesn't open and the method to bypass it works here, too. It also crashes, if I try to add a Mail Account, but I was able to import the settings from OutlookExpress. UI and icon glitches are similar to those of Firefox 45. Apart from that it seems to be fully functional. It doesn't run in the background after exit. And better run TB with hardware acceleration enabled, if possible. It reduces ui glitches.


user_pref("layers.acceleration.disabled", false);
user_pref("layers.acceleration.force-enabled", true);

It requires DirectX9c.

The add-on Squared Australis Tabs (Tb) 1.1 solves the Tab Bar glitches. Compatibility: TB 31 - 53

Thunderbird on Sourceforge

Version overview:

12.0     - 23.0b1      no workaround
24.0     - 34.0b1      KernelEx core update 25
36.0b1 - 41.0b2      I no longer intend to write a special guide, because these versions do not offer an advantage.
42.0b1 - 52.9.1       requirements see Firefox 42 and higher / first page
53.0b                      I no longer intend to write a special guide, because this version do not offer an advantage.


Edited by schwups
Link to comment
Share on other sites

  • 5 weeks later...

I've looked at Seamonkey again. I just use 2.24 and JS is enabled. I added the extensions jsbtn, a Javascript Toggler/a Status Bar JS on/off Button and PlainOldFavorites. Seamonkey must be added to the install.rdf file of PlainOldFavorites:

    <!--SeaMonkey -->

SeaMonkey Add-ons

Version 2.39: See Firefox 42 - 48

Version 2.40 (Gecko 43) starts with prefs.js entry: user_pref("layers.acceleration.force-enabled", true);
Without it Seamonkey crashes immediately on start. For additional requirements see Firefox 42 - 48.

"user_pref("layers.acceleration.force-enabled", true);" is suitable for SeaMonkey 2.30 - 2.32.1, too. (Issue: SM window is flawed and not completely displayed)

Versions 2.41 - 2.45: No official version releases - See https://ftp.mozilla.org/pub/seamonkey/oldnightly/. I tested 2.45 - it runs with with prefs.js entry "user_pref("layers.acceleration.force-enabled", true);". For additional requirements see Firefox 42 - 48.

SeaMonkey on Sourceforge

Don't forget to set the Xul.dll to XPSP2.


- Seamonkey crashes, if I try to clear the Private Data. SM 2.39 and higher versions aren't affected.

- Some pages load very delayed as happened for me with Firefox. The trick to run the portable version on XP once doesn't work. On next start on Win ME Seamonkey crashes immediately. Then I've to delete "places.sqlite" in the Data/Profile folder! The file will be recreated. SM 2.39 and higher versions aren't affected.

- Download doesn't work. It stops immediately and there is created one 0 byte file only.

- The Address Book works very slowly.

- And see Firefox for issues

Version overview:

2.9   - 2.20        no workaround
2.21 - 2.32.1     KernelEx core update 25
2.33 - 2.38        no workaround
2.39 - 2.49.5     requirements see Firefox 42 - 52 / first page

Edited by schwups
Link to comment
Share on other sites

  • 3 weeks later...

Now I'm running FF45.9esr (JS enabled) and latest KM 76.3.1 (JS disabled) on ME. I am quite surprised and I am not sure why. I believe it has to do with the KernelEx settings for the mfc*.dll/msvc*.dll files. I had tried different modes and had temporarily set mfc*.dll's to NT40 in context with "Streaming & Downloading Youtube Videos in 2020". I had problems with setting NT40. The mouse did not work repeatedly on OS start and I also had trouble shutting down. So I had set all the mfc* files to default or Base enhencements, if default didn't stick. FF 45.9 seem to run stable with JavaScript enabled, but it has the same or similar UI glitches as FF35. The extension "Classic Add-ons Archive" is installable and works.


network.dns.disableIPv6 => true

browser.newtabpage.enabled => false

xpinstall.signatures.required => false     to install unverified add-ons (already set in RT's builds)

RT's FF45 build:


Edited by schwups
Link to comment
Share on other sites

FF45 doesn't work without Kext! I've revised my ini file and removed redundant entries. Not all entries are required to run FF45:

~~~ Definitions ~~~







Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...