Jump to content

Win 98 SP3 broken networking - multiple NIC, physical/virtual machines / physical machines- ping error 10043/10091 .. on all machines, unfixable :(


Recommended Posts

Make this sense, when its not worked even after restore whole partition with which im sure that it worked before? If i broke something, restore should fix it, or not?

This again change of same machine, if problem is on network change inside machine will not help.

I would understand if machine would start to send some bad packets and router would block it, but it would work after reboot to other OS? Are these packets different.

Link to comment
Share on other sites

  • 3 years later...

From time when i first met this problem i simulated it losts of times on virtual and physical machines, its still the same after time or some change Win98 SP3 networking get broken..
  So i would say that some SP3 networking files are bugged, or broken, or incompatible with vanilla ones.. during some update or hw installation is maybe some vanilla file used to replace SP3 one..

  I would really like to know which files are responsible for Win 9x networking.. and replace them one by one. Telnet is broken too, cant connect. Winscp is not working - route problem.
When i use MS configuration utility (Winipcfg.exe), im getting DHCP server unavailable, when im trying to renew it.. I dont obtain right ip adress just default packets are not returning from router.. 
 Machine is not getting ip adress. ipconfig shows empty gateway.

  Symptoms same with all Nics, drivers installed, not errors, but networking is not working.. and ping is failing... 

I never that this problem with vanilla Windows 98 version or official updates.

Edited by ruthan
Link to comment
Share on other sites

  • ruthan changed the title to Win 98 SP3 broken networking - multiple NIC, physical/virtual machines / physical machines- ping error 10043/10091 .. on all machines, unfixable :(

There is some DHCP service dhcpsvr.dll, but how to check that is loaded correctly? Its not WinXp with service manager.

If im not wrong that DHCP service should work regardless of network settings a far as some Network adapter is added, or not?

Edited by ruthan
Link to comment
Share on other sites

Dr Watson for system snapshots with versions and descriptions of drivers.

System File Checker for detecting file changes.

Both available from the Tools menu in System Information, or directly from %WinDir%.

Revert system to last working. Take snapshot with DrWatson and have SFC scan and update.

Try installing USP2.1, then USP3.0beta. Take new snapshots and have SFC report changes.


Link to comment
Share on other sites

What version of the Unofficial SP3 are you using?

What Update options are your selecting?

I couldn't make out for sure, if you had ever had a machine with working networking after the update. It seemed like it was only some machines that had the issue. If that is true, of the machines that do have the issue, do they always have the issue (after the SP3 install); or is it erratic?

You can copy the service pack to a temporary folder, and extract it with 7-zip. "INFEX.INI" is the core of the service pack. You can examine it to get a grasp of the over all process. But for individual updates, you need to examine the ".INF" file, that correlates to the update. Also, you may need to examine the correlating ".BAT" files. This will tell you what files are being replaced, and what registry settings are being added/changed.

The file you probably want is "SPUPDATE.INF", unless you are also installing Internet Connection Sharing "ICS.INF".

You could try a fresh install, just installing "Main Updates/System Core Files (SPUPDATE.INF)". If you end up with the same networking issue as before, you could then eliminate, for certain, all the other "less likely" causes.

If "Main Updates/System Core Files" isn't causing the issue, then you can "one by one" install each update (that you normally use from the service pack) until you find the one that creates the error.

Unfortunately, you are the only one that can debug this, unless it is duplicated somewhere else.

After each change you make, to the new install, restart and test the network. The you can at least isolate, to some degree of certainty, that it is the service pack (and a specific update) causing your issue.

Link to comment
Share on other sites

I'm was using: U98SESP3 , i installed the most of the updates, which were describing as improvement or fixes.

Its not so simple, Networking is working after installation of updates.. Until, i try to chance something with networking, replace NIC or install new protocol like IPX etc, after that something gets struck is impossible to make it working again, after NIC and all protocols removal etc. Something is broken / stuck in system.

  I also tried to copy image Windows to multiple new physical / virtual machines, there whole HW is redetected and reinstalled, even that networking never get fixed.

 This way i would be able to simulate it again (i simulated it multiple times on different machines, i have snadshot i can revert yes).. but its not fix.. reinstall whole system because NIC replacement, or because protocol addition sucks.. So i would rather to fix it and look into that DHCP service or other network services why they are not working.. 

i will try that SFC check, Update: 1 dll corructed, restored, retested, problem not fixed. I tried to find network related drivers and their version if it helps.





Edited by ruthan
Link to comment
Share on other sites

I'm still wondering which version of SP3. For example 3.65 or 3.66.


I think I may have noticed something similar to this, once before. It almost seemed like the system needed to revert first (uninstall the updates), reconfigure the network with the needed change, and then re-install the updates. This was just a passing thought I had once, when dealing with a Win98SE system (post SP3.66 update). I can't remember the exact issue; but I vaguely remember it seeming like the files needed could not be installed (original cab files), because their reference had been lost.

However, it could have very well been, that some new file(s) were preventing other components from functioning correctly. I didn't mess with Win98SE for very long, so my memory is fuzzy on it.

If it was original files not being referenced, in the update's newer system and or .INF files, then one might be able to examine pre-update system INFs for the missing references. But I'm not entirely sure the INFs control everything. Sometimes, when installing a driver, it looks for files that the INF says it needs. However, depending on the version of that/those file, the following files called for (through out the rest of the installation) may be different. It must be detected linked dependencies that are being requested? So there is a chance that newer system files are not linked to older system files, needed for system reconfiguration. Or some near variation of that last sentence. It could just be some other trigger that doesn't get called.

It would still help to know which update option was causing it. It's probably the "Main Updates/System Core Files" option.

Another questions, do you get any errors or strange behavior, while installing the update?

3 hours ago, ruthan said:

I also tried to copy image Windows to multiple new physical / virtual machines, there whole HW is redetected and reinstalled, even that networking never get fixed.

Are you saying you copy the "broken" install over to a new system and the issue is still present; or that you are overwriting the broken install, with a working install, and the issue is still present. I think you are saying the first, and that would make sense; since nothing, with the core system, has really changed.

I can't remember, does SP3 have an uninstall option? If it does, can you test that?

Can you back up one of your working VMs and test if just the "Main Updates/System Core Files" option causes your/the issue? It would be nice to know, if focusing on just that one update is enough.

Link to comment
Share on other sites

@ruthan I should add, if you are just looking to solve this a little faster and be done with it, you could look at some of the older service packs. As far as collected official updates, many older versions still contain them all. So if an older service pack did not cause this issue, you could use it and then cherry pick the things you wanted from SP3 (providing it is not the thing causing the issue). Then you would have a way to duplicate a successful update, without the issue.

Edited by awkduck
Link to comment
Share on other sites

Im not 100% sure, or i dunno how to check it, after installation, but i have here 3.64 installer, so it would be probably it. I do not have reason to install it again and again when its broken, but i have some fine tuned machines / images with this major flaw..

 I dont really remember any errors with installation, as i wrote it worked fine, until some network configuration changes. 
 Im not even aware any other problems with machine, except this thing.. All seems to be properly setup and installed, i would undertand some bluescreen, NIC driver code, but this is something new.. 

 So question is, if is possible somehow test network services / component piece by piece TCP/IP has like 7 layers, so if possible to discover on which layers it fails, its not able to obtain IP from router.. if i set static addresses its still not working.. and ping is failing something in configuration is broken.. some core component is not working, or its these some dead write bridge NIC / dead NIC or something like that.. but i removed all old Nics in Safe mode, even not used devices.. 

 Only interesting thing is that ping localhost its working fine.. im not sure if it is using all network TCP/IP layers and services, or its faked call, which its outside of network setup.

I tested route print output its the same on working and not working machines, except ip adress which i now inserted as static, its from the same range, so it should work fine..

Edited by ruthan
Link to comment
Share on other sites

Not my field of expertise (I always used and still use only IP static addresses on my networks, bar the Wi-FI).

The 169.254.x.x nebtmask is "normal", it is a so-called APIPA address, it is actually a symptom, it means essentially "the network stack is set to get an address from a DHCP server, but none could be found, so I am using temporarily this address":


But what happens if you manually set a static IP address?

If everything works, than the issue is only related to the DHCP, if it doesn't there may be "wider" issues with the network stack.

What do you get with:

ARP -a

in the case of a missing DHCP and in the case of the static address?



P.S. Also, check the Registry in:


in it there may be one (or more keys) like DHCPINFO00, DHCPINFO01, etc.

Save/backup them (just in case), then delete them and reboot.

Edited by jaclaz
Link to comment
Share on other sites

12 hours ago, ruthan said:

I do not have reason to install it again and again when its broken, but i have some fine tuned machines / images with this major flaw..

I get it. We all have to problem solve, in a way that makes sense to us.

I do apologize, that I couldn't help more. I know I have used the service pack 3, without the issue you've described. I wish I could remember more, about the one time I had ran into an issue.

I suppose, I do things more in a revision history kinda way. For example, "what change broke things?". But it isn't a direct "fix this specific machine approach", but rather a "fix the cause approach". But the direct "fix this machine approach" will find the answer to the cause, just as well.

I'll keep my eyes on the thread, and see if I can help in anyway.

I don't think the following will help, but its just something I ran into, from the SP3 site.



Core options are for users ONLY, who will not be using Internet Explorer

That's the option with the "(98lite Users Only)" tag.

I didn't see your issue anywhere in the service pack forum, but I did not read it from cover to cover. It is possible you could find a clue there. You may have already looked. Also, there is a list (and links), for service pack releases, on the first post.

Link to comment
Share on other sites

Set IP address and gateway static is not solution, i would not bother if it would.. Im getting exactly the same errors.

Arp-a output:
NO ARP Entries Found

I found DHCPINFO00 key, deleted, rebooted, key was created with same or similar value, behavior is the same.



Link to comment
Share on other sites

I was looking for usual suspects and in nSP3 are these:
Internet Connection sharing ICS Client 5.2
Microsoft IPP Client 1.0
Microsoft L2TPIpsec VPN client..

  Im not sure, if installed them, probably some, but i dont know how to find out and how to uninstall them.. nSP3 has nothing like list of installed components when i start setup wizard again.. and nothing is listed in Add/Remove programs windows wizard.. or in windows components setup.

  But i find out some interesting thing, i tried to check, install original internet sharing component and got this interesting message, it could be clue what is wrong.. I have NIC list in Device manager, as in image above.

Other interesting point is when i do some networking change, its using files from sp3.cab, so they are probably some updates/ changes.

Edited by ruthan
Link to comment
Share on other sites

I am reminded of a common troubleshooting step that we advised on 9x systems when I worked with an ISP. It is a bunch of steps and I'm not fully convinced it is all needed, nor that there isn't something easier that could be done to do the same thing. I will put it here just in case.

1. Release IP
2. Arp -d
3. Go into the adapter properties and uncheck TCP/IP
4. Reboot
5. re-enable/check TCP/IP

This was for when a NIC (not WLAN) would always have the APIPA info even if a valid and functional DHCP server was present on the network. It was just one of those things that helped many people and many people had happen to them, but I never experienced personally.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...