Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
shorterxp

Question about TCP/IPv4

Recommended Posts

Posted (edited)

Hi, does anyone know if "Internet Protocol TCP/IP" seen here in XP, is actually version 4?

Open-Internet-Protocol-Properties.png

I need to determine if missing v4 on my (nlite) XP install is the cause for an app to not connect through certain ports.

My consensus from a google image search suggests "Internet Protocol TCP/IP version 4" is never displayed in XP network device properties, only "Internet Protocol TCP/IP" and/or "Internet Protocol TCP/IP version 6".

"Internet Protocol TCP/IP version 4" is seen on newer operating systems however.

image0006ac.jpg

I'd greatly appreciate any hints.

Edited by shorterxp

Share this post


Link to post
Share on other sites

Is it normal that there isn't the line IPv4 address on my system?

untitled.PNG.96c7706f6db338bb6187fe4fa7514ace.PNG

Contrast, a random youtube tutorial:

untitled2.PNG.16909fb26a2bcdab0a9f17ae141eccdc.PNG

 

Share this post


Link to post
Share on other sites

Yes, it's IPv4.

That property panel in my full install of XP+SP3 also shows:
This connection uses the following items:
...
[ ] Internet Protocol (TCP/IP)

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks dude.

@anyone:

Is missing IPv4 Address line in command prompt normal? I'm connected to a public wifi hotspot and theres a problem connecting to a port (needed for an 'app' to start). 'App' worked in the past on same connection, identical OS and H/w (except motherboard).

Other people had this same issue with the app. Fixes have been reported. The weirdest part is the fixes, they are very eratic in scope. Here is a list of the fix suggestions to make app work:

Disabled TCP/IPv6,
Made IP Static with Port Forward Utility, or
Added said Ports to win firewall, or
Added Google DNS in TCP/IP (someone said their ISP provider was blocking DHCP assigned IPs by Window XP). or
Nothing antivirus or firewall related is installed or on.Added Google DNS in TCP/IP

Weird huh? It could be ISP is blocking a port. I could try another connection to eliminate that possibility but no other connection exists. Its either OS/Motherboard driver conflict, ISP firewall or TCP/IPv4. There is no AV/Firewall running on OS as attempts are made.

It's so weird!

Here is what processmon reports when the attempt is made to start the app / connect to server.

g.jpg

Edited by shorterxp

Share this post


Link to post
Share on other sites

It could also be a completely unrelated issue with your .NET install:

https://www.realitymod.com/forum/showthread.php?t=124694

From what I have seen half the people over there had this same 1301 error for years (due to a whole lot of different reasons) and noone thought to modify the actual "App" to provide more meaningful (and differentiated) error codes.

jaclaz

Share this post


Link to post
Share on other sites
Posted (edited)

I saw that.

I reinstalled OS*, installed 3.5 SP1 and then 4 and Extended, then repair .NET in order and still fails.

The app has broad OS support perhaps its because of an oversight with 4.5 or later.

Then again it did work in the past last month but that was ona  different motherboard. This motherboard has nvidia Network Enumerator. The nlite OS is pretty much the same. So weird. I need to try that motherboard other again.

You are correct about the lack of error accuracy on the developers part.

 

*OS install takes only 3minutes. In fact the app takes longer to install than XP does lol. Much better than waiting half an hour for troubleshooting purposes as per original CD (or god forbid win10).

Edited by shorterxp

Share this post


Link to post
Share on other sites
Posted (edited)

Now I've tried a new motherboard and I still get same error. With Full XP SP3 (non-nlite) I get past verification error!

 

BUT

 

There now another error. I think this problem is ISP related and not hardware or OS. Although there is clearly something fishy with nlite install that causes a different error message!

 

I started a new thread about that here  https://msfn.org/board/topic/177606-error-995-anybody-familiar-how-to-fix/?do=findComment&comment=1152290

Edited by shorterxp

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×