Jump to content

Issues Connecting to Internet


Recommended Posts


I am currently attempting to create a dual-OS system on my gaming PC with Windows 10 Pro 64-bit and Windows XP Pro SP3 32-bit. I already have the dual boot setup between both OS and am working on finding drivers for the Windows XP side.

The only drivers I currently have are the one for the SATA ACHI connection and the network adapter.

The network adapter is a Realtek PCIe GBE Family Controller, hardware ID: PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458&REV_0C.

I found a Windows XP supported driver for it and installed it on my system. After rebooting the computer, it installs correctly, and the network icon showed up in the bottom right-hand corner of the task bar. However, when I plugged in the ethernet cord, nothing happened. I tried using a different cord and modem port, still nothing. It does work properly on the Windows 10 side however.

Does anyone might know what might be the cause of this?

Here are my system specs if it helps:

Gigabyte - GA-H110M-A Micro ATX LGA1151 Motherboard | Intel - Core i7-6700K 4.0GHz Quad-Core Processor |Gigabyte - GeForce GTX 1060 3GB 3GB Windforce OC Video Card | 16 GB DDR4 RAM

Also, as a side note, I would appreciate it if any of you could tell me where I can find drivers for my system for Windows XP. They're a bit hard to dig up, what with little official support for it. If you need hardware ID, I can give it to you.

Thanks so much for all your help!

Link to comment
Share on other sites

Check the card in device manager, maybe it has an error code for the driver.

The "I found a Windows XP supported driver" is very vague, if you found it on the board manufacturer site (which I doubt) you can be 99% (never 100%)  sure that the driver is suitable and works on that motherboard, if you found it *anywhere else*  the reliability of the "XP supported" part might be as low as 0% :w00t::ph34r:.


Link to comment
Share on other sites

13 hours ago, Bersaglio said:

Try official Realtek driver. Your LAN controller is 100% compatible with XP SP3. Official Realtek website gaves me this link with latest drivers for Your LAN controller. :-)

Thanks so much! It worked!

It's funny, I thought I was using the official driver. Go figure. ;)

There is another issue though. While there is an internet connection, it is extremely slow. For example, if you try to visits a website, internet explorer will start, attempt to load, then crash. The same thing happens with updates.

I checked the internet connection speed in "Internet Connections, and it showed it being 1.0 GBps.

What can I do to make the speed normal? What other crucial drivers does it depend on?

Edited by Kescarte_DeJudica
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...