Jump to content

KernelEx Auxiliary DLL Updates


Recommended Posts

KernelEx Auxiliary DLL Updates


Update packages include DLL and complete source code.

DLL API Counts
Stock = KernelEx 4.5.2

   Stock (5)
   WinXP (5)
   Stock (71)
   WinXP (158)
   Stock (17)
   WinXP (24)
   psapi3b.7z (27)
   Stock (16)
   WinXP (110)
   Stock (48)
   WinXP (95)
   uxtheme.7z (95)
   Uxtheme423.7z (124)
   Stock (20)
   WinXP (35)
   ROS.41 (44)


--- Stock ---
Msimg32 (5 of 5): 4.5.2
Pdh (71 of 158): 4.5.2
Psapi (17/27 of 24): 4.5.2/psapi3b.7z
Userenv (16 of 110): 4.5.2
Uxtheme (48/95/124 of 124): 4.5.2/uxtheme.7z/Uxtheme423
Wtsapi32 (20 of 35): 4.5.2

Edited by jumper
WIP / Uxtheme423
Link to comment
Share on other sites

@ Loblo. Could you install Java 7 in the 'old' way via the msi in appdata\sun\java ??


Latest JRE's appear to use a WIX installer and I found no way to install/unpack them.  Latest JDKs can still be unpacked however, and possibly installed too (I have not tried that), and you can use the included JRE (not the bundled JRE installer which is WIX based too).

Link to comment
Share on other sites

Installed those and it seems allright so far. 


Same results here.  

Part of the problem of me giving feedback is that (being mainly an end user and just a rudimentary programmer) i'm not sure of what apps i should use to test each file.  

However, i did just test the most-recent stable Media Player Classic - Black Edition (v1.4.2) portable, and it got past the long-standing UXTheme crash!  Unfortunately, it hit another one... but that's still progress....  

- Doug B.

Link to comment
Share on other sites

The plan is to keep a basic set of auxiliary DLLs with minimal functionality for inclusion with KernelEx. Then have larger and more functional versionals of each that can be downloaded and installed individually as plug-ins.

On my system, I am currently using four ReactOS (6-11-2014) DLLs as plug-ins. I put them in a KernelEx\ROS subfolder so my Ktree entries look like this KernelEx_KnownDLLs.reg file:


Edited by jumper
ipsCode clean-up
Link to comment
Share on other sites

Now I'm able to start and run Foxit Reader 7 ( KernelEX XPSP2 mode ). It is incredible fast here. Previous message was "Missing export PSAPI.DLL: GetMappedFileNameW".

It crashes with ribbon toolbar mode, but not with classic toolbar mode. Help => UI Options => change toolbar mode. The status bar buttons are pale, but function. They also look pale with Version 6.


crashlog ribbon toolbar mode:




Edited by schwups
Link to comment
Share on other sites

In the stack dump, I'm seeing way too many duplicate return addresses in Kernel32 (bff6....) and Kexbases (bfa4....). Looks like a stack leak is happening.

The crash is in module FOXITREADER.EXE, so I'll need to get that to have any hope in determining what lead up to the crash. The last reference to Kexbases is bfa4d24b; what version are you using?

Link to comment
Share on other sites

  • 7 months later...
  • 5 months later...

Hi Jumper, the entries (post 6) are case sensitive, aren't they ?

And I have tested t2embed.dll ! Seemed fine but is there a way to trigger an error to make sure that one dll is indeed compatible ?

Link to comment
Share on other sites

I believe the entries are not case-sensitive, but uppercase is the norm. Checking my registry, I see I am currently using mixed case on one entry and it presumably worked when I first added and tested it.

Why did you choose T2embed.dll and what verson of it are you testing? Just test any apps that call it and check the logs to see if it was invoked. If it was and the app performed as desired, then it works.

Link to comment
Share on other sites

DLL's from ReactOS 0.4.0.  (ROS\\...) which seem to work

Test environments: KEx v12.  -  Apps: Seamonkey 2.6.1., Sumatrapdf 3.0, Notepad++ 6.9, VLC 2.2.2, Audacity 2.0.6., Audacity 2.1.2, OpenOffice 3.2.1


- You may need to add these Kext-Stubs - please check the DLL's with DependencyWalker.




~ ~

Seem to be working:



Not working:

COMDLG32.DLL  (seem to break open dialogues)
DHCPCSVC.DLL  (seem to break flash player)
ICMP.DLL  (seem to break flash player)
DSOUND.DLL  (seem to break flash player)
IPHLPAPI.DLL  (seem to break flash player)
MSAFD.DLL  (causing Internet/Browser problems, websites do not load at all)
MSIMG32.DLL  (breaks SeaMonkey, kext stub seem to fail)
MSWSOCK.DLL  (breaks (at least) SeaMonkey)
OLE32.DLL  (breaks OS)
OLEAUT32.DLL  (breaks OS)
PSAPI.DLL  (breaks (at least) SeaMonkey)
RPCRT4.DLL  (breaks kex-apps)
RSAENH.DLL  (breaks OS)
SHDOCVW.DLL  (seem to break plainoldfavorites)
SHELL32.DLL  (breaks OS)
SHFOLDER.DLL  (seem to break (at least) VLC settings)
SHLWAPI.DLL  (breaks OS)
URLMON.DLL  (seem to break flash player)
USP10.DLL  (breaks kex-apps)
WININET.DLL  (causes some issues in notepad++)
WS2_32.DLL  (breaks kex-apps, asking for dnsapi.dll - more tests required)
WS2HELP.DLL  (breaks kex-apps, Kext entry failed - more tests required)
WSOCK32.DLL  (breaks kex-apps)

Not present in ReactOS 0.4.0:


Edited by MiKl
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...