Jump to content

KernelEx 4.5 Core Updates (4.5.2016.25)


Recommended Posts

KernelEx 12 works fine, thanks. But there is still a little bug in Kexbases 11 and 12. In Foxit Reader (tested on versions and the PDF text can be neither selected nor copied. The popup window "Failed to init" appears with the message "Invalid User32.dll, cannot find SetLayeredWindowAttributes". So I have reverted Kexbases back to version 10, which is O.K. What is interesting, if PDF file is opened in Adobe Reader, there is no problem to copy text with Kexbases 12. The only difference between these two readers: Adobe Reader copies text in ANSI style and Foxit Reader in Unicode style.

Link to comment
Share on other sites

@ Twin, I had a similar problem also once but with SumatraPDF. I think this issue is not caused 'directly' by KernelEx because I fixed this by upgrading unicode related files. Unfortunately I don't remember exactly which ones but please test uxtheme.dll and/or usp10.dll.
Edit/Follow up:
Tested Foxit No error message on my system but can confirm that text can not be selected.

But c&p is still something that maybe needs some attention. I can, for example, c&p text from a pdf via SumatraPDF to Notepad++. But not text from Notepad++ into the search field of SumatraPDF !

It is also not possible for me to directly c&p an image from a website (Kex-SeaMonkey) to my graphics app (Non-Kex-CorelDraw 11). I have to c&p the image first into, say, IrfanView and then c&p to Corel.

Edited by MiKl
Link to comment
Share on other sites

@schwups > Kexbases has considerably become bigger.
Moving the debug info into the dll's ensures its presence for debuggers (Procwin, DumpPE, Dr.Watson) and also shrinks the overall package size.

@MiKl > Is there a quick way to compare the contents of KexBases with what one have in Kext to remove possible double entries ?
Yes...process all Kexbase and Kext dll's (Kexbasen, Kexbases, ComdlgEx, iphlpapi4.dll, Kexstubs, Kstub822, etc.) with Kexports and Windiff! (Even Kexbasen and Kexbases can have duplicates when mixing different versions....)

@Twin: Welcome to the project. Does PDF text selection work correctly in Foxit 4/5 with all version .10 files? If so, thank you for reporting the regression.

Please use KexApiLog (DebugWindow) to isolate the api's involved. You can narrow/filter the results using the Windiff'ed output of Kexports on Kexbases.10 and .12 (see below); also try expanding it by diff'ing Kexbasen.10 and .12 as some api's were moved.

Kexbasen.12 + kexbases.10 is a version mismatch and does not support all 10+10 or 12+12 api's! Also, there are many duplicates, so the order they are declared in Core.ini >> contents= matters!

Kexbases.10 vs. Kexbases.12
edit: coming as soon as I debug the new spoilers

Kexbasen.10 vs. Kexbasen.12
edit: coming as soon as I debug the new spoilers

List produced with Kexports and Windiff 5.2.3790.0.

Note: User32:SetLayeredWindowAttributes is stubbed in both kexbases.10 and .12 as implicit-only. Explicit (delay) loads will fail. Using Kexbases.10 somehow avoids the delay-load call (that fails).

Edited by jumper
Spoiler and Code tags don't seem to be working yet....
Link to comment
Share on other sites

@MiKl > I have tried a while ago to copy and paste text from SumatraPDF to Notepad++ and back to search field of Sumatra, and all has been working well. But I use now Kexbases 10, so the problem must be in the used Kexbases version. As far as the browser images, I have neither SeaMonky, nor CorelDraw, but a similar constallation: Kex-Firefox/Opera and non-Kex-PaintShop7/PhotoShop7. Again, with Kexbases 10 I have no c&p problem.

@jumper > Yes, I was initially afraid that by mixing of different KernelEx component versions I get some mismatch. So first I experimented with a pure version 10. Foxit 4/5 worked correctly and all other programs, only Cinema4D R13 (otherwise working with only the original Xeno's build) still crashed when attempting to open help or tutorials from inside the program. Then I tried the version 12 with only Kexbases 10, and it was all right. Till now I have found no defect in any program, using this "mismatch" combination. So meanwhile I wait until some collision appears… or until Kexbases 12 will be revised…


Link to comment
Share on other sites


System Win ME, KernelEX 4.5.2:

Foxit Reader  The direct copy is possible to Notepad++ or OpenOffice writer.

System Win ME, KernelEX 4.5.2015.12:

Foxit Reader  Error message "Invalid User32.dll, cannot find SetLayeredWindowAttributes"


Datum 04/13/2016 Uhrzeit 12:26
FOXIT READER verursachte einen Fehler durch eine ungültige Seite
in Modul KERNEL32.DLL bei 0177:bff8e1ad.
EAX=c002fa54 CS=0177 EIP=bff8e1ad EFLGS=00010212
EBX=00000000 SS=017f ESP=01c3fe08 EBP=01c400a4
ECX=00000000 DS=017f ESI=01f01860 FS=3ba7
EDX=015dd8e0 ES=017f EDI=011e9cf0 GS=0000
Bytes bei CS:EIP:
53 8b 15 f4 bc fb bf 56 89 4d e4 57 89 4d dc 89

Versions 4.x: Copy function only by "text viewer" of Foxit.

Apparently a copy to MS Editor or WordPad is always impossible, it doesn't matter which version I use.

Link to comment
Share on other sites

  • 2 months later...

API lists for all 4.5.2015 versions through ...13: apilist.4.5.2015.13.7z
Use Windiff on version pairs to highlight API changes.

=== Under Construction ===
Left: 4.5.2015.12
Right: 4.5.2015.13
!> DECL_API("RtlMoveMemory", RtlMoveMemory_fwd),

!> DECL_API("RegisterTypeLibForUser", RegisterTypeLib),
!> DECL_API("UnRegisterTypeLibForUser", UnRegisterTypeLib),
!> DECL_API(442, RegisterTypeLib),
!> DECL_API(443, UnRegisterTypeLib),

!> DECL_API("IsValidDevmodeW", IsValidDevmodeW_stub),

!> DECL_API("SystemFunction040", SystemFunction040_stub),
!> DECL_API("SystemFunction041", SystemFunction041_stub),

!> DECL_API("AcquireSRWLockExclusive", AcquireSRWLockExclusive_stub),
!> DECL_API("AcquireSRWLockShared", AcquireSRWLockShared_stub),
!> DECL_API("InitializeSRWLock", InitializeSRWLock_stub),
!> DECL_API("ReleaseSRWLockExclusive", ReleaseSRWLockExclusive_stub),
!> DECL_API("ReleaseSRWLockShared", ReleaseSRWLockShared_stub),

!> DECL_API("LdrLoadDll", LdrLoadDll_stub),
!> DECL_API("LdrUnloadDll", LdrUnloadDll_stub),
!> DECL_API("ZwClose", NtClose_new),

!> DECL_API("SHGetKnownFolderPath", SHGetKnownFolderPath_stub),

!> DECL_API("PathUnExpandEnvStringsW", PathUnExpandEnvStringsW_stub),
!> DECL_API("ordinal467", ordinal467_stub),
!> DECL_API(467, ordinal467_stub),

!> DECL_API("CliImmSetHotKey", CliImmSetHotKey_stub),
!> DECL_API("EnableWindow", EnableWindow_fix),
!> DECL_API("SetProcessDPIAware", SetProcessDPIAware_stub),
!> DECL_API("User32InitializeImmEntryTable", User32InitializeImmEntryTable_stub),

Edited by jumper
Link to comment
Share on other sites

Hi Jumper, thanks for the new version !! I noticed one thing.
The PC in the living room is connected with the TV via a DVI/HDMI-adapter cable and with v13 TV-mode (watching TV) is distorted when flash content is displayed.
Closing that tab in the browser (or the browser completely) fixes the distortions.
Downgrading kernelex.dll to the one from v12 works !!
I am not sure if v13 brings up some flaws in my setup or if there is indeed some kind of a bug in the new kernelex.dll

Edited by MiKl
Link to comment
Share on other sites

Thanks for the update, jumper!

After a couple of days of typical usage, R13 is working well (no apparent glitches in my "everyday" programs)... but i don't really know what to look for. What were the changes?

By the way, my main system is "just KernelEx" -- no Kext/Kstubs or ROS, so as to not complicate testing. (98SE with USP3x, 98SE2ME, RP9, IEradicator, etc.)

- Doug B.

Edited by DougB
Changed "RP7" to "RP9"
Link to comment
Share on other sites

2 hours ago, DougB said:

What were the changes?

I did not had the time yet to check everything but what I noticed are ntdll.dll [LdrLoadDll] which is great because this function as a kext stub caused only problems in my setups. And advapi32.dll [SystemFunction040] & [SystemFunction041].

Link to comment
Share on other sites

> Downgrading kernelex.dll to the one from v12 works !!
Kernelex.dll is functionally the same. Only the version and timestamps were bumped--nothing that would affect any app.

> What were the changes?
API changes now detailed in download post.

> By the way, my main system is "just KernelEx" -- no Kext/Kstubs or ROS, so as to not complicate testing. (98SE with USP3x, 98SE2ME, RP7, IEradicator, etc.)
Did you mean without? Please clarify.

> this function as a kext stub caused only problems
The new stubs are all implicit-only. They are only used if the module would otherwise fail to load. Kexstubs definitions are (currently) also used for explicit/delay loading of API's.

Link to comment
Share on other sites

>> By the way, my main system is "just KernelEx" -- no Kext/Kstubs or ROS, so as to not complicate testing. (98SE with USP3x, 98SE2ME, RP9, IEradicator, etc.)

> Did you mean without? Please clarify.

Ok, my main system:

98SE, including U98SESP 3.55, 98SE2ME, KernelEx r13 (without Kext/Kstub or ROS), RP 9.7.2, IEradicator, etc.

For this system, i'm trying to "Keep It Simple" in terms of KEx; plain-vanilla KernelEx to lessen the chances of weird interactions in order to (hopefully) simplify testing/reporting/troubleshooting.

I also have another 98SE system that does use Kext and ROS, but that is secondary and isn't used as much.

- Doug B.

Link to comment
Share on other sites

  • 1 month later...

Hi Jumper, is there maybe a new version coming soon ??
Not that I am impatient, actually I love what I can still do with a Kex'ed 98SE, but it would be nice to see higher versions than of Flash still working, etc.
Thx, MiKl

Link to comment
Share on other sites

  • jumper changed the title to KernelEx 4.5 Core Updates (4.5.2016.25)

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...