Jump to content

File unable to be deleted


Recommended Posts



I've unpacked this morning an exe with Universal Extractor (the old version that runs under Win98)

and now I get 2 files named 'Fran_ais.ini' on my desktop that I can't delete.


What I have already done (and is useless):

 - simple Delete -> the files go to the Recycle Bin, but it cannot be emptied with the warning: 'The file is not found'.

 - Shift+Delete -> same thing

 - Reboot -> no difference

 - Rename -> impossible (error 1026)

 - Open the file in Notepad -> The file is not found.

 - Delete from Dos on reboot (with %WINDIR%\WININIT.EXE & WININIT.INI) -> doesn't work (I have tried to delete the file with 'NUL=path' and the folder with 'deltree /y directory')

 - ScanDisk (with Automatically fix errors): SCANDSK.EXE on reboot, SCANDSKW.EXE Standard, and then Thorough -> No error detected


And now? :blushing:  :crazy:

Any help would be greatly appreciated!



System: Win98SE - SP3.0 - KernelEx 4.5.2 (last version) - Revolutions Pack 9.7 (last version)

Edited by CharlesF
Link to comment
Share on other sites

I think I managed to delete similar problem "files" using NDN in the past. http://ndn.muxe.com/


From what I recall it resulted in a damaged containing directory and/or loss of other files in the containing dir after reboot so backup your data before you try this.


And perhaps you can fix the problem with Norton Disk Doctor insted of scandisk if you've got that tool.

Link to comment
Share on other sites

Just a guess, mind you, but the "underscore" in that name may be an "invalid" character.
There are quite a few tricks one can play (at least on NT based system) using those "malformed" names, see (as an example):


I presume that the "original" was Français.ini and *something* in your environment (codepage and/or Unicode and/or *what not*) makes it an invalid character.

Cannot remember if 9x has the /x DIR option :unsure: which would be the "right" way to deal with invalid characters under NT based systems.


Possibly the easiest way is to access with a hex editor the actual directory entry on disk  and change the offending character.


Right now I cannot remember a suitable tool for Win9x usage, but if you cannot find any, just post and I'll have a look in the ol' toolbox for something that may do.



Link to comment
Share on other sites

Hmmm... "Scary" thought, but I played with this before (I have a copy floating around somewhere from an old HDD) -but- it's DOS-oriented.




EDIT! And here is Starman's take on a Disk Editor (appears to be an "upgraded" CP Disk Editor) -


I will -not-swear to it but it -may- be useful -and very dangerous-!!!

(note I found my Norton Utilities disk for Win95, so mine is "in between" the one that the above link talks about.)

Edited by submix8c
Link to comment
Share on other sites

Maybe "Delete Doctor" by Kevin Solway could help: http://www.theabsolute.net/sware/#deletedr


Delete files that are difficult to delete, such as some files left by viruses and trojans, or files with corrupted file names.  This program can also delete files like the "index.dat" files, which store Internet history, by scheduling them for deletion upon system restart.  Select a file to delete from the built-in file browser or drag a file to the application's icon or window from Window's Explorer.  

(Executable for Win95/98/ME/2000/NT/XP/Vista - Freeware)

- Doug B.

Link to comment
Share on other sites

Thx everybody for your kind help!!  :thumbup   :thumbup   :thumbup


@ loblo: Thank you so much, it has worked instantly! 

So far, no other file lost.   :D


@jaclaz: you're right, I thought also that the error came from a "ç" misunderstood,

that's why I'd tried to rename the file to 'Français' but with without success.


@submix8c &  DougB: thanks for the links. I keep them!!

I have tried another one called Dr Delete, uploaded here FWIW: Dr.Delete.rar

but without success this time.


@TmEE: I'd tried to delete the ini file in true DOS after reboot, which should be more powerful.

Link to comment
Share on other sites

@ loblo: Thank you so much, it has worked instantly! 

So far, no other file lost.   :D


Well it worked instantly for me too but as far as I can recall (as this was a while ago) there were problems in the dir were the undeletable file was after reboot which I had to fix with scandisk so make sure everything is OK after rebooting if you haven't done so yet. Glad it worked anyway.

Link to comment
Share on other sites

Ah, got here too late! I've had that problem myself a few times and everytime I had forgot the right way to fix it, banging my head on the walls. Apparently the easy way to do it is:

- open a command prompt in the folder containing the offending file(s)


• run a DIR /P command (in case there are too many files in the folder it will display a page at a time)

• find the offending file(s)' SHORT name(s) in the list (cancel listing with CTRL-C if needed)

or b:

• right-click the offending file(s), select Properties and get the MS-DOS name (if present)

- run DEL with those short names in the command prompt window.


It should work without problems. Just make sure you don't get the wrong name(s), because they can be very similar.

Link to comment
Share on other sites

:doh: <= new emoticon?

"Theoretically" that should (normally) work -unless- the long-name is (e.g.) already 8.3 and the short-name is currupted as well. (note that there are actually TWO entries AFAICR for LFN support.)

Link to comment
Share on other sites

I don't think the short name can be corrupted so easily (if at all).

The FAT structure is somewhat strange but it has its well-defined structure. Incidentally I stumbled into this recently when following a hardware crash I found myself with 945 stray files that chkdsk (on XP) converted to .chk. In my desperate attempts to restore the files (I'm building a rescue utility for this) I had to deal with FAT file name structure. The long file name has a CRC that has to match the short name and if that fails there's no tell what Scandisk/Chkdisk may do to those files.


P.S. You mean this one? 40.gif

Edited by Drugwash
Link to comment
Share on other sites

This? (not sure how accurate, but -appears- to be...)


Bear in mind, a badly written Installer -or trojan/virus/whatever- could (theoretically) screw up a directory entry regardless.


In this case we can "assume" that the OP simply has used something that is not suited to their CodePage/Language (?) thus the "weird" characters.


(40.gif- need a whole bunch of emoticon links - anyone up to making a list?)

edit -

emoticons - get the link to image above, start with "1.gif", up to "79.gif"...

guess you just have to "browse"? 30.gif <= me sometimes.

Edited by submix8c
Link to comment
Share on other sites

There is very little "strange" in a FAT structure, it is by now well documented and with the help of a hex/disk editor it can be navigated rather easily.

As a matter of fact Français.ini is an 8.3 name, only with one character not in the "plain" ASCII 7-bit.


And - at least in my XP, the "Short Name" for Français.ini is - curiously enough :) - FRANC€AIS.INI (in the sense that hex character 80 is used).


The c with cedilla may be a 231 i.e. E7 or 00E7 in UNicode and could be rendered as "pi", see:


but when it comes to special characters and codepages *anything* is really possible, in CP1252 the c with sedilla is also  231 i.e. E7 but it may have been a C with cedilla which would be 199 aka C7, on codepage (say) OEM 850 and on 852 they become  135/87 and 128/80 (same as ASCII extended).


On second thought, though I have never used it under 9x/Me, the DMDE (which I like a lot on NT based systems) would be a tool that can easily "find" the actual sector to correct (directory entry), and I have no reason to doubt it can do the same on 9x/Me:



It is not particularly difficult to use, but if you are not familiar with it it may take som etime to get used to it.

Basically you access the logicaldrive, set the Editor to "Root Directory" (ALT+R), set the mode to FAT directory (F4), if needed, then in the lower left panel you navigate your directory tree (directories are the ones with the > sign) until you find the file entry, then select it and set the mode to hexadecimal (F2).

Then you toggle  to "edit mode"  Edit->Edit Mode or ALT+E and proceed to change the "offending byte" (twice, one for the long and one for the short filename)



Link to comment
Share on other sites

I stand corrected. Sometimes the short name may not help in this situation. I've just tested by creating a folder called test•2 (note the bullet character) and it appears as TEST2 in DOS, however it cannot be deleted - neither from Windows (directly or DOS prompt) nor from true DOS.


Funny thing is I proceeded creating a second folder with the very same name and it got created, exactly as before, so now there's two identically named folders in the same location, both of them with the same Long File name and same DOS short name and both undeletable! Oh man, I've been asking for trouble!


Now, on to fixing it. Back to Windows, ran a Scandisk on that drive. Found errors, fixed them automatically. In the respective folder, one of the test names got changed to TEST-2 in both Long File Name and DOS short name. I could delete that one right away.

The other one was changed to TEST[]2 (actually there's an unprintable character in there) in LFN while short name is still TEST2. But still can't be opened or deleted.


Ran Scandisk once more on that drive, after deleting first fixed folder. Again found errors, again fixed them. But last folder's name wasn't changed this time and is still undeletable.


Opened a file manager on a XP machine and looked at that folder over the network. Long name appears as TEST•2, so XP recognizes the bullet character correctly while 98SE shows it as a blank nonprintable character. But not even XP can delete it over the network (no problems with permissions).


Last chance: back to true DOS, ran a DOS scandisk. Stumbled into that folder, told me it's invalid (funninest thing is, the name looked correct in true DOS!), blah-blah. Offered to fix it, accepted:

1 invalid directory entry was removed

1 lost cluster was saved as a file


Back to Windows, the offending folder is no more (obviously). The saved cluster is empty, as the folder had nothing in it. I'm not sure what would have happened if there were files/subfolders in there, but I really don't wanna test that scenario as I already wasted a lot of time with this. Bottom line is, when Windows fails, true DOS comes to rescue. One way or another, problem gets solved. :)


Now back to more important stuff. ;)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...