Jump to content


bigmuscle
 Share

Recommended Posts

1) The SearchIndexer.exe proces crashes after every reboot once, but then it auto-restarts and works OK until next reboot.

PopisCesta k chybující aplikaci:	C:\Windows\System32\SearchIndexer.exePodpis problémuNázev události problému:	APPCRASHNázev aplikace:	SearchIndexer.exeVerze aplikace:	7.0.9600.16384Časové razítko aplikace:	5215d4c4Název chybného modulu:	MSSRCH.DLLVerze chybného modulu:	7.0.9600.16384Časové razítko chybného modulu:	5215d425Kód výjimky:	c0000005Posun výjimky:	0000000000006dbeVerze operačního systému:	6.3.9600.2.0.0.256.4ID národního prostředí:	1029Další informace 1:	6d41Další informace 2:	6d41e4396d81642d19366c6551ed1668Další informace 3:	e03aDalší informace 4:	e03a041bd62db5852c187261b2519512Další informace o tomto problémuID sady:	e25ae552d453d49eddf5ca482dea705d (125837385)

generate a crash dump:

https://www.dropbox.com/s/5ghwoscdk8lbxxu/WER_SearchIndexer_full.reg

zip and upload the dumps.

After you've generated the dumps use this reg file to stop the AppVerifier and dump creation:

https://www.dropbox.com/s/7gw5dhg6z2cw8l5/WER_SearchIndexer_full_uninstall.reg

Link to comment
Share on other sites


AppInit_DLLs method works, I tested and there is no reason why it should not, because the "blocking" check which causes the problems on some localized systems happens in aerohost.exe which is not used in other injection methods.

This is what I have noticed after I did some testing.

When I get "Black box" I see the following (extra lines) in the debug.log

DBGHELP: .\uDWM.pdb - file not foundDBGHELP: .\dll\uDWM.pdb - file not foundDBGHELP: .\symbols\dll\uDWM.pdb - file not foundDBGHELP: udwm - public symbols          C:\AeroGlass\symbols\uDWM.pdb\4588A14F9B8E4824B21524CD279E1EFF2\uDWM.pdbSymbols loaded for udwm.dll as 3 (#0)
And when I get the normal "Aero glass" I don't see the above stuff. Everything else in the log between the two is same.
Then send me your uDWM.dll via PM please. You either have some old version of UDWM or there is some new update. Symbols should normally be needed at this time.

Just...

Hello,

I have installed AG81 (by setup.exe) as registered user in W81x64 and graphically everything works fine, but I need to fix two minor issues with the app:

1) The SearchIndexer.exe proces crashes after every reboot once, but then it auto-restarts and works OK until next reboot.

When AG81 is unistalled, then it no longer crashes.

PopisCesta k chybující aplikaci:	C:\Windows\System32\SearchIndexer.exePodpis problémuNázev události problému:	APPCRASHNázev aplikace:	SearchIndexer.exeVerze aplikace:	7.0.9600.16384Časové razítko aplikace:	5215d4c4Název chybného modulu:	MSSRCH.DLLVerze chybného modulu:	7.0.9600.16384Časové razítko chybného modulu:	5215d425Kód výjimky:	c0000005Posun výjimky:	0000000000006dbeVerze operačního systému:	6.3.9600.2.0.0.256.4ID národního prostředí:	1029Další informace 1:	6d41Další informace 2:	6d41e4396d81642d19366c6551ed1668Další informace 3:	e03aDalší informace 4:	e03a041bd62db5852c187261b2519512Další informace o tomto problémuID sady:	e25ae552d453d49eddf5ca482dea705d (125837385)

I doubt that it can cause crash in totally unrelated application. I just guess that Aero Glass causes that SearchIndexer loads into some corrupted memory part.

2) Windows DWM auto-stores the information about "ColorizationXXX" DWORD value in registry. So here is the feature reguest:

I created "ColorizationXXXInactive" values, but they are fixed, when I switch from one theme to another. It will be nice to have an option (reg key), that for example:

ColorizationColorInactive is 80% of ColorizationColor (called "ColorizationColorRatio") and when theme is switched, then "ColorizationColorInactive" should be updated with "ColorizationColor" (from new theme) * ColorizationColorRatio. Same for blur, and some other ColorizationXXX values.

I do not understand this much. Playing with ColorizationColorBalance and ColorizationColorBalanceInactive does not do what you need?

Link to comment
Share on other sites

@bigmuscle : I'm also having the black box problems! any fix? :blink:

a1in.png

J1Zq1SI.jpg

That is what I get too, I thought I fixed it by editing TextGlowMode but after a restart it was back, I fixed it again by restarting DWM and changing the registry, Not sure what's going on. Maybe it's a race condition? Does it read TextGlowMode from HKLM also or only HKCU?

Link to comment
Share on other sites

Black title in windows appear if I see this error in the log:

CoCreateInstance(CLSID_WICImagingFactory, NULL, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&pImageFactory)) failed with 0x800401F0

It will happen on boot / reboot.

It is cleared if i do a logout / login.

....

Edited by wmn
Link to comment
Share on other sites

MY TextGlowMode settings, working fine. :w00t:

Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000001"CustomThemeAtlas"="C:\\AeroGlass\\win8rtm_glow.png"[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000001"CustomThemeAtlas"="C:\\AeroGlass\\win8rtm_glow.png"
Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000001"CustomThemeAtlas"="C:\\AeroGlass\\win8cp.png"[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000001"CustomThemeAtlas"="C:\\AeroGlass\\win8cp.png"

Info update:

The symbols i am using:

dwm.pdb
dwmcore.pdb
uDWM.pdb

Symbols downloaded using:

http://www.msfn.org/board/topic/163570-aero-glass-for-win81-rtm-rc3/page-16#entry1058721

I have no black box problem.

Info update:

Using the aerohost method, and NOT using a 3rd party theme, just using a themeatlas file.

Info update:

Tested 3rd party theme (Soft8 VS by neiio):

Settings: (working fine)

Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000003"CustomThemeAtlas"=""[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000003"CustomThemeAtlas"=""
Edited by ace2
Link to comment
Share on other sites

No black box problem here either. That part seems to be working fine for me using the aerohost method.

For what it's worth, I'm not trying to use any 3rd party theme, just a themeatlas file.

AGW81DualMon.png

-Noel

Link to comment
Share on other sites

bigmuscle, thanks a lot for the release! I just made another donation to you (not for additional licenses but just to support your development). Hope, you'll delight us with AeroGlass updates and improvements!

P.S. A small question: how to make AeroGlass more "transparent" but keep automatic theme color?

Link to comment
Share on other sites

P.S. A small question: how to make AeroGlass more "transparent" but keep automatic theme color?

You can edit BlurDeviation.

No Blur Example:

Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM]"BlurDeviation"=dword:00000000[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\DWM]"BlurDeviation"=dword:00000000
Link to comment
Share on other sites

Hi all, i have 2 questions...

1) I made a donation when I started to use the software in the beta phase. But a couple days ago I changed most of the hardware of my computer (mobo+cpu+mem). Now after install the windows 8.1 and the aero glass final version its seems that my licence is not valid any more. So... how can a i do to resolve this??

2) There any way to remove the ugly "Aero Glass for Win8.1" letter on the bottom-right side of my desktop??

thx

Link to comment
Share on other sites

@bigmuscle : I'm also having the black box problems! any fix? :blink:

a1in.png

J1Zq1SI.jpg

That is what I get too, I thought I fixed it by editing TextGlowMode but after a restart it was back, I fixed it again by restarting DWM and changing the registry, Not sure what's going on. Maybe it's a race condition? Does it read TextGlowMode from HKLM also or only HKCU?

:angelsee:

JdVwl4o.png0MmpRZj.png

Link to comment
Share on other sites

Does it read TextGlowMode from HKLM also or only HKCU?

Each settings (except of those intended for HKLM only) is read from HKCU at first. If the value is not found, it falls back to HKLM. This allows specifying each value on per-user and global basis separately. E.g. setting some value in HKCU and HKLM to same value brings no result and only creates redundant data.

Link to comment
Share on other sites

Gentlemen

Am up and running with AeroGlass following a clean install of Windows 8.1 x64 and all is well! Just one question: I've disabled AeroGlass on battery power in the registry but it still seems to be active.

HKLM\Software\Microsoft\Windows\DWM

DisableGlassOnBattery DWORD 0x1

How can I tell if AeroGlass is running via the TaskManager? The DWM.exe process is listed as running via DWM-1 both on AC and battery power. (Injection provided at startup using the registry entry rather than the AeroHost task, which wasn't working for me). The symbols seem to be loading correctly and there are no errors reported in the debug file.

Thanks!

Link to comment
Share on other sites

Info update from Post #190

Uninstalled aerohost method.

Installing DWMGlass.dll using LoadAppInit_DLLs method.

TextGlowMode settings:

Windows Registry Editor Version 5.00[HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000002"CustomThemeAtlas"="C:\\AeroGlass\\win8cp.png"[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\DWM]"TextGlowMode"=dword:00000002"CustomThemeAtlas"="C:\\AeroGlass\\win8cp.png"

Works fine.

TextGlowMode NOTES:

"TextGlowMode"=dword:00000001 Black box problem
"TextGlowMode"=dword:00000002 Works fine
"TextGlowMode"=dword:00000003 No glow

Going back to aerohost method. :w00t:

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...