Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


ppgrainbow

Skype 6.1 on Windows 2000

Recommended Posts

I've just done some testing. The last version of Skype where you can send messages is 5.9.0.123. Sending messages doesn't work starting from versions 5.10.x.x. I've uploaded some of the older Skype versions to my Download Archive (navigate to Programs/Skype). After installing Skype 5.9.0.123 make sure that automatic updates are disabled in its settings.

Just in case here you can find changelog for Skype 5.10.

Edit: This registry entry seems to do the job when it comes to blocking Skype autoupdates:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Skype\Phone]
"DisableVersionCheckPolicy"=dword:00000001

Edited by tomasz86

Share this post


Link to post
Share on other sites

blackwingcat has managed to find a way to run Skype 6.1 and newer in Windows 2000:

http://blog.livedoor.jp/blackwingcat/archives/1759259.html

Unfortunately sending messages doesn't work (yet?) so Skype 5.9.0.123 is still the last fully functional version.

I try to install Exetended kernel v23a and Skype 6.2 in VMWare image which you provided at first.

But It seems no problem to send messages. :ph34r:

Share this post


Link to post
Share on other sites

I try to install Exetended kernel v23a and Skype 6.2 in VMWare image which you provided at first.

But It seems no problem to send messages. :ph34r:

I'm trying to do it right now but still nothing happens when trying to send text (only sending emoticons works). Would it be a problem for you to upload the WMWare image where sending messages work again?

I've managed to make it work in a VM but can't on my desktop. I'll try to do more tests to find out what the problem is about.

Edit: After more testing:

  1. Skype 6.2 works with BWC Kernel v23a but doesn't with UURollup-v11 daily. I don't know yet what the reason is.
  2. There's a problem though. After installing Skype 6.2 using blackwingcat's installer everything seems to work fine... but after reboot system fonts become something like this:
    J55BRKP.jpg
  3. In the blackwingcat's registry file there are these settings:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink]
    "Helvetica"=hex(7):4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,\
    00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,\
    69,00,63,00,00,00,00,00
    "Tahoma"=hex(7):4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,\
    00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,\
    69,00,63,00,00,00,00,00
    "Arial"=hex(7):4c,00,5f,00,31,00,30,00,36,00,34,00,36,00,2e,00,54,00,54,00,46,\
    00,00,00,4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,00,\
    43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,69,\
    00,63,00,00,00,00,00
    "MS Sans Serif"=hex(7):4c,00,5f,00,31,00,30,00,36,00,34,00,36,00,2e,00,54,00,\
    54,00,46,00,00,00,4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,\
    00,54,00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,\
    68,00,69,00,63,00,00,00,00,00
    "Marlett"=hex(7):4c,00,5f,00,31,00,30,00,36,00,34,00,36,00,2e,00,54,00,54,00,\
    46,00,00,00,4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,\
    00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,\
    69,00,63,00,00,00,00,00
    "Microsoft Sans Serif"=hex(7):4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,\
    2e,00,54,00,54,00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,\
    00,74,00,68,00,69,00,63,00,00,00,00,00


    And after transforming them to INF format:

    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Helvetica",0x10000,"MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Tahoma",0x10000,"MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Arial",0x10000,"L_10646.TTF","MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","MS Sans Serif",0x10000,"L_10646.TTF","MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Marlett",0x10000,"L_10646.TTF","MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Microsoft Sans Serif",0x10000,"MSGOTHIC.TTC,MS UI Gothic"


  4. I installed Skype 6.2 once again but this time without these font related keys... and fonts are fine after reboot and Skype itself also seems to work! What are the above font settings required for? :unsure:

Edited by tomasz86

Share this post


Link to post
Share on other sites

I've managed to make it work in a VM but can't on my desktop. I'll try to do more tests to find out what the problem is about.

Normaliz.dll was the culprit in case of UURollup (more info here).

Edited by tomasz86

Share this post


Link to post
Share on other sites

FontLink Setting is for Japanese one.

You can recover registry from %systemroot%\repair\system

Load Hive and Export it.

or Install Japanese setting.

I try to install Exetended kernel v23a and Skype 6.2 in VMWare image which you provided at first.

But It seems no problem to send messages. :ph34r:

I'm trying to do it right now but still nothing happens when trying to send text (only sending emoticons works). Would it be a problem for you to upload the WMWare image where sending messages work again?

I've managed to make it work in a VM but can't on my desktop. I'll try to do more tests to find out what the problem is about.

Edit: After more testing:

  1. Skype 6.2 works with BWC Kernel v23a but doesn't with UURollup-v11 daily. I don't know yet what the reason is.
  2. There's a problem though. After installing Skype 6.2 using blackwingcat's installer everything seems to work fine... but after reboot system fonts become something like this:
    J55BRKP.jpg
  3. In the blackwingcat's registry file there are these settings:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink]
    "Helvetica"=hex(7):4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,\
    00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,\
    69,00,63,00,00,00,00,00
    "Tahoma"=hex(7):4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,\
    00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,\
    69,00,63,00,00,00,00,00
    "Arial"=hex(7):4c,00,5f,00,31,00,30,00,36,00,34,00,36,00,2e,00,54,00,54,00,46,\
    00,00,00,4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,00,\
    43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,69,\
    00,63,00,00,00,00,00
    "MS Sans Serif"=hex(7):4c,00,5f,00,31,00,30,00,36,00,34,00,36,00,2e,00,54,00,\
    54,00,46,00,00,00,4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,\
    00,54,00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,\
    68,00,69,00,63,00,00,00,00,00
    "Marlett"=hex(7):4c,00,5f,00,31,00,30,00,36,00,34,00,36,00,2e,00,54,00,54,00,\
    46,00,00,00,4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,2e,00,54,00,54,\
    00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,00,74,00,68,00,\
    69,00,63,00,00,00,00,00
    "Microsoft Sans Serif"=hex(7):4d,00,53,00,47,00,4f,00,54,00,48,00,49,00,43,00,\
    2e,00,54,00,54,00,43,00,2c,00,4d,00,53,00,20,00,55,00,49,00,20,00,47,00,6f,\
    00,74,00,68,00,69,00,63,00,00,00,00,00


    And after transforming them to INF format:

    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Helvetica",0x10000,"MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Tahoma",0x10000,"MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Arial",0x10000,"L_10646.TTF","MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","MS Sans Serif",0x10000,"L_10646.TTF","MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Marlett",0x10000,"L_10646.TTF","MSGOTHIC.TTC,MS UI Gothic"
    HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink","Microsoft Sans Serif",0x10000,"MSGOTHIC.TTC,MS UI Gothic"


  4. I installed Skype 6.2 once again but this time without these font related keys... and fonts are fine after reboot and Skype itself also seems to work! What are the above font settings required for? :unsure:

Edited by blackwingcat

Share this post


Link to post
Share on other sites

Skype 6.9 and 6.10 on Windows 2000 crashes when its logon sequence.

It seems call "jmp [edx] (edx=0x00000204)."

How do I catch this exception (I want to know this call address.)?. Are there any ideas?

Edited by blackwingcat

Share this post


Link to post
Share on other sites

Skype 6.9/6.10 seem to require Windows XP Service Pack 3, and it seems to me an error I had when it was installed on Service Pack 2, it was related to CPU info or something like that. I doubt that answers your question but I think it might help you get started. All I know is the newest Skype versions will NOT work on Windows XP Service Pack 2 and below.

Share this post


Link to post
Share on other sites

Time to dig this up since it affects us Windows 2000 users to a degree. Tomasz86's version works for now...but what do we do after this deadline hits? The newest version will install, but calls cannot be made nor can files be sent since I just tested it out tonight. I don't know how long we have but this is not good news for us.

Share this post


Link to post
Share on other sites

Do you know what's the oldest Skype version to work in Windows 2000 at the moment?

Last time I checked, the old Skype 4.2 was still working fine.

Share this post


Link to post
Share on other sites

Do you know what's the oldest Skype version to work in Windows 2000 at the moment?

Last time I checked, the old Skype 4.2 was still working fine.

I'm using the latest one you have on your site so far, which is 6.3.32.105 but even that is giving me the 'your skype will retire soon' message. The reason I brought this up is I had version 5 something on my machine and it signed me out saying it was too old and would no longer work until I upgraded.

Share this post


Link to post
Share on other sites

You were right. This is what happens when trying to log in with Skype 4.2 in Windows 2000 <_<

 

MnwztNX.png

 

Using Application Compatibility Launcher to run it in XP SP3 mode doesn't help as Skype just crashes then.

Share this post


Link to post
Share on other sites

I use 5.2 on XP SP3, and it remains working OK. So the problem is just another MS device to force people to upgrade.

I wonder whether there may be a way to by-pass it or not...

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...