Jump to content

Start Is Back - 2.1 release


Recommended Posts


zip and upload the 4 files that show up under "files that help describe the problem"

Sorry I haven't replied sooner. I haven't used my computer much the last month and haven't shut it down at all, so no crashes. But today, I finally did a restart after installing some Windows Updates and it happened again. The error report was slightly different:

4yrv6c1.png

Here are the four "files that help describe the problem": http://www.mediafire.com/download/v9h311ptyeemnbu/ExplorerCrash.zip

Thanks for any help you can give me with diagnosing this crash.

Link to post
Share on other sites

The crash is caused by some bug in Games folder Parental control Ratings system (sic!).

Wpc!CRatingSystemCache::GetRatingSystem+0x97Wpc!CSystemSettings::GetDefaultRatingsSystemForLocale+0x408Wpc!CSystemSettings::GetCurrentRatingsSystem+0x120Wpc!CSystemSettings::GetCurrentRatingsSystemID+0x36Wpc!CGamesSettings::Initialize+0x84Wpc!CWindowsParentalControls::GetGamesSettings+0x85gameux!CGameExplorer::GetGamesSettingsForUser+0x5agameux!CGameExplorer::GetGamesSettingsForCurrentUser+0x59gameux!CGameExplorer::SetupWPC+0xa7gameux!CGameExplorer::GetGameInternal+0xe8gameux!CGameExplorer::GetGame+0x8bgameux!CGameFolder::GetGame+0x3fgameux!CGameFolder::GetPropertyStore+0x34gameux!CGameFolder::BindToObject+0x7cshell32!CShellItem::BindToHandler+0x4ddshell32!CShellItem::_GetPropertyStoreWorker+0x36bshell32!CShellItem::GetPropertyStoreForKeys+0x116SearchFolder!CGrepQuery::_EvaluateItem+0x1086SearchFolder!CRowsetEnumeration::_EnumerateRowset+0x2f1SearchFolder!CRowsetEnumeration::WaitForResults+0x3fSearchFolder!CQueryResultSet::_HandleBatches+0xbdSearchFolder!CQueryResultSet::RealizeResults+0x19f

It's manifested because StartIsBack adds Games folder into search results.

Unfortunately I'm not sure why your Games folder causes crash, nor there is a setting to remove games from search results.

You may delete your games shortcuts from Games folder one by one to find which one is faulty.

Or you can add explorer.exe into DEP exclusion list.

Edited by Tihiy
Link to post
Share on other sites

The crash is caused by some bug in Games folder Parental control Ratings system (sic!).

Wpc!CRatingSystemCache::GetRatingSystem+0x97Wpc!CSystemSettings::GetDefaultRatingsSystemForLocale+0x408Wpc!CSystemSettings::GetCurrentRatingsSystem+0x120Wpc!CSystemSettings::GetCurrentRatingsSystemID+0x36Wpc!CGamesSettings::Initialize+0x84Wpc!CWindowsParentalControls::GetGamesSettings+0x85gameux!CGameExplorer::GetGamesSettingsForUser+0x5agameux!CGameExplorer::GetGamesSettingsForCurrentUser+0x59gameux!CGameExplorer::SetupWPC+0xa7gameux!CGameExplorer::GetGameInternal+0xe8gameux!CGameExplorer::GetGame+0x8bgameux!CGameFolder::GetGame+0x3fgameux!CGameFolder::GetPropertyStore+0x34gameux!CGameFolder::BindToObject+0x7cshell32!CShellItem::BindToHandler+0x4ddshell32!CShellItem::_GetPropertyStoreWorker+0x36bshell32!CShellItem::GetPropertyStoreForKeys+0x116SearchFolder!CGrepQuery::_EvaluateItem+0x1086SearchFolder!CRowsetEnumeration::_EnumerateRowset+0x2f1SearchFolder!CRowsetEnumeration::WaitForResults+0x3fSearchFolder!CQueryResultSet::_HandleBatches+0xbdSearchFolder!CQueryResultSet::RealizeResults+0x19f

It's manifested because StartIsBack adds Games folder into search results.

Unfortunately I'm not sure why your Games folder causes crash, nor there is a setting to remove games from search results.

You may delete your games shortcuts from Games folder one by one to find which one is faulty.

Or you can add explorer.exe into DEP exclusion list.

Thanks for the prompt reply! So you're saying that the crashes will stop if I add Explorer.exe as a DEP exception here:

fwGFZOo.png

No need to delete Games folder shortcuts one-by-one to find the culprit if I do the above, correct?

Link to post
Share on other sites

this is a 64bit explorer, which can't be added there.

have you calculated the Experience score? Try to remove the games The Witcher 2 - Assassins of Kings Enhanced Edition and HL2. Those are the 2 last strings I see in the stack while the crash happens. Maybe one of the tool has an incorrect WEI score requirement which causes the crash.

Link to post
Share on other sites

Thanks for the heads-up regarding 64-bit Explorer. I have run WEI already. So now I should try removing those two games you mentioned. Is it simply a matter of right-clicking and selecting "Hide This Game?"

IFERT4T.png

VQLpIA7.png

Edited by octiceps
Link to post
Share on other sites

Also, I'm not sure what you mean by this:

Maybe one of the tool has an incorrect WEI score requirement which causes the crash.

Because neither Witcher 2 nor the two Half-Life 2 games show a WEI score requirement in Games Explorer. The only two games which show it are Battlefield 3 and Battlefield 4 Beta.

q4irS7D.png

B0NM9e1.png

Edited by octiceps
Link to post
Share on other sites

Have you tried to hide them? Does this fix it?

Yes I've hidden them. Now it's just a waiting game to see if the crash happens again. It always happens the same way every time, basically when I enter a search term in the Start Menu after boot. But it's random in that it doesn't happen after every reboot, just some of them. I wonder if you or Tihiy could shed some light on why it's random like this.

Link to post
Share on other sites

Hi there,

Have installed and purchased StartisBack+ for my Windows 8.1 x64 machine, however setting the custom start button icon only works on my main screen - the additional monitor task menu start button still shows the default - any way to set it same for both screens?

Thankspost-382816-0-59515400-1381807188_thumb.

Link to post
Share on other sites

Hi there,

Have installed and purchased StartisBack+ for my Windows 8.1 x64 machine, however setting the custom start button icon only works on my main screen - the additional monitor task menu start button still shows the default - any way to set it same for both screens?

That means you have enabled 'All screen corners are active on secondary monitors'.

Link to post
Share on other sites

When I press super key, start menu opens on the screen where the last active window was. I can't find a way to force it to always open on the main screen without removing taskbar from the secondary screen. Please add an option to do that.

Edited by Dissentient
Link to post
Share on other sites

When I press super key, start menu opens on the screen where the last active window was. I can't find a way to force it to always open on the main screen without removing taskbar from the secondary screen. Please add an option to do that.

You can check the SIB+ option 'Enable on corners on secondary screens'. That will make secondary monitors have standard Start button and open start menu on primary monitor only.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...