Jump to content

Resurrecting a 1999-Vintage Win98SE Machine


Recommended Posts

Inside windows, open regedit and navigate to HKLM\Software\Microsoft\Windows\CurrentVersion\Detect, and then add as a new dword value:


Close regedit and shut down the machine.

Turn it on again, and go into BIOS, and change all of the followng settngs as indcated:


Anti-Virus Protection: Disabled


Memory Hole at 15M-16M: Disabled


ACPI Function: Disabled

PM Control by APM: Yes


PNP OS Installed: No

Resources Controlled By: Manual

Reset Configuration Data: Enabled (it'll disable itself after ONE reboot)

Assign IRQ for USB: Disabled


Let windows boot into safe mode and remove all USB-related items, then reboot normally and let windos redetect them all.

Let us know the outcome. Good luck!

Well the system is screwed up, big time. I'm going to reinstall Win98 trying disabling ACPI during installation with setup /c i setup /p i .

Edited by TELVM
Link to comment
Share on other sites

Since you decided to reinstall, you have nothing to lose in trying the following before going ahead with the reinstallation. So, please, do try rebooting and letting windows start (as far as it manages to) then shutting it down (unless it hangs/freezes, when a reset is needed) two or three times in a row. The system may manage to fix itself enough for us to go on. If not, then reinstall without ACPI, and give it the manufacturer's drivers and VIA's USB drivers, but do not install NUSB for the moment.

BTW, it is

Setup /p i


Setup /c i

Link to comment
Share on other sites

Thanks a lot for your help and patience Dencorso. The system went too FUBAR :wacko: , better to start afresh. I'm reinstalling as per your last instructions.

Link to comment
Share on other sites

Sadly it was not possible to install Win98SE with 'setup /p i' to disable ACPI in this comp. After entering the command installation began, but always froze and hung some seconds later. I had to reinstall with ACPI enabled.

If the problem is conflict from ACPI and USB controllers sharing the same IRQs, how about disabling some non-used devices (joystick, COM, printer ports) to free IRQs, then reassign so that no IRQ is shared by ACPI and USB?

Link to comment
Share on other sites

At last! Halleluyah! Got USB 2.0 pendrives working with the dino! :thumbup :thumbup:thumbup 

Out of desperation I started changing many things almost aleatorially, and by pure serendipity this is the winner combination:

- USB 2.0 PCI card moved to slot 3 (center one of the five).

- Installed Spanish version of NUSB 3.3, then installed VIA drivers for VT6202 USB 2.0 PCI Card.

- Under Device Manager - USB, disabled Universal Host Controller Intel 82371AB/EB PCI to USB.

- In Device Manager - System Devices - PCI Bus - IRQ Control ...


... leave only 'Get IRQ Table using MS specification table' ticked.


· ACPI: Enabled

· Power Control by APM: Yes

· PNP OS Installed: Yes

· Resources Controlled by: Auto

· Reset Configuration Data: Disabled

· Assign IRQ for VGA: Yes

· Assign IRQ for USB: Yes

· PCI Latency Timer: 32 PCI Clocks

· Slots 1 to 4 Use IRQ: Auto

· USB Keyboard Support: Disabled

Link to comment
Share on other sites

Congratulations! clapping.gif

BTW, since you now can connect pendrives at USB 2.0 speed, this is a great moment for acquiring a full-disk image as a backup, so that you'll never again need to install from scratch.

Link to comment
Share on other sites

I'm now having some trouble trying to create a 128MB ramdisk using XMSDSK.EXE . I put both the HIMEMX.EXE and XMSDSK.EXE files in C:\Windows , and added these two lines to the top of CONFIG.SYS:



But for some reason the comp just freezes while initializing it :huh: .

(If I REMark the ramdisk line, HIMEMX.EXE loads OK)

And now gentlemen time for some laughs :lol: .

A bit of retro benchmarking, just for fun:



Behold my highly sophisticated astronautics-grade PII cooling solution :D :


Works like a charm however, keeping the Deschutes 350/100 overclocked to 434/124 quite cool:


Link to comment
Share on other sites

Forget HIMEMX.EXE. You don't need it at all, with 768 MiB RAM. Use MS HIMEM.SYS instead.

But you do need to add both to system.ini and system.cb a [VCache] section having a single setting:

MaxFileCache=114688 ; 112 MiB

Then I think your XMSDSK will load OK. Let me know how it goes.

PS: Loved your cooling solution! :thumbup

Link to comment
Share on other sites

No joy man, system keeps crashing on startup.

However something bizarre: Starting up step by step I observe the line with xmsdsk.exe passes OK; then, some lines later, the crashing comes after some mouse related line :blink: .

But if I REMark the ramdisk line, comp starts OK and mouse works OK :wacko: .

Could it be that XMSDSK.EXE is conflicting somehow with the mouse?

Link to comment
Share on other sites

Sure, here they go: Dino System Files

Got another little drawback, I made two FAT32 partitions in the HDD, the first 32GB one for Win98SE and a second 80GB one for future WinXP. Problem is, these partitions are now named C: and D:, and the CD/DVD driver was displaced to letter E: . That's not good, some old games only work fine if CD driver is D: .

There is any way to switch letters so that 80GB HDD partition is E:, and CD/DVD is D: again?

Were that not possible, can we 'hide' or 'deactivate' somehow the 80GB partition for Win98SE eyes only, so that ignores it, doesn't assign letter, and gives letter D: directly to the CD/DVD?

Dino System Files.zip

Link to comment
Share on other sites

About system freezing when connecting USB drive to USB 1.x port - may be that occurred because Windows 98 needs to read FAT table and freezes until the FAT table is read completely. USB 1.x has low speed and reading FAT can take some time. I had the same issue. My 320 GB USB HDD freezes my system for more than 3.5 minutes. My 4 GB flash drive freezes my system for 3-4 seconds. However after this time span system works OK and I can read/write files on my USB drives. I have USB 1.1 ports. I have tried many things - rebooting, reinstalling NUSB, etc. - before I learned that I need just to wait for a few minutes. USB 2.0 is much faster, so FAT table is read almost instantly with it.

Link to comment
Share on other sites

@ Jaclaz: Thanks a lot for the link to Letter Assigner, it's exactly what was needed and works like a charm :thumbup . Also for the grammar lesson :D .

@M()zart: Thanks for your advice, USB 2.0 runs fine now in the dino and pendrives are recognized instantly. Seems it was some IRQ/drivers conflict, now solved.

Link to comment
Share on other sites

You said it crashes DOS. I doubt it. I think it crashes Windows. Let's see who's right.

Set BootGUI=0 and Logo=0 in MSDOS.SYS, and try to boot substituting your current config.sys by the one attached.

If you get to the DOS prompt without a crash, do a DIR command to make sure dos is working, then do a WIN command, for Windows to load.

If it crashes only after the WIN command, pay attention to any message that it may flash and report it, or tell us there's no message at all.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...