Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

WinNTSetup v4.6.0

Recommended Posts

Hmm, no I use diskpart.exe and that decides between the 2 by extension.

But I wonder that there is a problem with attaching them.

Link to post
Share on other sites

For easy testing of the VHDXs that diskmgmt creates, can drag a shortcut of W:\Windows\System32\diskmgmt.msc to desktop.

See the diskmgmt "Action" menu.

Hope that helps.


diskmgmt might attach the VHDX when it is created and that error might be from trying to attach a VHDX that is already attached.

Don't see a way to detach the VHDX via diskmgmt.

Sorry if that confused things.

Edited by RUSerious
Link to post
Share on other sites

You right, it gives this "wrong paramter" error if the vdisk is already attached or detached.


I uploaded new version, that should fix the gui not want to create a vhdx.

Link to post
Share on other sites

JFX, hope you don't mind me asking a somewhat off-topic question: Do you know if there's a way to tell which DISM versions are compatible? For example: sometimes when I test a new Windows 10 preview build, I want to add NetFX3 and some drivers to the install.wim before first install (also: convert to Enterprise using SetEdition). But sometimes (other/new build) I get an error saying I need a newer DISM version. Other times it does work (like now: 10036 can service the 10041 install.wim just fine).


I don't want to take up a lot of your time, but I guessed you might know this. So once again: How can I know if I can service a *new* install.wim with an "old" DISM. Or is it just trial and error? Thanks!


(On the MDL forum, some friendly people explained how to extract the new DISM files from a new ISO, or even from an ESD, using wimlib and image 1 of the wim [instead of 4 for the install files]. Haven't tested that, though...)

Edited by Atari800XL
Link to post
Share on other sites

Well, it's a technical preview, they can brake or change functionality with every build as they like.

So no, there is no way to tell.

  • Upvote 1
Link to post
Share on other sites

There was indeed a problem with user creating using, but only using x86 exe.


Switching off system restore works, on vista and later quota is set to 0.

It's not so easy to fully disable it on nt6, I wanted to address this with a service like I did with password reset.


But that resulted in to many false positive AV reports.

Edited by JFX
Link to post
Share on other sites
Firstly, thank you very much for WinNTsetup and your other useful tools.
Secondly, I'm sorry my bad English.
I have a issue (and later request, if it's possible).
At first, I will writing the issue:
I can install Windows 7~10TP Build 9876 to my 2nd HDD with WinNTsetup. But since Win10TP's build 9926 and 10041, it's become strange. In that, after cyan logo/boot phase is disappeared, the PC alway restart. No start sysprep phase, no setup/OOBE settings/desktop. I tried almost every ways for solution: using wimlib instead of wimGapi, BCD parameters, tweaks service/drivers in Reg hives, what not. No change. :(

Also I tried another way without WinNTsetup. Extracting Install.wim with WimLib.
wimlib-imagex.exe extract install.wim 1 --dest-dir=e:\bootsect.exe /nt60 e: /mbr /forcebcdboot e:\windows /s e:

No change. No BSOD, no any dump or log file. Again, after logo, PC is restarting cycle.

Finally, I tried Windows' own Setup phases (directly running original Setup on ISO). The Windows Setup (Boot.WIM Image:2) can install normal way. After install progress is finished, PC restart. Okay. After logo is loading, the white OOBE/sysprep phase is coming. No reset loop. I very suprised that. 

What is make settings Windows Setup, besides of bootsect, BCDboot? I just can't detect. :)
Edited by ilkertezcan
Link to post
Share on other sites
It's hard to find out what original Windows setup actually does.

Maybe it's a BSOD, have you disabled automatic reboot?
Link to post
Share on other sites
  • 2 weeks later...

I just upgraded to 3.7.2 -> 3.7.7 and noticed a new drop-down that appears next to the use bootsect ... drop-down after starting Setup. Some of the options are ALL, BIOS, UEFI, etc. I must have missed the discussion about this. Can someone explain what those options are for and what changes they make?

Edited by click-click
Link to post
Share on other sites

hi to all. I'm new on this forum but i'm a Computer technician

first of all thanks to JFX for this great tool.


My problem make me crazy... so if you can help me...


i've a winPE 8 with bootice and winntsetup, when i try to setup a Windows7 ultimate 64 in a virtualbox machine, the setup cant continue due ^ Windows could not update the computer's boot configuration "

same on a dell with Uefi bios ( same wim image on a regular dvd make the trick ) the setup from the same source but in the traditional way ( mounted iso of win7 setup ) works

i've made 10000000000 reinstallation with every combination of winntsetup optition... but without success...

can anyone help me


sorry for my bad english

Edited by Lordk1
Link to post
Share on other sites

thanks for the fast reply.

i've made a virtualbox Virtual Machine vith 25Gb Hard drive and two CD.

the boot order:

 1 Win8PEx64.iso

 2 Windows7x64.iso

 3 Sata virtual HD


the VM boot regular and Windows8PE works. then i make partition on the hd with BOOTICE ( 100Mb NTFS Active and Boot for reserved and 24900Mb NTFS for the Sys )

after that on winntsetup after select the wim i specify the boot drive ( c:\ 100mb ntfs ) and all icons went green

after that select the system drive ( d:\ )

click setup and on the next screen i leaved all on default.


after the first reboot, the VM boot regular on virtual hard drive and the setup start. after few minutes the error popup.


that's all


i've tried with another wim x86 but the resul is the same

Link to post
Share on other sites
  • JFX changed the title to WinNTSetup v4.6.0

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...