Jump to content

latest VLC player no longer works


Recommended Posts

For some reason, ffdshow is extremely choppy on my system. I've tried a few of the latest releases from free-codecs.com - all MMX versions and they all exhibited strong video lags accompanied with choppy sound. I had to completely uninstall ffdshow.

Now I only have XVid 1.1.3 and DivX 5.2.1 which work pretty decently with BSPlayer Pro.

Link to comment
Share on other sites

I have no technical knowledge of VLC however 0.8.6d had broken unicode support. Actually wxWidgets from 0.8.6d had broken unicode support in one of it's libraries (resulting in missing text from menus and windows in some languages although translations were complete). They probably overdid it somehow. And from what i've heard is that 0.9 will completely scrap wxWidgets so that's why it probably works without problems.

Link to comment
Share on other sites

  • 4 weeks later...
- Subtitles support?

- Incomplete/damaged files support?

- Codecs/Filters exception list? (anyone else having crashes in GTCODEC.DLL installed/used by webcam?)

- User-friendly, rich-featured playlist?

- Low on resources on low-end machines?

Which of the above-mentioned players can do all these and still be free(ware)/open-source?

MPlayer with its very powerful frontend SMPlayer. Unfortunately it wouldn't seek through videos, at least on my machine. Maybe you'll be a bit luckier.

Link to comment
Share on other sites

Nope, sorry. Could be KernelEx interfering, but the above combination didn't work right and crashed on exit. Qt has issues in Win9x. I'll stick to BSPlayer 2.27 for now, which is working OK for my slow machine.

Link to comment
Share on other sites

  • 3 months later...

Well, after a nice run with 0.8.6f, VideoLAN has killed wxWidgets again in 9x...

I just tried 0.8.6h, and it fails with the classic 0.8.6e error:

wxWidgets Fatal Error

This program uses Unicode and requires Windows NT/2000/XP.

Program aborted.

So, I tried the libwxwidgets_plugin.dll fix by copying the file from the working 0.8.6f...

Now it starts, but when I try to play a video, it fails:

VLC has caused an invalid page fault in module liblinear_resampler_plugin.dll at 017f:6a5018aa

Guess I'm going back to 0.8.6f...

BTW, 0.8.6f can still be downloaded from:



0.8.6h works fine (with the 0.8.6f widgets plugin) with most files.

It just so happened that I tested it on a recently downloaded file.

The file was an Apple QuickTime trailer with 5.1 audio.

I used to be able to play these 5.1 trailers but with audio problems.

(See here: http://www.msfn.org/board/VLC-media-player...ve-t115798.html)

However, now it appears that they will not play for me at all...

I tried 0.8.6c, 0.8.6f, and 0.8.6h, all with the same page fault.

QuickTime Trailers with stereo work with no problem.

I tried all sorts to play without error... Removing new software, changing Windows settings, and so on.

Summary: 0.8.6h works with the wxWidgets file from 0.8.6f, however 5.1 audio playback in QuickTime 7 files may be problematic...

UPDATE - Problem Solved!

I had deselected the High quality audio resampling option to improve playback of HD QuickTime videos...

It appears now that the 'low quality' resampling fails on 9x with 5.1 audio...

With this re-enabled, all is fine!

And... since I can play 5.1 audio, I have also discovered that VLC player 0.8.6h has actually fixed my 5.1 audio problems. :thumbup

See here: http://www.msfn.org/board/VLC-media-player...529#entry778529

Edited by RetroOS
Link to comment
Share on other sites

My usual video player for Win9x is Crystal Player 1.85 (older version). It's lacking some features and has a few annoyances, but overall I find it the most comfortable (after changing the default skin :).

Some random points:


* Better at handling maxed CPU (that's why I switched to using it from RadLight 3).

* On-the-fly switching of rendering mode (Overlay, VMR, etc.)

* Nice built-in subtitles rendering (*.sub has some issues though).

* Shift subtitles sync with hotkeys.

* Dropped frames stats.


* Troublesome seeking.

* Doesn't support >2GB files.

* Audio shifting increments a bit too coarse (100ms).

Edited by shae
Link to comment
Share on other sites

  • 2 months later...

Version 0.9.2 was released and is incompatible with Win9x.

Latest packages (0.9.2)

This release only supports Windows 2000 and later

It's possible to install it but when you're trying to run it, you get a message about missing exports with one of the libraries.

Version 0.8.6i works without any problem (at least on my computer).

Windows 95/98/Me

VLC 0.8.6 is the latest release with support for this operating system.

Btw, one more thing:

Warning: The following package is not up-to-date with the latest official version of the software. When using an out-of-date version, you may encounter important bugs or security holes. If you wish to use the latest version of the software, you may need to download source code and compile the software manually, or wait for someone else to do it.
Edited by rainyd
Link to comment
Share on other sites

  • 2 weeks later...

I can confirm that 0.8.6i works fine.

When I try 0.9.2, it starts to run and then nothing.

I find a hidden vlc task that appears to have hung.

I have KernelEx 0.3.5b (Tihiy's update) installed and this may be why I don't get the missing exports error...

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...