Jump to content

Vistapack 2.4 Released


damian666
 Share

Recommended Posts

About fix for the clock.

Maybe mod 10.bmp to be an alpha bitmap with the center transparent. Hopefully then the refreshes won't stick to the pic.

I wish I had time to help but I am heading to the mainland for 4-5 days.

Also, I was thinking that comctl32.dll, 130 and 131.bmps had originally a background of 192,192,192 and this shows transparent. Maybe this color could be used for the new bitmaps background as well.

Link to comment
Share on other sites


bug in the visual style huh, well...

know how to make a visual style?

i dont really, i am glad i got it like that.

btw, its not mine to begin with, i just modded it, and added a basic scheme to it.

so, maybe, maybe not man.

@squeeto, or anyone else, how the hell do i make the bmp transparent without using the magic pink color?

and i will try the color code you suggested ok?

you want to know where the icons are that look like xp ones in the fileopen dialog huh...

well, i dont know, else i had patched them right :blushing:

so please let me know if you find them, all i know is that some programs have their own resources for that, like office does...

and that windows update is a real pesky one man.

it wont change, just for a sec, and then it will re download itself again...

its a crc check i think...

well thanx again man...

damian666

Link to comment
Share on other sites

@squeeto, or anyone else, how the hell do i make the bmp transparent without using the magic pink color?

It doesn't work anyway. See pic.

I made a very crude 32bit bmp with the center transparent. It still displays improperly.

Damian, google "32bit bmp" to get a better idea but simply it is a .bmp with the alpha channel.

post-81494-1201915958_thumb.jpg

Link to comment
Share on other sites

hi squeeto, thanx for the try man, i tried it myself too, but i came to the same conclusion, it looks like s***!!

well, nice try man...

@mara, i found out where to find those xp like icons on the fileopen dialog.

they are stored in the winsxs folder in a folder with controls in the name...

but when i tried to patch it, my pc would not go past the logonscreen..

so i think we should lt it go...

try it if you like, maybe i did something wrong. :)

damian666

Link to comment
Share on other sites

I tried to replace and I done it. Here are the results:

post-127541-1202135286_thumb.jpg

I tested in virtual machine and Windows in that machine has Windows File Protection disabled. Maybe that is problem, or maybe not. Maybe you should try again.

Cheers ;)

Link to comment
Share on other sites

hi guys, thanx for the help.

@mara, i think i f***ed it up or something, but tell me this, which of the 2 did you patch? i have 2 folders in there so...

I will credit you for the help you give man.

and squeeto, i got them man, the arrow is much better on this one , thank you man.

i would credit you, but you are allready in there dude!! from the beginning :D

edit:

i have created a winntbbu for the cd patcher, nice setupscreen .

you will see...

damian666

Link to comment
Share on other sites

EDIT: You were right, I checked the XP CD files (wuaucpl.cpl) and it is patched, but when I installed Windows it seems that got reverted.

I have encountered two bugs related to this in Windows 2000 pack:

- wuacpl.cpl

The icon isn´t patches

The wuaucpl.cpl.txt show this:

[COMMANDS]

-modify "Resources\wuaucpl.cpl\102.ico", ICONGROUP, 102,

but this icon number and ICONGROUP don´t exist in wuaucpl.cpl.The ICON resouce is 1 to 33,and the ICONGROUP is 1 to 5.And in DIR Resources\wuaucpl.cpl only include only 1 icon and this is a generic icon not related to Automatic windows update Vista icons.I dowloaded the Windows XP pack and the wuaucpl.cpl.txt is OK but not the icons 1 and 4.I copied wuaucpl.cpl.txt from XP to 2000 pack and file are patches OK.

-wuauclt.exe

The icon isn´t patches

The wuauclt.exe.txt show this:

[COMMANDS]

-modify "Resources\wuauclt.exe\301.ico", ICONGROUP, 301,

but in this file DON´T EXIST ICON or ICONGROUP Resource.I don´t know if in XP are the same error.At this moment I can´t check it.

Link to comment
Share on other sites

hi guys, thanx for the help.

@mara, i think i f***ed it up or something, but tell me this, which of the 2 did you patch? i have 2 folders in there so...

I have two folders too, and I patched both files without any problems. I used your bitmaps from Vistapack v2.1 and I just replaced it with Resource Hacker. I hope that you will be able to replace it yourself. I will done some test with Windows File Protection Enabled as soon as I have some spare time and I'll post the results.

I will credit you for the help you give man.

Thanks. I like to help.

Cheers ;)

Edited by mara-
Link to comment
Share on other sites

I have installed Vista2000 pack but not patched the system.I only want patch a windows 2000 source(CD or in Hardisk) but the cd patch don´t function.

AutoIt Error:

Line -1:

Error:Unable to execute the external program.

El sistema no puede hallar el archivo especificado(Spanish)="The system cannot find the specified file"(I think?)

Edited by jose_rsh
Link to comment
Share on other sites

ok jose, thanx for reporting.

i will check it out for you man.

workaround is patch the system, and see if it will work then.

let me know if it does ok?

damian666

Well,I´ve patched my system and I´m looking for posible problem or error on patching or in reshacker command,or posible error or differens in icons.I have encountered a few.For example,there are some system files that have only two icons in the same resorce,with the same resolution(16 or 256 or 32 bit) with diferent format(48x48-32x32,48x48-16x16,32x32-16x16,....)and the icon patch have 3 icon´s but with DIFFERENT resolutions(16,256 and 32 bit) in the same format(48x48 or 32x32 or 16x16).When patching the file some resolutions and format disaparens.An example:

ORIGINAL acctres.dll:

Resource ICONGROUP 100(the language isn´t importand at this time)

32 x 32 (16 colors) - Ordinal name: 1

16 x 16 (16 colors) - Ordinal name: 2

ICON File 100.ico in DIR acctres.dll to pacth the system:

32x32 16 colours - ordinal 1

32x32 256 colours - ordinal 2

32x32 32 bit colour - ordinal 3

System file acctres.dll after pacth:

32 x 32 (16 colors) - Ordinal name: 1

32 x 32 (256 colors) - Ordinal name: 2

32 x 32 (16.8mil colors) - Ordinal name: 9

Can you see the differences?The original 16 x 16 (16 colors) - Ordinal name: 2 is ERASED and changed for 32 x 32 (256 colors) - Ordinal name: 2 that is differents in format(32x32) and in colours(256).This is not a problem for the system?The 100.ico file don´t have to have the same ico that is replaced in the same format?

And sorry for my English,I´m from Spain and I don´t know if you can understand me.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...