Jump to content

Vistapack 2.4 Released


damian666
 Share

Recommended Posts


Hi damian666,

I just downloaded the new version and I must tell that it looks great. But I found few bugs on very begin:

#1. rebuilder and vistapack patcher always complain about sysdm.cpl. When I opened Reload-log.txt, I found this:

Patching File: sysdm.cpl
Executing Reshacker
File not found
Reshacker script error

I also opened log of VistaPack patcher (log.txt) and I found same error.

#2. File Open Dialog in same cases still not patched (reported here) and in case when it is, there is problem with transparency with Back button (reported here).

Link to comment
Share on other sites

well, i have been busy with that file open dialog, but i cant seem to get it right.

i think i have to get rid of it :(

now i found it, it tries to patch the 115 dialog, but i only have it in dutch...

go to the resources \sysdm folder and open the apropriate txt file.

delete the last two lines.

run reloader, that should do it.

damian666

P.S. else you could post the reshacker log for me, that way i can see whats wrong, just copy paste it here the sysdm log

Edited by damian666
Link to comment
Share on other sites

or you could try to translate it for me :)

then post it here, and people can use that dialog to replace the ones they have.

if you want to, just open 115.res with reshacker.

i cant compile the new version on my work, so i have to wait till wednesday to fix it myself for you guys.

sorry for that.

or post the sysdm you have so i can do it myself, but only at home

let me know what you want to do, mara.

damian666

Edited by damian666
Link to comment
Share on other sites

I don't know if I understand you correctly but here is the log:

[21 jan 2008, 20:26:49]

[FileNames]
Exe=Backup\sysdm.cpl
SaveAs=NewFiles\sysdm.cpl
Log=Logs\sysdm.cpl-en.log

[Commands]
-addoverwrite "Resources\sysdm.cpl\1.bmp", BITMAP, 1,
Modified: BITMAP,1,1033
-addoverwrite "Resources\sysdm.cpl\1.ico", ICONGROUP, 1,
Modified: ICONGROUP,1,1033
-addoverwrite "Resources\sysdm.cpl\2.bmp", BITMAP, 2,
Modified: BITMAP,2,1033
-addoverwrite "Resources\sysdm.cpl\2.ico", ICONGROUP, 2,
Modified: ICONGROUP,2,1033
-addoverwrite "Resources\sysdm.cpl\3.bmp", BITMAP, 3,
Added: BITMAP,3,0
-addoverwrite "Resources\sysdm.cpl\3.ico", ICONGROUP, 3,
Modified: ICONGROUP,3,1033
-addoverwrite "Resources\sysdm.cpl\6.bmp", BITMAP, 6,
Error: "Resources\sysdm.cpl\6.bmp" does not exist

and here is 115.res translated to English:

115.rar

Also I found one more bug. I used your option Remove logoff text and after I rebooted, Rebuilder complained about explorer.exe, then it did a rebuild and it restored text to start menu buttons. Also bug reported here still exist (third picture), and this one here (first picture).

Cheers ;)

EDIT: Can you tell me in which file is located this Back button of File Open Dialog? I just want to try something.

EDIT2: One more bug:

post-127541-1200932428_thumb.jpg

Edited by mara-
Link to comment
Share on other sites

OK, I think I done something with this Back button, tell me what you think. Here is the screen shot (only back button replaced in dialog):

post-127541-1200944844_thumb.jpg

If you like it, I'll be glad to upload the recourse.

Also I noticed that you done some changes to sysdm.cpl (I applied changes manually) and I sow that you inserted "Windows Experience" picture in advanced tab. My suggestion is that you insert in all tabs this picture. I tried to do this for myself, but it seems that rest of the tabs are not located in this file.

Cheers ;)

Edited by mara-
Link to comment
Share on other sites

ok, cool squeeto, thanx for the report dude.

and how are you dude?

All is Good.

You probably have this but I notice it is missing from your latest pack. This is my English version for timedate.cpl, 1.rc

1 DIALOGEX 0, 0, 252, 146
STYLE DS_FIXEDSYS | DS_MODALFRAME | WS_POPUP | WS_CAPTION | WS_SYSMENU
CAPTION "Date && Time"
LANGUAGE LANG_ENGLISH, SUBLANG_ENGLISH_US
FONT 8, "MS Shell Dlg"
{
CONTROL "&Date", 103, BUTTON, BS_GROUPBOX | WS_CHILD | WS_VISIBLE, 4, 2, 122, 125
CONTROL "Month", -1, STATIC, SS_LEFT | WS_CHILD | WS_GROUP, 10, 17, 0, 0
CONTROL "", 713, COMBOBOX, CBS_DROPDOWNLIST | WS_CHILD | WS_VISIBLE | WS_VSCROLL | WS_TABSTOP, 11, 17, 50, 120
CONTROL "Year", -1, STATIC, SS_LEFT | WS_CHILD | WS_GROUP, 67, 17, 0, 0
CONTROL "", 706, EDIT, ES_LEFT | WS_CHILD | WS_VISIBLE | WS_BORDER | WS_TABSTOP, 68, 17, 42, 13
CONTROL "", 714, "msctls_updown32", UDS_WRAP | UDS_SETBUDDYINT | UDS_AUTOBUDDY | UDS_ARROWKEYS | UDS_NOTHOUSANDS | WS_CHILD | WS_VISIBLE, 110, 17, 8, 12
CONTROL "Day", -1, STATIC, SS_LEFT | WS_CHILD | WS_GROUP, 10, 37, 0, 0
CONTROL "", 711, "CalWndMain", 0x50810000, 11, 37, 108, 80
CONTROL "&Time", 104, BUTTON, BS_GROUPBOX | WS_CHILD | WS_VISIBLE, 132, 2, 113, 125
CONTROL "", 712, "ClockWndMain", 0x50000000, 144, 13, 90, 90
CONTROL "", 715, EDIT, ES_LEFT | WS_CHILD | WS_VISIBLE | WS_DISABLED | WS_BORDER | WS_TABSTOP, 159, 105, 57, 12
CONTROL "Hour", -1, STATIC, SS_LEFT | WS_CHILD | WS_GROUP, 161, 107, 0, 0
CONTROL "", 701, EDIT, ES_RIGHT | ES_MULTILINE | WS_CHILD | WS_VISIBLE | WS_GROUP | WS_TABSTOP, 161, 107, 8, 8
CONTROL "", 707, STATIC, SS_CENTER | SS_NOPREFIX | WS_CHILD | WS_VISIBLE | WS_GROUP, 169, 107, 4, 8
CONTROL "Minute", -1, STATIC, SS_LEFT | WS_CHILD | WS_GROUP, 173, 107, 0, 0
CONTROL "", 702, EDIT, ES_RIGHT | ES_MULTILINE | WS_CHILD | WS_VISIBLE | WS_GROUP | WS_TABSTOP, 173, 107, 8, 8
CONTROL "", 708, STATIC, SS_CENTER | SS_NOPREFIX | WS_CHILD | WS_VISIBLE | WS_GROUP, 181, 107, 4, 8
CONTROL "Second", -1, STATIC, SS_LEFT | WS_CHILD | WS_GROUP, 185, 107, 0, 0
CONTROL "", 703, EDIT, ES_RIGHT | ES_MULTILINE | WS_CHILD | WS_VISIBLE | WS_GROUP | WS_TABSTOP, 185, 107, 8, 8
CONTROL "AM/PM", -1, STATIC, SS_LEFT | WS_CHILD | WS_GROUP, 193, 107, 0, 0
CONTROL "", 710, LISTBOX, LBS_NOTIFY | WS_CHILD | WS_VISIBLE | WS_GROUP | WS_TABSTOP, 193, 107, 21, 17
CONTROL "", 709, "msctls_updown32", UDS_WRAP | UDS_SETBUDDYINT | UDS_AUTOBUDDY | UDS_ARROWKEYS | UDS_NOTHOUSANDS | WS_CHILD | WS_VISIBLE, 217, 105, 7, 11
CONTROL "Current time zone: %s", 716, STATIC, SS_LEFT | WS_CHILD | WS_VISIBLE | WS_GROUP, 4, 136, 243, 8
CONTROL 10, 0, STATIC, SS_BITMAP | SS_CENTERIMAGE | SS_REALSIZEIMAGE | WS_CHILD | WS_VISIBLE | WS_GROUP, 138, 14, 101, 87
}

I suppose you are holding out on this because of the display error?

post-81494-1201022258_thumb.jpg

Link to comment
Share on other sites

ok guys, i tried to get the bug out, the resource fix is on the first page.

instructions are included.

mara, yes i want that resource very badly...

i cant get it right for some reason.

the other "bugs" are noted and i will try to fix them for the next version.

btw, logoff text remover only works after you have rebooted after the patch process.

:hello:

damian666

p.s. anotherr bug found but this is on 2000, reloader i f***ed...

see first post for updated patcher.

this is the last time i work on this when i am sick man :(

i make to many mistakes when sick...

Edited by damian666
Link to comment
Share on other sites

Here it is, I did not use the transparency, I found the best color that fits to the dialog. I'm uploading you .bmp files.

bmp.rar

btw, logoff text remover only works after you have rebooted after the patch process.

I know this, but when I do that, Reloader put text back on buttons.

And if you ever need some resource translated to English, just post here or PM me.

Cheers ;)

Link to comment
Share on other sites

thanx mara, i will do that...

nice bmp's, much better looking the the ones i made, cheers.

and about the logofftext remover, i didnt encounter that myself, but i will try to fix it man.

but what could cause the reloader to kick in?

weird...

i will investigate it dude.

damian666

Link to comment
Share on other sites

Hey damian,

There is an error in path of your installer for resource fix:

C:\Program Files\Vitapack XP

instead of

C:\Program Files\Vistapack XP

Also, this clock looks great, but it has few bugs. There is double needle for seconds (one is static and other is moving), and when I click to some other tab, on Time Zone for example and then I return to Time & Date, needles for minute and hour disappears.

BTW, did you changed anything related to Boot Screen, because with v2.1 when I patched my XP CD, boot screen was changed, but with this version boot screen does not get changed.

Also take a look on this picture:

post-127541-1201127503_thumb.jpg

And, I hope you don't mind for so much bug reports or for so much suggestions. I know that in past few days I wrote pretty much posts here.

Cheers ;)

Edited by mara-
Link to comment
Share on other sites

hi mara, no ofcourse i dont mind your help in any way...

sure, much bugreports are not nice to see, but it arent all bugs, some things i just didnt do yet, or have trouble with...

and spelling fault for the fix huh?!!!

now thats a stupid bug :)

so people, just cut and past the contents of "vitapack xp" to the "vistapack xp" folder and you are good to go...

and the clock, well it is just a little tryout, and as you say, it is not flawless...

but it looks better then it was huh?!

but if you dont like it, i can always take it out again.

because i dont think it can be done better then that...

and automatic update is something that resists modding man.

when it finds out it is modded, it will dl itself agian.

thus getting in a endless loop with the reloader...

so sorry, but i dont know how to do it man.

and no i didnt change anything in the bootscreen, but sometimes the xp setup takes the bootscreen out of the sp2 cab instead of the cd itself, thus using a non patched one.

check the reshacker log in the i386 log dir please...

Link to comment
Share on other sites

I checked the log, everything seems fine. And yes clock looks cool, in my opinion you can leave it, who know, maybe in future you find better solution. And this thing with security center: It seems that this icon is replaced when system is patched, but picture that I showed you is from system where I patched the XP CD and then installed it. Maybe you can check it out when you have time.

Cheers ;)

EDIT: You were right, I checked the XP CD files (wuaucpl.cpl) and it is patched, but when I installed Windows it seems that got reverted.

BTW, do you know where icons of FIle Open dialog are located? I mean on those, which appears when you use Paint for example to open file.

Edited by mara-
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...