Jump to content

HOWTO create a fully up to date XP x64 DVD (EoL Feb 2016)


Recommended Posts


I think I finally see the light, I only have one other question about the image of the directory after integration. it shows a + mark next to the addons folder indicating one or more folders inside.I was thinking it may be the 7z update. Could you clarify for me please and thank-you very much for your help.

In my case (where that image is captured) there are some folders for drivers that can't be integrated and have to be done by silent install, I cut the commands from the batch files before posting them, the full version being:

rem Hardware specific driver applications | Acer GridVista | UPS | Gigabyte DES | USB to Serial Adapter | Acer Launch Manager | HP Quick Launch | HP Wireless | Intel Matrix Storage Manager

rem %Source%AddOns\AcerGrid\Setup.exe /S

rem %Source%AddOns\PowerManagerII\Setup.exe /S /F2%Temp%\PowerManagerIIsetup.log

rem %Source%AddOns\DES\Setup.exe /S /F2%Temp%\DynamicEnergySaverSetup.log

rem %Source%AddOns\USBtoSerialSetup.exe /S

rem %Source%AddOns\LaunchManager\Setup.exe /S /F2%Temp%\LaunchManagerSetup.log

rem Copy %Source%AddOns\LaunchManager\LaunchManager.* "%ProgramFiles(x86)%\Launch Manager\"

rem Regedit /S %Source%AddOns\LaunchManager\HotKeys.reg

rem %Source%AddOns\QuickLaunch\Setup.exe /S /F2%Temp%\QuickLaunchSetup.log

rem %Source%AddOns\WirelessAssistant\Setup.exe /Passive /NoRestart

%Source%AddOns\iata96enu.exe /S

Link to comment
Share on other sites

  • 4 weeks later...

Kurt_Aust, I see you have stuck with Java 6U22 for the 32 bit version due to an install error. I also am getting an error on my W7 x64 unattended install - revoked certificate. I checked the dates and they look good. I am not really sure which 6U23 installer I am getting the error on since I spool my output to a file. I just get a stop and a dialog. If I respond yes to continue, all completes fine. Are you getting the same error? BTW, I notice you added Mozilla to your parameters. Do I need to add Chrome since I am using it? Perhaps Mozilla or IE covers Chrome. Thanks for your help. Enjoy, John.

Link to comment
Share on other sites

January update

Addition (at \Hotfix):

@ 584-WindowsServer2003.WindowsXP-KB2419635-x64-ENU.exe .. 3,114,368 MS11-002 - Data Access Components (MDAC) 2.8 SP2

Added Google Chrome to the supported applications


This is my bug http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7007629

not exactly critical, just annoying, as update 23 is NOT a security update, I'm sticking with update 22 for now.

The MOZILLA=1 parameter is old and not really needed anymore, details at http://www.oracle.com/technetwork/java/javase/silent-136552.html

According to https://www.mozilla.com/en-US/plugincheck/ Java is installed on Chrome in my VM tests.

Link to comment
Share on other sites

Kurt_Aust, thanks much. I got three good links from your reply. I cannot find my Java problem in their DB. My certificate problem is strange in that it happens only when I do my unattended install. Running the same commands on my VM works fine. From the installer options link I discovered how to get a log file so I can track down the error better. I removed the IEXPLORER=1, ADDLOCAL=ALL, and /NoRestart. None are needed. I also found that the silent switch does not work as a capital S. I had searched quite a bit for the installable Chrome file with no luck, so I tried the Enterprise version you found. It does install, but will not accept my User Data folder having all my settings. It seems to recognize some (search engines, one home tab), but none of the others. I have some more work to do here. Thanks again for your help. Enjoy, John.

EDIT: Can you give me one more link? I would like a link to the site where you found the Chrome installer and switches. Thanks.

EDIT: I did my install on VM and got the Java install logs but no error.

EDIT: I have manged to get Chrome to install and use my old settings. There is another stand alone installer (ChromeStandaloneSetup.exe) found here http://www.google.com/chrome/eula.html?standalone=1. The "Set Google Chrome as my default browser" box needs to be unchecked or a 80040909 install error will occur. No switches are needed to install it passively.

Edited by johnhc
Link to comment
Share on other sites

  • 4 weeks later...

February updates










@ RunOnce\install_flash_player_ax.exe 2,871,968 Updated 8 February

Additions (all at \Hotfix):

@ . . . 588-WindowsServer2003.WindowsXP-KB2478971-x64-ENU.exe .. 1,439,616 MS11-013 - Kerberos

# 592-WindowsServer2003.WindowsXP-KB2483185-x64-ENU.exe 13,170,048 MS11-006 - Shell Graphics Processing

@ . . . 596-WindowsServer2003.WindowsXP-KB2476687-x64-ENU.exe . . . 690,048 MS11-010 - Client/Server Run-time Subsystem (CSRSS)

@ 600-WindowsServer2003.WindowsXP-KB2479628-x64-ENU.exe .. 4,354,432 MS11-012 - Kernel-Mode Drivers

@ . . . 604-WindowsServer2003.WindowsXP-KB2478960-x64-ENU.exe .. 1,460,608 MS11-014 - Local Security Authority Subsystem Service (LSASS)

# 608-WindowsServer2003.WindowsXP-KB2393802-x64-ENU.exe .. 9,321,344 MS11-011 - Kernel

@ . . . 612-WindowsServer2003.WindowsXP-KB2485376-x64-ENU.exe . . . 873,344 MS11-007 - OpenType Compact Font Format (CFF)

# 616-WindowsServer2003.WindowsXP-KB971029-x64-ENU.exe .. 12,624,256 Block AutoPlay on USB media

# 904-IE8-WindowsServer2003.WindowsXP-KB2482017-x64-ENU.exe 42,716,032 MS11-003 - Cumulative Security Update

Returned Opera to the supported applications list as the silent install switches now work, on the flip side SumatraPDF now requires the v1.2 installer and the v1.3 executable.

Interestingly only one security patch this month is completely new, the rest update previous patches. It would be nice to think there would be another service pack or at least an update rollup, but somehow I'm not holding my breath.

It's also nice to see that the security chasm (calling it a hole doesn't do it justice) created by the autorun/autoplay "feature" is being wound back. It still amazes me that someone high up at Microsoft thought that it was a good idea. Unfortunately as the "feature" is still available on CD/DVD drives it won't stop an international criminal syndicate (Sony) from installing malware on your system.

johnhc: Tip, I don't get a message that you've edited your post, so it would be best if you want a reply that you either do a new post or PM me that you've edited your current one.

I don't really remember where I found it anymore so I'd suggest that you just do a search on "GoogleChromeStandaloneEnterprise.msi"

Link to comment
Share on other sites

  • 3 weeks later...

Kurt - Thank you very much for this guide. I wanted to express my appreciation of your work as I have used it to put together my own up to date XP x64 DVD. I knew absolutely nothing about how to create one before reading your guide and although I made a lot of mistakes along the way I now have a much better understanding of the process. Thanks also to 5eraph for his update packs.

I have a problem though that I hope you can help me with. I have created an ISO using my original XP x64 Pro OEM disc, nlite to integrate 5eraph's x64 and IE8 update packs and Boogy's slipstreamer and have burned it to a DVD that works perfectly in VMware but throws up errors in Setup when trying to install to a real Hard Drive. In particular when Setup is starting I get (amongst other messages) "File \AMD\ntkrnlmp.exe could not be loaded. The error code is 7. Setup cannot continue. Press any key to exit.". Sometimes setup will get further but end with an error such as "The file ohci1394.sys is corrupted. Press any key to continue". Bizarrely Setup completes successfully if I use the original XP x64 cd or if I use a cd burnt that just includes SP2 integrated into XP x64 Pro.

I have burnt 4 seperate DVD's thinking I might have faulty discs. Same thing - all work fine when in a VM but all have the same problems when trying to install to a real Hard Drive.

Any idea what may be the problem? I have attached a copy of the last session.ini file if it helps.

Kind regards

Link to comment
Share on other sites

Those files are located in the driver cabinets. Do you enable cabinet merging or disable high compression in nLite's options, OldNewb? Your Last Sessoin.ini was not attached.

You may also want to check your RAM as suggested in KB318729.

Edited by 5eraph
Link to comment
Share on other sites

Hi Kurt and 5eraph - thank you both for your speedy replies. You guys are stars. :thumbup Sorry so slow to get back to you- work has been getting in the way.

I have run Memtest86+ and no problems there. Have reset BIOS to defaults (as suggested elsewhere) and retried but without success.

5eraph - have looked at my nlite setup and yes High Compression was disabled as was Cab Merging. I don't know if it makes any difference but OEM branding was enabled.

Will try a rebuild with these options reversed and let you know how I get on.

Sorry Last Session.ini wasn't attached. I thought I had managed to upload it but being new to posting to a forum I am probably doing something incredibly dim. Will try again.


Link to comment
Share on other sites

OldNewb, looking at your last session I'd suggest doing a burn with just 5eraph's packs and whatever drivers you may need, don't yank anything out or muck around with the services, hopefully that should narrow it down.

Also do you know where this comes from?



G:\Slipstreaming xp64\Build v5.9 (2011-02-27)\Hotfix\5er_UpdatePack_XPx64SP2_2011-02_1.7z

G:\Slipstreaming xp64\Build v5.9 (2011-02-27)\Hotfix\5er_IE8_Addon_2011-02_1_x64.7z

G:\Slipstreaming xp64\Build v5.9 (2011-02-27)\Hotfix\IE8Tweaks.7z

G:\Slipstreaming xp64\Build v5.9 (2011-02-27)\Hotfix\5er_MSSignedThemes_Addon_v6.1.1_x64.7z

I've never seen such a line in any of my builds.

Of course this assumes you haven't found a solution yet.

Link to comment
Share on other sites


Also do you know where this comes from?


I've never seen such a line in any of my builds.

Hi, Kurt_Aust

It's the second checkmark. Very useful, if you ask me (applies only during working with NLite).


(Image courtesy of -X-)


Link to comment
Share on other sites

Hi Kurt - tried the changes I proposed last post but without success.

The Hotfix reports you mention simply give the location (on my system) of the files I am integrating with nlite. GrofLuigi is correct. They are produced by nlite althoughI wasn't aware they were shown in the Last Session.ini file. AFAIK they display messages about any "issues" during integration. I had Display Reports selected and they did display 19 error messages when I was integrating 5eraph's XPUpdate pack but these were all relating to .dll's that were newer in the ISO than those being integrated (ie: those in 5eraph's pack).

This whole business has me puzzled and I am sure it is something incredibly simple.

Do you know for sure that an OEM CD can be used to build an uptodate DVD as you have so clearly explained?

Does creating the image on a DVD make any difference to building on a CD?

Could it be that the DVD can be read in a VM (running on xp64) but the same DVD cannot be read when booting? perhaps no drivers?

It is so odd. When I boot from the DVD (which includes AddOns and RunOnce folders) the drive is working (I can see the light on it!) but Setup takes forever to display anything on screen and then produces errors. Last attempt got as far as "pci.sys is corrupted......"

Am going to try a few more builds and try to eliminate some possibilities.

Thanks once again for your input. I WILL get this to work!!

Best wishes for a good weekend.

Link to comment
Share on other sites

I take it you are referring to an original Microsoft OEM CD (as I don't know of any manufacturer OEM CDs, HP, Dell, et al)?

If so the answer is definitely yes, it's what I do on my systems and it works fine. Being on a DVD as opposed to a CD makes no difference.

One thing that did occur to me based on your last post is - is the DVD drive from which you are trying to install SATA? On my main system if I try to install from a SATA attached DVD drive I inevitably get a BSoD, I have to install from an old school parallel IDE attached DVD drive.

Link to comment
Share on other sites

Hi Kurt - yes I am using an original MS OEM cd and also using an IDE attached Samsung DVD/RW writer.

Tried another build last night - this time not removing any components when integrating 5eraph's update pack. Same result. It works fine in a VM but not when installing to a real Hard Drive!

Setup once again took ages to read from the DVD and then BSOD with message "File |AMD64\ntkrnlmp.exe could not be loaded. The error code is 14"

A different error code this time (was 7) but still no success.

Checksums are all as should be and burn verified. It must be some thing to do with the DVD drive and its driver. If the same drive is used to read the nlited DVD in a VM and is successful then why does it not produce the same result when booting from the same DVD?

Will keep experimenting and will let you know how I get on. If you or any other members have any ideas I would be glad to hear them.

Thanks again for your help - Enjoy your evening :D

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...