Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Yurek3

How use WPI in UA Vista

Recommended Posts


I haven't installed Vista yet. I am not any a hurry, either. But will do a test machine this spring/summer. Don't expect anything too soon.

Share this post


Link to post
Share on other sites

Tested in vista, WPI works fine

Havnt test this with runonce yet.

EDIT hmmmm, i doesnt work as good as i thought :angry:

Edited by sp00f

Share this post


Link to post
Share on other sites

When i click wpi.hta , it opens without any errors.

but when a .cmd file opens the wpi.hta , it gives an error.

wpierroryq5.th.jpg

Cant open reg key for reading.

( In Vista32 )

Edited by sp00f

Share this post


Link to post
Share on other sites

It's not that simple that it was with Win XP, I think. I managed it by using ConfigurationSet in the UA Install, so an WPI.cmd gets copied to %systemdrive%\Install and I call it per AutoUnattend.xml. I will try to explain in the next days.

Share this post


Link to post
Share on other sites
It's not that simple that it was with Win XP, I think. I managed it by using ConfigurationSet in the UA Install, so an WPI.cmd gets copied to %systemdrive%\Install and I call it per AutoUnattend.xml. I will try to explain in the next days.

You can place such folder in your install.wim, that not the difficult part.

To run it without errors and run things from cdrom, thats what doesnt work

Share this post


Link to post
Share on other sites

Ater i opened core.js , i saw the problem, it looks for XP files.

:hello:

	// %CDROM%
li = GetDriveLetters(4);
for (i=0; i<li.length; i++)
{
if (FileExists(li[i]+'\\WPI.HTA') || FileExists(li[i]+'\\WIN51') || FileExists(li[i]+'\\I386\\DRIVER.CAB'))
cddrv = li[i];
}

if (cddrv=="")
{

Edited by sp00f

Share this post


Link to post
Share on other sites

Yes,

I would like to know that too. I'm really want to installing this software but i'm getting the same errors as above. Pliek could you please point us to the right way!... thank yu very much!!!

Nick

Share this post


Link to post
Share on other sites

I just changed the xp things into vista things in core.js , that was all........

LOL even the makers from wpi never respond to this....they had to know after i posted the error, but they didnt.

Glad i found this myself :hello:

Problem solved WPI runs in vista now.

And where do you see Pliek? :blink:

Edited by sp00f

Share this post


Link to post
Share on other sites

IT WAS NOTICED AND NOTED!!!

But we are very busy with the next version for now you will have to manually edit...

Share this post


Link to post
Share on other sites
I just changed the xp things into vista things in core.js , that was all........

LOL even the makers from wpi never respond to this....they had to know after i posted the error, but they didnt.

Glad i found this myself :hello:

Problem solved WPI runs in vista now.

And where do you see Pliek? :blink:

Hi sp00f,

Could you please upload the correct file so I can add the correct ones. Thank you (or mail np at all)

Many thnx

Nickx

Share this post


Link to post
Share on other sites
I just changed the xp things into vista things in core.js , that was all........

LOL even the makers from wpi never respond to this....they had to know after i posted the error, but they didnt.

Glad i found this myself :hello:

Problem solved WPI runs in vista now.

And where do you see Pliek? :blink:

Hi sp00f,

Could you please upload the correct file so I can add the correct ones. Thank you (or mail np at all)

Many thnx

Nickx

Just edit the core.js

In that file you look for this :

if (FileExists(li[i]+'\\WPI.HTA') || FileExists(li[i]+'\\WIN51') || FileExists(li[i]+'\\I386\\DRIVER.CAB'))

Change "WIN51" and "I386\\DRIVER.CAB" into things that are on your vista DVD.

I use this ( these things are in MY Vista DVD ) :

(FileExists(li[i]+'\\WPI.HTA') || FileExists(li[i]+'\\AppsRoot.txt') || FileExists(li[i]+'\\sources\\install_Windows Vista (vLite) ULTIMATE.clg'))

And to start WPI i used firegeier's guide :

http://firegeier.unattended-sponsor.de/en/applications.html

But instead of installing aps from there i only use this for WPI

%AppsRoot%Install\WPI\WPI.hta

Edited by sp00f

Share this post


Link to post
Share on other sites

I use RunOnceEx method with wpi (old version wpi lite 1.2 with the 6.0 iernoncedll) no problem with Vista but with UAC DISABLED !

btw, why Microsoft invented the UAC ?!

all n00bs will doesn't know what's question is when UAC pop up,

and all geeks know perfectly what's the pop up and he's boring to click "Continue"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...