Jump to content

This is drivin' me nuts...


RaGhul
 Share

Recommended Posts

Ok, I've had copy errors before, but now it's getting out of hand.

The thing is, if I just integrate Xable's Update Pack onto a clean XP cd using Integrator... no problems. If I just Remove Components from a clean CD using nLite... once again, NO problems.

However, if I try to combine the two in any way, shape or form, I get this: "Windows cannot copy file..."

It's the ULTIMATE definition of redundancy: trying the same thing over and over (and over) again, just to wind up with the same results.

What really irks me is how all these people are saying things like, "Wow, I got my CD down to 187megs", or "Never had ANY problems". Yeah, I can do that do, but not if I want to integrate the latest hotfixes to stay up to date. So far, the best result I got was by first Removing Components with nLite, then Integrating Xable's pack. Just one copy error. But still...

Seriously, I'm not a dope. I DO read. I've installed XP so many times, I've MEMORIZED the serial key. I know VMware. (It has saved me 'countless' CDs.) I even helped Kel with an Addon. I even ResHack boooggy's WMP so I can use the icon I prefer.

What gives?

PS: Going crazy!! :}:}:}

Edited by RaGhul
Link to comment
Share on other sites


Like i say at ryans forum:

I`ve always done everything with nLite and had no copy errors, whichever pack i`ve used.

Get on MSN RaGhul and you can walk me through exactly what you do to get copy errors. If it`s reproducible we can figure out why it happens.

Link to comment
Share on other sites

If you get file copy errors it`s because you`ve done something wrong or it`s a bug in nLite. Check your methods and if you still get copy errors make a new thread with steps to reproduce the errors so it can be reproduced and debugged.

btw my pack installs legitcheckcontrol.dll so you can access microsoft update.. it doesn`t install the tray nag.

Link to comment
Share on other sites

RaGhul, now if it's my mistake lets fix it.

But first explain to me in less steps possible how to duplicate that issue?

For example:

-Copy clean xp install

-Integrate Xables X addon with Integrator

-Remove Y component, make iso...?

Link to comment
Share on other sites

Ok,

I start out with XP Corporate with SP2 already in it. Whether it's slipstreamed or not, I'm not sure, but I believe it's MS's version, not slipstreamed. The ISO file is 585mb, labeled "VRMPVOL_EN".

I extract it to a folder using Winrar. After that, I've tried each of these:

1.) Integrator to add Ryan/Xable's pack, then Remove Components with nLite.

2.) Remove Components with nLite, then Integrator to add Ryan/Xable's pack.

3.) nLite for both.

No other addons.

Always produces at least 3 (usually more) copy errors. The only way that HASN'T produced errors was method 3.), using Ryan's pack.

The files that won't copy are always different, but not random. They change depending on what I did, but if I try re-installing the same resultant CD on VMware, I get the same errors as before.

VMware has saved me alot of coasters, and I've tested it with actual CDs burned from the same ISO. It will produce the same exact errors as if I had actually installed it with a CD, so I know the results are good.

Attached is my INI file. I'll be happy to explain further, if need be.

These links might also help:

http://www.msfn.org/board/index.php?showtopic=90019

http://www.ryanvm.net/forum/viewtopic.php?t=4046

Edited by RaGhul
Link to comment
Share on other sites

RaGhul.. Interesting that you said you have a ms slipstreamed xpsp2. I also have a directly integrated xp sp2 copy from ms. Also the issue with xable's pack is identical to mine.

I believe it has to do with the source in some way. Perhaps nlite does something different when it sees that source. The only reason i use that disc as opposed to one where I slipstreamed sp2 myself is because its actually smaller then when I do it manually.

Have you ever updated an sp1 disc to sp2 and seen this difference in size?

I have had many issues with nlite since 1.2 was released with my copy of xpsp2. Before that version it seems that nlite liked my xpsp2 from ms but after it has not. I have not tried 1.3rc yet but I plan to tonite and maybe this one will work better overall. If not I plan to try the manual sp2 and see what happens that way.

Edited by Madhits45
Link to comment
Share on other sites

That's a good observation, Madhits. Maybe it well help nuhi in narrowing down what causes the problem.

I too have had more problems with the newer releases. Maybe nuhi can track down what he does differently in the Component Removal process now that may explain the problem.

Also, I saw more errors with Xable's than Ryan's, it seems. More interesting, though, is that neither pack got me to the coveted "zero copy errors" until I did the opposite of what everyone told me to do: Remove Components first, then Integrate.

I would like someone 'in the know' to explain to me why everything should be added 'before' Removal. Maybe I'm nuts, but it seems to me more logical to Remove Components first.

PS: Actually, come to find out I think my disk is not MS factory, but slipstreamed with SP2 after all. :P Same problems as you, though, so I'm not sure it's a big deal. Then again, maybe that's the problem: nLite is trying to remove stuff, but finds it in different places than expected. So it doesn't remove them entirely. Hmmm....

Link to comment
Share on other sites

nuhi,

I've also read on the forums here that there is a file in I386 which tells XP what size the files are supposed to be, and if the size doesn't match up, XP whines.

I'm thinking the problem is either this, or what I mentioned in the previous post. Just an educated guess.

Perhaps you could put in a script in nLite to edit this file. It could potentially save many people ALOT of grief. :D

(nuhi, you there?)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...