Jump to content

is there any way to run silent batch files at t-12?


Recommended Posts

i've tried compiling my batch to silent exe using quick batch and using exescript, both don't work.

i've tried using cmdow.exe and another batch file loader, both don't work.

is there some trick to it? it's not an error in the batch or something lame like that, because the batch alone works fine and i use full path names in it.

Link to comment
Share on other sites

you can probably succeed by using windows built-in tools.

either START /B command (i never tested that) :



c:\windows\system32\cmd.exe /k start /wait /b x:\path_to\your_batch.cmd

or a VBS/JS launcher ; search on the forum for details, but it's something like that :


(the 1 "equals" /wait ; and the False means hidden ; or it's maybe the opposite, i still don't know the manual by heart :lol: )


Link to comment
Share on other sites

t-12 is that after first reboot? The first time you see a gui. If it is I have a way. I use an old trick for installing my drivers still and its basicly a special setup.exe that calls a file called presetup.exe. The presetup.exe is just a batch file and I have added a lot of file moves and deletes to it and they work great. A lot easyer to delete files then, then it is later in the install. If I'm right about the timing then I'll post the files for you.

I would have started to use Nlite to add my drivers but because I love this presetup thing I never bothered to switch.

Link to comment
Share on other sites

put cmdow in the $oem$ folder

add: cmdow @ /hid

to the beginning of each cmd file

I have all of my cmd files in the $oem$ also not sur eif it makes a difference or not. but everything I run, runs from cmdlines.txt. Only the updates run from svcpack.inf.

Link to comment
Share on other sites

yah, using it that way does work but using it as a loader doesn't. i don't use cmdow anymore tho because of the annoying AV signatures.

i know it's not malware, but whenever i use that file it's inevitable i get countless emails from paranoid people.

even tho cmdlines won't run compiled silent exes, svcpack will. strange stuff. (didn't try a loader in svcpack since the first thing i tried worked)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...