Jump to content

How to make a basic WinPE 2.0 CD


Recommended Posts

I was able to get the drivers slipstreamed. I have been reading the help files but I have a couple of questions and I was wondering if anyone could help me out. First, what is a good shell to use with PE 2.0? I have been trying to get explorer to work but with no luck so far. Also how do I enable the network so that I can map a drive and dump an image to it?


I was able to access all of my raid drives and the got the network driver working. Just before using the /prep command I copied over my Opera folder, Nu2Menu, and A43 and Totalcommander. All of these items run in PE 2.0. Now as I am not familiar with nu2menu I need to read up on how to edit the nu2menu.xml file so I can opera, a43 and TC to the menu. If I have time I am going to try to write a small gui for the imagex program using either vb or .net.

Edited by ElAguila
Link to comment
Share on other sites

  • 2 weeks later...

You guys can also take a look at booting into Win PE from the HD as well, it's much quicker, and can all be done unattended.

In the PE doc in the WAIK, look the article titled "Walkthrough: Boot Windows PE from Hard Disk".

The way I did it from my Vista installation is I copied boot.wim to the c:\boot\ folder. I then added an option in the BCD to boot into PE (see "How to create an entry to boot a WIM image from a hard disk" from this page: http://technet2.microsoft.com/WindowsVista....mspx?mfr=true)

One thing we do at work (using PE '05) is we have batch files/VBS scripts which change the boot loader (ntldr) and reboots into PE to capture snapshots or restore systems using ximage (now Imagex). Our PE image looks for c:\pe\auto.bat and executes it. This way, from Windows, we can copy the capture auto.bat or restore auto.bat to c:\pe\ and reboot into PE to perform our custom action.

One important note aboute ximage is that it uses single instancing. This means that all duplicate files (eg. c:\windows\dllcache\*.dll) will only appear once. It is also non-destructive. You can capture an image of c: to c:\backup.wim. You can take a snapshot of a newly installed OS (eg. XP which basically consists of c:\Documents and Settings, c:\Program Files, c:\Windows) into a WIM file. the pagefile and system volume information folder will be ignored due to wimscript.ini. You can then reboot into PE, move c:\Documents and Settings, c:\Program Files and c:\Windows to c:\Backup and apply the image you captured to the c: drive. Any other folders in C: will remain untouched. Reboot and you're in a fresh install of XP and your data is still on the HD. Reboot into PE, delete c:\Documents and Settings, c:\Program Files and c:\Windows and move the 3 folders from c:\Backup\ back to the root or c: and reboot back into the original OS. All of this can be scripted of course.

Hope this helps.

Link to comment
Share on other sites

  • 11 months later...

Hello evryone I am new here and I have been reading a little bit and tried searching around but I guess I don't reallt know what to search for as I can't find my answer. My girlfriend just recently got this HP dx6650us with windows vista Home professional X86 and I am trying to move here users folder to the d:\ that came partitioned with the computer. Well I have downloaded and installed the WAIK and the .zip in the thread. Well I make sure the there is no c:\winpe_x86 folder and the I start up the WAIK command prompt and I type, step1.bat, and it completes, but wen it completes the line doesn't say c:\Program Files\Windows AIK\Tools\PETools> it says c:\winpe_x86. I'm not sure if that's what supposed to happen, but then I type in, step2.bat, and it says:

c:\winpe_x86>imagex /mountrw c:\winpe_x86\winpe.wim 1 c:\winpe_x86\mount

ImageX Tool for Windows

Copyright © Microsoft Corp. 1981-2005. All rights reserved.

ERROR: The current logged on user does not have administrative privileges.

But I don't know how that can be as there is only one account and that is the Admin and I am logged on as the admin...

If anyone can help that would be greatly apreciated


Link to comment
Share on other sites

  • 3 months later...
  • 2 years later...

Thx for the reply... I have found a solution from a different site which worked for me..

copype.cmd x86 c:\winpe_x86

copy c:\winpe_x86\winpe.wim c:\winpe_x86\ISO\sources\boot.wim

Dism /Mount-Wim /WimFile:C:\winpe_x86\ISO\sources\boot.wim /index:1 /MountDir:C:\winpe_x86\mount

Dism /image:C:\winpe_x86\mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\winpe-wmi.cab"

Dism /image:C:\winpe_x86\mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\winpe-hta.cab"

Dism /image:C:\winpe_x86\mount /Add-Package /PackagePath:"C:\Program Files\Windows AIK\Tools\PETools\x86\WinPE_FPs\winpe-scripting.cab"

copy "C:\Program Files\Windows AIK\Tools\x86\imagex.exe" C:\winpe_x86\mount\Windows\System32\imagex.exe

Dism /unmount-Wim /MountDir:C:\winpe_x86\mount /Commit

To use USB drive as your bootable media, go through the below site..



Link to comment
Share on other sites

  • 1 year later...

step 5 bat doesnt work anyone have any idea why

On WHICH environment? :w00t:

Maybe you are trying to use a WinPE 3.0 instead ofa WinPE 2.x? :unsure:

(read just a few posts above yours)


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...