Jump to content

[Discontinued] AutoRIS V2.10

Recommended Posts


Its an Genuine Microsoft Hologramed Disk that came in microsoft packaging with an authentic COA

I suspect RogueSpear has Slipstreamd XP gold with SP1 & Then SP2 that is why is looking for both "WIN51IP.SP1", and "WIN51IP.SP2".

RogueSpear: Ran the script (with Fixed tag file issue. Copied in Filecase.exe) all seemed ok (Restarted Service & asked me to start an ris install).

But now Windows Setup Complains about no NIC Drivers Loaded for Current NIC , .inf & sys files are there.

Should there be a coresponding .pnf ?? eg yk51x86.pnf

Link to comment
Share on other sites

The script I posted just checks for one file Win51 that all i wanted to know if it found it.

I made that Script on Vista and the image in the reply I get when i put in the XPCD

in my CD Drive.

I think RogueSpear did it that why so it would work for either SP1 or SP2 pack. But this

is just a guess.

But now Windows Setup Complains about no NIC Drivers Loaded for Current NIC , .inf & sys files are there.

This I have no knowlegde on i just wanted to make sure the cd was being identified correctly.

Link to comment
Share on other sites

Ok, just got into work and I'm going to need some coffee before any major work gets done, but I should have V1.01 posted later in the day (it's 8:00AM now where I am).

@krismark, don't ya know any better than to run version 1.0 software from a guy who's avatar looks like mine? :P Ok, seriously.. My XP CD is actually a Gold + SP2 slipstream. I think what I'll do is change the code to only look for and copy WIN51IP.SP2 since that seems to be what we're looking for here. I'll have to test it though to see if both RVM and nLite are satisfied with only that file. Also I'll change the code to leave the tag file in place for future use. I think I was a little too aggressive in my cleanup efforts.

Regarding filecase.exe - just a plain old oversight on my part. You can try to get everything down the first time but it never fails, always forget something. In case you're wondering, filecase.exe is actually needed for the proper operation of the script. Some of the compression routines run on the basis of file extension and they're case sensitive. My personal taste is to have everything in one case or the other as it makes it easier to go through a directory with thousands of files that way. So I opted in favor of filecase.exe rather than putting in redundant code to process each file extention twice (once for each case).

Regarding your last screenshot error, I think it was line 227. I'll have to put a note about that in the first post. You must be running AutoRIS from an account that has the right to attach to WMI and restart the BINL service on your RIS server. The permission denied error I can only assume was due to an account with insufficient privleges or there was a WMI problem on your computer.

Like a lot of programs and general procedures regarding the processing of an install image, if something goes wrong towards the beginning then it all goes to hell. I think this could have something to do with your final problem of NIC drivers not being found. Rest assured I'll get a revision up soon.

Link to comment
Share on other sites

I just noticed something. For the constant RVMEXE, you put in the path and filename.

from AutoRIS.vbs

Const RISSERVER = "sbs01.krismark.local"

Const RISIMAGE = "\\sbs01.krismark.local\Reminst\Setup\English\Images\AUTORIS"


Const RVMEXE = "e:\RISTEMP\RVM_Integrator_1.0RC8.exe"

It should be the filename only. Slightly further down the script is this line:

RVM = RISTEMP & "\" & RVMEXE & " " & RISTEMP & """\integrator.ini"" /integrate"

AutoRIS expects to find the RVM Integrator (and the RVM Packs) inside of RISTEMP. As you can see from the line above, adding the path to the constant will create issues. Also you are using too old a version of the RVM Integrator. The minimum version level is specified in post #1.

Link to comment
Share on other sites

I am logged onto the domain with administrator & Domain Admin Rights. Do you know how to give rights to attach to WMI and restart the BINL service ??

Edit: I found this :http://support.microsoft.com/default.aspx?scid=kb;en-us;325353

Looking foward to future versions. BTW where is the link for 1.01 ??

I am home from work with the flu and you are helping me pass the time. BTW its 6.10 A.M here in Sydney.

Edited by krismark
Link to comment
Share on other sites

Heres a few things I found today.

1. You need to remove Read Only attributes from txtsetup.sif and other files if using BTS Driver Pack

2. BTS Removes Filecase.exe from your Ristemp Directory, so as RogueSpear points out:

Filecase.exe is required and must be within your system path for AutoRIS to function properly. It is now included with AutoRIS. Just drop in %SystemRoot% or somewhere else within your path.

Link to comment
Share on other sites

Ok, I had V1.01 up for a short while when I discovered a not so nice error in my code. For the user who isn't versed in VBS, this would render the script pretty much useless since they couldn't fix the error. I'm currently running a test of what should be V1.02. My efforts have been hampered today by my main job (imagine that) and then an emergency call from a client. No rest for the weary.

Please keep in mind too that when I run through a test it can take well over an hour to complete. And then some more time to analyze the results. So I'm going to make every effort to get 1.02 out the door tonight. I just want to be a little confident that there aren't any major issues with it.

Version 1.0 had been running so smooth for me for like a week. I must have run 20 different tests with it and had no problems at all. The slew of issues that were brought to my attention within hours of it's posting kind of shook me into reality and made me realize this could be more challenging than I had once though.

Link to comment
Share on other sites

Version 1.02 has been posted. Along with the changelog in the first post, I did a little editing here and there of the instructions to reflect the changes and to hopefully make it a little easier to understand. I put this version through a lot of testing today and it ran perfect in every instance. The only major issue I could forsee is a possible file copy error or folder delete error due to the OS having a lock on something. It seems things have to coded just so and in just the right order to avoid this problem. Like I said I did a LOT of testing, trying my best to envision all of the various snafus that could come up. I'm sure that I couldn't have caught them all.

I'm going to start work on implementing some minor new features and adding in some code for using an .INI file that AutoRIS will use for settings. This way people won't have to actually edit the script themselves (though you're free to if you like). One thing I would like some feedback on is what features would you like to see? I was thinking of including a .SIF file with the basics in there and having AutoRIS edit the .SIF file based on user entries in the .INI file. Check out the sample .SIF that I included in my unattended RIS guide and see what you think.

In case anyone was wondering why I don't have AutoRIS launch nLite for the user. nLite requires that the "working directory" or if you check out a windows shortcut, the "Start From" entry, be defined. This is something that I have been unable to figure out in VBscript. I'm going to see if AutoIt has any kind of facility for this or for that matter, does this by default. If AutoIt can do this I could implement the solution very quickly by calling AutoItX.dll as a COM object through VBscript. What this means though is that the end user would have to register that dll file before running AutoRIS. What do you all think about that? The other solution would be to completely rewrite AutoRIS to AutoIt (say that 10 times fast lol).

Well in any case I hope that V1.02 works a bit smoother for you patient souls who have suffered through the first version.

Link to comment
Share on other sites


The perfect RIS Install

Multiple previously unsupoerted NIC's

BTS Drivers Packs intergrated.

Throw in svcpack.inf And SVCPACK directory from XPCREATE

misc other bits stollen from unattended guide.

What more could you want ??

Link to comment
Share on other sites

Yes it was.

I still have the issue of not having the right permissions to Restart BINL from the workstation, which means I run AutoRis from the server and then have to go back to the workstaion to do BTS as FEDIT that BTS uses to modify .sif files wont run in 2003. ( I still have to remove read only from .sif manually as well, so maybe thats somthing you could do ?)

Thanks for your effort.

Link to comment
Share on other sites


Here is a line of code:

Set colServiceList = objWMIService.ExecQuery("Select * from Win32_Service where Name='BINLSVC'")

If you notice the shortname for the service is defined as BINLSVC. I am wondering if you could check for me what the BINL service's short name is on 2003SBS. Perhaps it is different? If so maybe I can implement server version detection and change the shortname based on that.

If the shortname is the same, then I'm truly stumped and will have to investigate further.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...