Jump to content

[Discontinued] AutoRIS V2.10

Recommended Posts

Thanks although a OEM folder is also not present on the RIS structure?

Have a look at this thread the guy has exactly the same problem and said he fixed it. He has not gone into great detail how though. Have you any idea exactly what lines he would of amended?

Im looking at a ghost image of the disk taken just after that error and all the required files seem to now live in C:\$win_nt$.~ls\$OEM$


The thread is above

Link to comment
Share on other sites

This is what I get for answering questions before my first cup of coffee :P My mind was still over at CD\DVD installations. I'll put forth a better reply and hopefully an update once I get settled in for the day (and about 3 cups of coffee later).

Link to comment
Share on other sites

Thanks dude

Ive posted this also in another thread (Autoris problem)

OK I give up I just cant get this to work!

I really did want the mass storage drivers integrated however I was getting errors.

So I decided to go with the method 2 helper addon as the AutoRIS seems to be geeared towards that anyway and not really compatible with a full M2 slipstream and even that does not work.

I am still getting cannot find C:\Watchdriversigning.exe and other itterations depending on which method I use (as stipulated in PRESETUP.CMD)

I see the file is sat in the $1 folder on the ris server so theoretically it should be copied to the root of C however if I pause the setup after text mode reboot and look at the files on the harddisk with BART PE at that stage all the $1 folder is sat within a folder called $win_nt$.~ls so its no wonder setup cant find the file.

Any ideas at all guys cos this is really p***ing me off now lol

Link to comment
Share on other sites

This is basically the deal: I'm not going to mess around the BTS stuff too much because anything I do will only be obsolete the moment Bashrat releases the next generation of BASE. I've spent a lot of time figuring out what would be the best way to do it, and it's certainly doable, however it would take a bit of time to get it all proper and tested. Time I simply don't have when I know something newer and better is on it's way. What I'm going to do as a stopgap is put the pause in that I mentioned earlier so that if anyone would like, they can do the full blown integration on their own.

I personally never integrate the mass storage drivers into my RIS source because as of now, there's no need for it. I'm sure this may change and hopefully when it does, the situation with integration will have progressed. I can tell you that as a matter SOP, I use to always integrate the mass storage drivers and didn't have any difficulties with it, so it is possible.

I'm working on V1.52 as we speak and will look into any problems with the M2 helper, though I think in this case perhaps better documentation is all that's necessary. Also, V1.52 will contain some fixes in the form of newer NIC drivers and .inf files for the drivers. V1.51 has some issues with the Intel drivers.

Link to comment
Share on other sites

V1.52 - 02/10/2006

- The supplemental NIC drivers have been updated. There is still a conflict between the latest revisions of RealTek's NICs and their older integrated NICs. If you need to support only the older versions, you should remove the updated RealTek drivers from the NIC_Drivers folder.

- Automation for a full BTS DriverPack slipstream has been removed. In place is the old style "pause and wait" where you must perform the slipstream/integration on your own.

- The nLite sample .ini file has been updated to reflect nLite V1.0 RC6.

- Added Restricted Sites Zone protection to the cmdlines.reg registry tweak file.

Link to comment
Share on other sites

Hey RogueSpear

Thanks alot for your efforts in creating AutoRIS, much appreciated mate.

I was driving my self nuts trying to figure out why the BTS DPs Slipstream didnt seem to run... lol... time to learn vbscript methinks :blushing:

In regards to the WatchDriverSigningPolicy.exe error - is there anything I can do to to resolve this.... I mean is it a relatively simple fix or not? I setup/reload a heap of different PC's for people and use RIS with BTS DPs (Method 1) to ensure that I dont need to create Mass Storage driver setup disks.



EDIT: Just found this post -> http://www.msfn.org/board/index.php?showtopic=66624 so think I may be able to sort it. Thanks tho :)

Edited by Judge_MC1
Link to comment
Share on other sites

Man I seriously don't see what all the grief is with these two .exe files. You can do things one of two ways: either keep the files on the CD/DVD and execute them from there or copy them to the root of your system drive and execute them from there. If your presetup.cmd file is looking for them on the CD then it will obviously fail if they're on the hard disk and vice versa.

With RIS you're limited to executing them from the system drive (unless for some reason you want to overcomplicate things and require a CD in the drive). Here is the presetup.cmd that is in the Method 2 helper for RIS:

7za.exe x -y -aoa %SYSTEMDRIVE%\DriverPack*.7z -o"%SYSTEMDRIVE%"
7za.exe x -y -aoa %SYSTEMDRIVE%\000_WinDir.7z -o"%SYSTEMROOT%"
START %SYSTEMDRIVE%\WatchDriverSigningPolicy.exe
DEL %SYSTEMDRIVE%\DriverPack*.7z
DEL %SYSTEMDRIVE%\SetDevicePath.exe

Now, you get SetDevicePath.exe and WatchDriverSigningPolicy.exe onto the system drive either by placing them within $OEM$\$1 in your RIS image OR you could place them inside one of your DriverPack 7z archive files. Either way they will end up where they need to be in time for execution. Something I've been doing for a while now is making one big huge DriverPack file called DriverPack_All.7z and the two exe's are inside of that. I find that the copy operation and the decompression runs a little faster when it's one file instead of a dozen or so files.

Finally, later during RunOnceEx, the BTS_Finish.cmd is excuted and then all of the extraneous files are cleaned up.

Link to comment
Share on other sites

Hey it's no problem.. I just think that all the recent discussion about this has only served to make the issue a little more confusing. Unfortunately the way that things are at the moment, they just aren't perfect. I'm hopeful that with BTS's forthcoming updates, a lot of these issues will be easily resolved and made automatic.

Link to comment
Share on other sites

Hi rogue thanks for the update but I still have the exact same problem as the guy that posted above.

I see where your coming from however I am still getting the error that it cannot find the file watchdriversigning.exe.

I know why it is but what I dont know is what im doing different to make all you guys not have the problem!

As i have explained before your presetup.cmd makes the PC look at C:\wathdriversigning.exe however my file which SHOULD be copied to C: root by being in $OEM$\$1 is simply not in that position after the textmode reboot.

All of the files are in $win_nt$.~ls\$OEM$\$1 if i take a look at the state of the harddisk with BART PE when the error occurs.

So I understand why it cant find the file because its not actually in the place where its looking. What I dont understand is why my OEM$\$1 is not at the root of C: at this stage and what I am doing wrong to make it still be in win_nt$.~ls\$OEM$\$1 at this stage!

Any ideas?

Link to comment
Share on other sites

OK thats fixed it! :thumbup

Thanks for all your patience and assistance!

Now the scripts are properly running ive noticed the amount of changes that your app makes to a standard windows installation. Many of which i dont want or need.

What i do want to do is disable firewall, disable fast user switching (im not joining a domain just a workgroup) and most importantly for me enable Remote Desktop. Have you any clues on how I would go about doing this?

thanks again

Link to comment
Share on other sites

I believe I disable fast user switching in the registry tweaks file.. take a peek in there.

"Start"=dword:00000004 ; Set Fast User Switching service to Disabled

Enabling Remote Desktop and disabling the Windows Firewall are both taken care of in the .SIF file.


Profiles = WindowsFirewall.TurnOffFirewall

Mode = 0

Edited by RogueSpear
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...