Jump to content

[Discontinued] AutoRIS V2.10

Recommended Posts


Running services.msc, Remote Installation Server is BINLSVC

From a command promt I can manually Start/Stop the service with "net start/stop binlsvc" on the server.

I have Also posted this Question in microsoft.public.windows.server.sbs yesterday with no reponse as yet.

How can I give a Domain Account the right to attach to WMI and restart the

BINL service on my RIS server.

I am running a VBS Script that remotely wants to attach to WMI and restart

the BINL service on my RIS server.

Edited by krismark
Link to comment
Share on other sites

The account you are using to attempt the service restart on the RIS server from your workstation is assigned to the Domain Admins group, correct? If so maybe try this: download PSTools from SysInternals if you don't already have it and run this on your workstation against the RIS server from a command line:

psservice \\RISSERVER restart binlsvc

Do not enter in a username and password. This way it will use the credentials of your user account that you're running AutoRIS from.

Edited by RogueSpear
Link to comment
Share on other sites


User is a member of domain admins:

Following id out put from psservice.exe

PsService v2.13 - Service information and configuration utility

Copyright © 2001-2004 Mark Russinovich

Sysinternals - www.sysinternals.com


DISPLAY_NAME: Remote Installation

Manages requests made by Pre-Boot eXecution Environment (PXE) - enabled client c

omputers. If this service is stopped, PXE-enabled client computers will be unabl

e to install Windows remotely or use other Remote Install (RIS) -based tools. If

this service is disabled, any services that explicitly depend on it will fail t

o start.




WIN32_EXIT_CODE : 0 (0x0)



WAIT_HINT : 0x7d0

Link to comment
Share on other sites

Ok, so according to your event logs, did the service restart? If so, I'm guessing there's a WMI issue here and this would suck, but I suppose I could call on psservice for 2003 servers instead of keeping it all internal. Would add yet another file to the download.

Link to comment
Share on other sites

I usually don't have DHCP running on the RIS server myself. I'm going to have to do some fooling around with psservice and also detecting the server OS. Shouldn't be overly complex, but I'd certainly like to know if anyone else is having this problem on a 2003 server, whether it's SBS or not.

Also, I think in the next version I'm going to include a .SIF file for the end user to modify to their needs and AutoRIS will copy it down to the Templates directory and at the same time delete the default .SIF file.

Link to comment
Share on other sites

Roguespear, I have been trying to use the AutoRis script, but have been unable to get it to work. The instructions are written very well, and it all makes sense, however when it gets to the RVM integration it errors out.

I am using this version of integrator: RVM_Integrator_1.0RC8.exe

I know your instructions say to use minimum V1.0 RC13 Beta 5, however Im downloading the above version straight from Ryan's site.

I get an error that is being thrown from the integrator (perhaps due to version), that states: Invalid # of Parameters: 2 is an invalid amount of parameters. Please check your syntax. I have verified my .ini quite a few times.

Then after I close the error, and get past nlite, if there are no files in the NIC folder, it errors out, and says "file not found"

My bigger concern is with the integrator. Any ideas?

Thanks for this handy little program, I will quite a bit of use out of it, as I do nothing but RIS installs.

Link to comment
Share on other sites

The version you are trying to use is unable to process the integrator.ini file. This functionality was only implemented starting with V1.0 RC13 Beta 4, though that version did have an issue with addon packs. The newer V1.0 RC13 Beta 6 corrected that problem. You can find the latest versions of the integrator in the Members Only forum on Ryan's site. All it takes to become a member is registration on the site.

Also thank you for pointing out the problem with the NIC_Drivers folder. That's an oversight I will try to correct tonight.

Edited by RogueSpear
Link to comment
Share on other sites

Always interested in anything RIS! Has anyone tried using AutoRIS to make an image and then RIPREPing an image to install to like machines? I tried with RISult and had no problem making the orginal image byt the RIPREPed images were trouble. Each an every device wanted to be reinstalled and and when they were reinstalled they reported that the "data invalid".

Link to comment
Share on other sites

I have been trying to use AutoRis with the 1.3.1 update pack, and I dont think it has worked for me. Im basing this assumption from the RVM_integrate.log file that says "access denied" to everything. Also the percent complete goes from 1 to 100 very quickly. Ive been unable to boot to my SP2 ris image after AutoRis does its magic. It tells me that the NIC driver is missing or corrupt even though its there and unmodifed by me. These systems are running the 3com 3c920 which is supported natively.

Ive also tried with the **edited to remove referenced s/w**, and I get the same "access denied" with its log file as well. However I was able to boot the ris image without the NIC error, but I encountered a different error. Unfortunately I didnt write it down, but it said there was an error in my .sif file on line 0 within section "LocalSourceDisks", and it referenced sp2.cab. Im pretty close on the verbage of this error, but I know its not 100%. If I duplicate it, I'll post the exact message.

Is this normal within the log? I can boot the SP2 image before AutoRis runs, so Im not sure whats going on as far as the NIC goes. Ive had to resort to the hotfixes being run from the $OEM$ (yuck) folder, until I get this sorted out.

Ive attached the log file in question.

Any help would be appreciated.


Edited by jguderian
Link to comment
Share on other sites

Off hand it sounds to me as though you have some NTFS permission problems going on or there's a lock on a file / directory. I am wondering if you could outline your entire procedure for me and specify what Windows Server version you are using. I'm curious to know if everything is working ok before the RVM integration. Are you running AutoRIS using a domain admin account?

Link to comment
Share on other sites

The RIS server is W2k server stabdard SP4. My workstation is Windows XP SP2. I am running AutoRIS out of C:\RISTEMP. My user Id that Im running all of this from is a an enterprise admin (domain admin). I have permissions to everything.

I was going to try AutoRis without the RVM integration, so when I do this I can post back with results.

Im unclear why the integration is looking at my workstations Windows directory?

Thanks for the help. Im looking forward to using AutoRis, its a great utility, and I appreciate your effort.

Link to comment
Share on other sites

Around line 219 of your code is " Set objWMIService = GetObject("winmgmts:" & "{impersonationLevel=impersonate}!\\" & RISSERVER & "\root\cimv2") " . It has been awhile since I coded but is that saying directory root\cimv2 on the RIS Server? I have errored out a time or two on this line and noticed that there was no \root\cimv2 on my RIS Server.

Thanks for the script.

Link to comment
Share on other sites

Without the integrator involved in the AutoRis script, everything works fine. I can boot to the RIS image, and I dont get the NIC error.

With the integrator, I still get the integrate.log file with all the "access denied" messages, and I was able to boot to the RIS image without error at the point AutoRis asks (During the .PNF creation). After AutoRis completes I can boot the RIS image without any errors (The NIC thing must have been a fluke). After it copies all of the files to the workstation, I get the following error:

The following value in the .SIF file used by Setup is corrupted or missing:

Value 0 on the line in section [sourceDisksFiles] with key "SP2.cab."

Setup cannot continue.

So it seems clear to me that the integrator is causing this problem, but Im unsure why? If I run the integrator seprately I get the same access denied issues.

Im still uncertain why the integrator is trying to do anything to my local workstations Windows directory?

Any ideas?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...