Jump to content

MS Office 2003 Fails To Install


dalsoth
 Share

Recommended Posts

Hi

I am having problems with MS Office 2003 installing using the RunOnceEx method. My XP unattended install goes fine then when it starts the apps part MS Office starts to install and you see the bar moving across then it goes backwards and quickly moves onto installing the next program in the list.

I had followed the MSFN guide on slipstreaming sp1 into office and creating the unattended.mst file to run the setup.exe but that failed so i tried with just running the pro11.msi and that did the same thing.

Heres a part of my file:

REG ADD %KEY%\000 /VE /D "MS Office 2003 SP1" /f
REG ADD %KEY%\000 /V 1 /D "%systemdrive%\install\Applications\Office2003\PRO11.MSI /qb-" /f

This was the original:

REG ADD %KEY%\000 /VE /D "MS Office 2003 SP1" /f
REG ADD %KEY%\000 /V 1 /D "%systemdrive%\install\Applications\Office2003\setup.exe TRANSFORMS=Unattended.MST /qb-" /f

Any ideas why it just fails? :wacko:

Thanks

Edited by dalsoth
Link to comment
Share on other sites


I dont think i even installed the dot net framework as i dont think its part of the hotfixes on ryans site is it? I only installed his main hotfix update and not any of the additional things like the framework and adobe reader etc that is listed seperately.

Link to comment
Share on other sites

Trying to run the msi file by itself won't work. Mine is similar to your original, though now I run all install from the DVD because there are too many and it saves time copying. Even with the slipstream you need to use the setup.exe file and the transform file. The only real difference is that it makes no hiddden msocache folder because a slipstream is by definition an administrative install point. I made mine from a 10-in-1 CD that I made from the five original CDs using an AIO maker.

It sounds to me as if your slipstream glitched somehow. Try the install the normal way (not silent) and see what happens. That revering bar just means it is erasing and cleaning up after a failed install. Are you trying this on a virtual machine?? Make sure you give yourself enopugh space. I use at least 5 or 6GB to test with and even that is gettting thin as I add programs. If you are copying everything over first, you may be running out of room.

Oh, and .NET Framework wouldn't have anything to do with it. That's one of the first things I install in my unattendeds. I put it in so no one will be bothered by nagging from MS for it. Anyway, it is an environment that is becoming more and more important to have.

Edited by DonDamm
Link to comment
Share on other sites

I noticed that you're using "TRANSFORMS=Unattended.MST"

You made an Administrative Point?

I don't sure but I think that if you make an Administrative Point you don't have to use the mst file

Sorry for my English

Edited by ozwaldo
Link to comment
Share on other sites

I followed the advanced guide on the unattended site here to slipstream office and set it up using the office resource kit etc..

I will have another go, maybe it just failed somewhere along the line like it was suggested above.

Thanks for the help i will see what happens in a few days when i try again.

Link to comment
Share on other sites

I suspect that the install is failing because of a path problem since you don't specify the path to the MST file. Take off the trailing "-" in the following line:

REG ADD %KEY%\000 /V 1 /D "%systemdrive%\install\Applications\Office2003\setup.exe TRANSFORMS=Unattended.MST /qb-" /f

And see what the error is...

You also could follow the instructions here:

http://office.microsoft.com/en-us/assistan...1717621033.aspx

replacing any of the network location information with correct locations on your DVD. Editing the setup.ini file w/MST & chaining in the SP1 hotfixes using this method makes it easy to add in othe hotfixes in later builds, and also enables the Local Install Source for Office 2k3.

Glenn Fincher

Link to comment
Share on other sites

i used the ofice shinker for mine, but i had office XP.

it WAS working, i made many unattended installs where it worked, but in my laast "revision" of "my" nlited windows, i have the same problem.

i think that some new update or some tweak i made with nlite is conficting with the shinked install.

a manual install of what i want to use, but with the full cd, after installing windows, does work.

Link to comment
Share on other sites

i think that some new update or some tweak i made with nlite is conficting with the shinked install.

a manual install of what i want to use, but with the full cd, after installing windows, does work.

i think i hav d same problem... but mine is installing fine... but when i try to run word, excel or powerpoint, the wind0ws installer dialogs pops up & crashes the app... cant find the solution.... :angry:

Link to comment
Share on other sites

I have the exactly the same problem. Followed the office shrinker guide religiously but the office install just goes back on itself and doesnt install anything whatsoever.

Wanted everything to fit on 1 cd, but have since given up after many installs and resorted to sticking the full 600+ mbs with an unatteneded.mst on a dvd. Oh well.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...