Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Petr

Service pack for Windows 98 Standard (First, Gold)

Recommended Posts

better the 4.10.2228 of secur32.dll file, Petr.  DCOM 98 has secur32.dll file v4.10.2177 and using 4.10.2000 may break v4.71.3328 of dcom98 and the W9x DSClient.
So I have checked internal timestamp of the files

4.10.2000 (Q266772): 396BA333h -> 07/12/2000 00:44:03

4.10.2228 (Q266772): 395CAC8Ch -> 06/30/2000 16:19:56

4.10.2177 (dcom98): 36FC8E56h -> 03/27/1999 08:52:54

4.10.2177 and 4.10.2000 have exactly the same exports and imports, 4.10.2228 has 3 new exports:

DecryptMessage

EncryptMessage

SspiLogonUserA

These functions are not used by any other module.

There is an interesting MSKB article 286261 - Conflicts between the Active Directory Client Extension and Windows 98 hotfix files. I will keep 4.10.2228 in the FESP.

powercfg.cpl 5.0.3103.1000 does NOT work under Win98 FE, Petr.  Tried using that and loading the Power Management control panel app in Win98 FE did NOTHING!  So Powercfg.cpl v5.0.3103.1000 is for Win98 SE only AND the Q258680 patch is really meant only for Win98 SE (NOT FE).
Yes, powercfg.cpl needsfunctions unsupported in FE versions:

batmeter,dll: DestroyBatmeter

pwrprof.dll: GetCurrentPowerPolicies

Do you think that it safe to keep in fesp just the desk.cpl? I suppose it could be OK.

Edited by Petr

Share this post


Link to post
Share on other sites

Do you think that it safe to keep in fesp just the desk.cpl? I suppose it could be OK.

absolutely, Petr. The desk.cpl file from the Q258680 patch works fine under 98fe. I even put it on my WinME system and it worked w/out any problems.

Share this post


Link to post
Share on other sites
General characterstics:

1. This SP is based on Gape's SP 2.0.1 for SE.

2. Contains all available (to me) updates and hotfixes for Windows 98 Standard Edition including IE/OE4.01SP1

3. Added Windows Update Engine/Client 5.3.3790.13

4. Added updated fonts

5. New hotfixes common with SE: Q240896, Q896358, Q323708, Q314941,

6. Updated Jpegim32.flt, Html32.cnv, Msconv97.dll, Mswrd832.cnv, Mswrd632.wpc

7. Uninstall almost broken, similar to SESP.

8. Semi-slipstreaming should work, not tested

9. Preserving should work

10. Tested on W98 fresh install, W98+IE5.5SP2 and W98+IE6.0SP1, system appears to be functional.

11. I sure fogot something important :-)

Please test and let me know, it could be possible that some hotfixes cannot be used for all possible configurations.

Any success / failure reports are welcome.

Petr

Q896358, Q888113, Q835732 patches require IE 5 or better. Those patches break IE 4.x. I know for sure if you run the Win98 Q896358 & Q888113 updates, they may still not work unless you are using Win98 + IE6 SP1. If using Win98, but using IE6, IE 5.5 SP2 or less, those patches refuse to install.

like to see ie4.01 sp2 or even ie5.x or 6.x integrated in Petr's 98 FE SP and Gape's 98 SE SP someday. sure the WinXP SP2 pack is massive (full sp2 pack is 280 Mb in size) but contains IE6 SP2, DX9.0c, MSI 3.0, WMP9, MDAC 2.8 SP1 & other addons included in one gigantic pack.

DSClient Q323455 Win98 update addresses many or even all the issues mentioned in MS article 283261. The older version of DSClient (included in Win2000 CDs) have the problems mentioned in article 283261.

Share this post


Link to post
Share on other sites
Q896358, Q888113, Q835732 patches require IE 5 or better.  Those patches break IE 4.x.  I know for sure if you run the Win98 Q896358 & Q888113 updates, they may still not work unless you are using Win98 + IE6 SP1.  If using Win98, but using IE6, IE 5.5 SP2 or less, those patches refuse to install.

Q896358, Q888113 installs if SHDOCVW.DLL is version 5.50.4807.2300 and newer - i.e. IE 5.5SP2+

Q323255 contains HTML Help 1.4 (5.2.3644.0) and will install for SHDOCVW 5.0.2014.213 and newer, i.e. IE 5.0 (no SP) and newer.

Q811630 contains updated HTML Help 1.4 (5.2.3735.0) and will install for SHDOCVW 5.0.2014.213 and newer, i.e. IE 5.0 (no SP) and newer.

Q896358 contains HTML Help 1.41 (5.2.3790.309) and will install for SHDOCVW 5.50.4807.2300 and newer, i.e. IE 5.5 SP2 and newer.

These are restrictions in the iexpress packages, but what is the reality?

I also don't know how to verify Q891781 DHTMLED.DLL 6.1.0.9231 functionality with older versions of IE, iexpress package will install if BROWSEUI.DLL version is between 5.0.2014.200 and 6.0.2900.0, i.e. IE 5.0 (no SP) to IE 6.0 SP2. But will it work with IE4? And is it important?

And how to verify Q888113 HLINK.DLL 5.2.3790.227 functionality?

Q835732 - it is backported patch from NT Workstation 4.0, in the system requirements, mentioned in MS04-011, there is no information about Internet Explorer version.

Is there any way how to verify the functionlity of updated files?

In fact, I think IE4 is useless today anyway.

like to see ie4.01 sp2 or even ie5.x or 6.x integrated in Petr's 98 FE SP and Gape's 98 SE SP someday.  sure the WinXP SP2 pack is massive (full sp2 pack is 280 Mb in size) but contains IE6 SP2, DX9.0c, MSI 3.0, WMP9, MDAC 2.8 SP1 & other addons included in one gigantic pack.
It would mean much work with unknown result. As of FESP, I'm sure I won't do it. Several days I have put FESP to rapidshare and now there are 3 (!) downloads only - you, MDGx and maybe Gape. I suppose to fix the biggest problems and leave FESP as it is.
DSClient Q323455 Win98 update addresses many or even all the issues mentioned in MS article 283261.  The older version of DSClient (included in Win2000 CDs) have the problems mentioned in article 283261.
Right, therefore all files are upgraded to Q323455 version. Maybe I should add also negotiat.dll, it is not in W98 bas install but if anybody has installed the old W2K client, it would be updated from 5.0.2195.1 to 5.0.2195.4784.

Petr

Share this post


Link to post
Share on other sites
It would mean much work with unknown result. As of FESP, I'm sure I won't do it. Several days I have put FESP to rapidshare and now there are 3 (!) downloads only - you, MDGx and maybe Gape. I suppose to fix the biggest problems and leave FESP as it is.
Things I've done to help spread the word about your SP:

- I put a link at my front page [i have ~ 4000 unique hits/day]:

http://www.mdgx.com/

- I added a link here:

http://www.mdgx.com/web.htm#SP1

- and here [98SE2ME forum]:

http://www.msfn.org/board/?showtopic=46349

Things you can do to spread the word:

- ask Gape if he would like to make your topic a "sticky".

- edit the 1st post here, add the rapidshare link and a few words about the SP at the top.

- email Jim or Tim @ MajorGeeks [they are buddies of mine, u can mention my name if u think it helps]:

http://www.majorgeeks.com/page.php?id=2

- as you should email Danny Boss @ SoftPedia:

http://www.softpedia.com/

- email a few other high visitor hit count news web sites, I would suggest at least:

- WinXPCentral [Digital Dave is a buddy of mine, u can mention my name if u think it helps]:

http://www.winxpcentral.com/

- TechSpot [Thomas McGuire is a buddy of mine, u can mention my name if u think it helps]:

http://www.techspot.com/

- Fred Langa @ LangaList [Fred is a buddy of mine, u can mention my name if u think it helps]:

http://www.langa.com/

- PC World:

http://www.pcworld.com/

- Scot Finnie:

http://www.scotsnewsletter.com/

- Warp2Search:

http://www.warp2search.net/

- BetaNews:

http://www.betanews.com/

- NeoWin:

http://www.neowin.net/

Hope this helps.

Edited by MDGx

Share this post


Link to post
Share on other sites
Things you can do to spread the word:

Hi MDGX, I suppose it is too soon to sent this alpha version to the general public. I need more test results before this. Too many files are updated, not the same as in SE package.

Petr

Share this post


Link to post
Share on other sites
Things you can do to spread the word:
Hi MDGX, I suppose it is too soon to sent this alpha version to the general public. I need more test results before this. Too many files are updated, not the same as in SE package.

Petr

Roger that.

Share this post


Link to post
Share on other sites

Small bugfix: http://rapidshare.de/files/2723154/fesp201en-a2.exe.html

SFV: 4DE59716

MD5: 0abf6d68a3582af75072481a1395c2c3

Changes:

- negotiat.dll added

- powercfg.cpl removed

- kswdmcap.ax, joyhid.vxd, msmouse.vxd 1024 -> 1056

- esdi_506.98G removed

- mqrt.dll from SDK folder removed

- explorer without "Second Edition banner"

- use HKLM,%KEY_RENAME%\IO.SYS,,,%30%

- explorer.exe from ie4.01sp2

- wbemprox.dll update added

- atl.dll 1028 -> 1056

- small correction of KB article numbers in SPUPDATE.INF

Petr

Share this post


Link to post
Share on other sites

Good work, Petr. I tested it briefly.

BTW, I am going to finish my master degree soon. So, I was very busy in the June. I hope I'll back to work on the SP after the July 8.

Edited by Gape

Share this post


Link to post
Share on other sites

Your new alpha 2 SP works great on my "from scratch" 98FE install.

I've also tried it on a new setup + MS IE 6.0 SP1 + DirectX 9.0c, with same results.

Keep up the good work, Petr.

PS:

If I [ever] find the time, I consider a couple of new projects: 98FE298SE + 98FE2ME. :)

Share this post


Link to post
Share on other sites

I'll admit I don't have 98FE but I think the servicepack is an excellent idea. If I only had FE this would be terrific for doing fresh installs. If your tiring of it go ahead and put it on the backburner for awhile.(I'm sure everyone understands it's done in your free time and you have a life offline too.) I would second the motion for a sticky. Keep up the good work. :thumbup

Jaymo

Share this post


Link to post
Share on other sites
Just wondering if you can silently install the Win98 FE SP like you can with Gape's Win98 SE service pack?

Not tested, but it should be the same.

Petr

Share this post


Link to post
Share on other sites
Q192117 - DNS Settings Not Saved If DUN Installed During Batch Setup

  File name  Version    Date     Time    Size
  ---------------------------------------------------
  Mstcp.dll  4.10.2012  6/23/98  9:26am  39,280 bytes

I have just gotten the Q192117 mstcp.dll hotfix from Microsoft though it took 2 tries. First time I tried asking, I got a less than intelligent response from a support rep. that Win98 support has been retired. So I asked again and then a different support rep gave me the patch. Email me Petr and I'll be able to give it to you later today.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...