Jump to content

Framedyn.dll and Srclient.dll missing


Recommended Posts

FYI in the Audioshell Addon, the AudioShe.inf is MISSING a ; at the begining of the first line. If you place a " ; " there, framedyn.dll and srclient.dll errors should disappear on systems where you are installing Audioshell Addon.

I just did a test where I ran Integrator 1.2.2, RVM 2.03, 2.04 and 2.05 and ONLY added Audioshell. That was it, nothing else. I didn't even make it unattended to simplify things. Received framedyn.dll and srclient.dll errors. I then corrected the INF after discovering the issue and burned a new ISO with the corrected file, and obtained a perfect install.

Link to comment
Share on other sites

  • 1 year later...

So explain to me how did you manage that please?

Clean Windows installation files?

Then RVM integrator or what?

Then nlite with what preset, attach it...

Link to comment
Share on other sites

And sometimes it is not as simple as a single addon either!

I had this problem for over a month before finally working out which two addons were responsible - both worked perfectly on their own and each had worked fine in previous versions but I had one particular combination that just didn't want to play ball. Took hours and hours to track down.

Link to comment
Share on other sites

Mandarin, how about some details, it's fixing time at the nLand?

Both addons have been updated several times since so I don't see the value in you spending time on those particular ones. But for info one addon was Foxys Nirsoft Collection large v1.5 which would never work for me with Kels Uber pack v9.9.5. Changing either would solve the problem and I don't get the issue with either of the updated addons.

I can understand Ricktendo's issue because both of those addons are variations of each other - you would never usually use both together on the same system.

Link to comment
Share on other sites

  • 1 month later...

Ran into some problems today.

First i did wmp11 with booogies tool.

Then i used nlite to integrate those.







This was the first error i ran into, got it 4 times i think.


Then later when i came into windows, it came with Framedyn.dll and Srclient.dll, my internet explorer was greyed out aswell.

This is with the lastest release of wmp80 from boooogie and nlite beta 1.4

edit; forgot to mention this was on a clean xp pro x86.

Edited by wazer
Link to comment
Share on other sites

  • 3 months later...

i got this error today after using Nlite version 1.4 (which i presume is the latest) to only update a Windows XP sp2 CD (msdn original cd) with one hotfix, namely kb888111xpsp2.exe, i did not use any other tool like Ryan's ones mentioned earlier in this thread.

once I apply the hotfix i click on the make iso button and then i'm done, final step is to mount the completed iso in daemon tools and run rissetup to 'add new image' on my RIS server.

steps to reproduce:-

1. start nlite, point to c:\xp_source when asked.

2. click next and ignore any last session, then next

3. select 'hotfixes addons and update packs' and 'bootable isos' and click next

4. on the hotfix page click insert and point to path of hotfix exe file C:\hda hotfixes\hotfix2\KB888111_Supported_OS_All_Languages\us\x86fre

5. click next, click make ISO.

6. once done, close nlite, open daemon tools, select mount image, browse to winlite.iso

7. click start, at run type 'rissetup' click add new image and it'll complete adding your edited windows xpsp2 cd iso.

8. pxe client computer to test the above

so whats going on here ???

additional note, during RIS setup.exe complains that it cannot find/copy nlite.inf, and I resolved that by doing this



Edited by anyweb
Link to comment
Share on other sites

i've just resolved the Framedyn.dll error described in the post above.

it seems the nlite.inf error mentioned above is giving a clue to the issue, as once i manually expand the file and copy it to my RIS source, the installation proceeds with no errors and the Framedyn.dll error is now gone.

can anyone explain why the nlite.in_ file remains compressed ???

i'll start searching the forums now to figure out why that is happening....

Link to comment
Share on other sites

  • 8 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...