Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
SiMoNsAyS

[How To]: ATI Catalyst

Recommended Posts

I started trying this, but most of it does not work

Nothing goes to the temp file.

Instead you can go to the Windows\Installer folder and pull the MSI's

However I am stuck running hte batch file method. Since I have an AMD processor I have to install the AGP driver and the SmartGART drivers before the ati program. :(

I would say it could work even with an AMD, but since I ran into massive errors on my first install, I am going to have to do it differently.

Thanks for the great info :)

EDIT:

I Just looked at your sig, we have **** near identical systems

I am running a 2400, on a A7N8x rev 2 board with 320GB of maxtor drives and 1and a quarted GB of RAM

Gonna have to try and wrap my brain around this.

Share this post


Link to post
Share on other sites

when are you running the batch file?

I use OEMPnPPath for the base drivers, then run the driver setup (for SmartGart) and the CPanel Setup using RunOnceEx with the /K switch. Works great for me.

As for "extracting" the drivers, I guess they changed their compression method and you can no longer open the downloaded files with winrar. I just downloaded the individual packages, then ran the exe and it asks where you want extract files to, then it extracts the files and runs the setup. just cancel the setup, and the extracted files will still be in the specified location.

Share this post


Link to post
Share on other sites

my drivers are perfectly installed :huh:

i suppose is because you run installation before runonce, did you run it from cmdlines?

try to install at a later point on windows setup...

Share this post


Link to post
Share on other sites

Ahh, thanks for the info.

Yeha I am going back to the runonce method.

I tried beingtricky last time and loading hte agp/smartgart during hte driver install. Think I should just do it all at runonce.

ECHO.
ECHO Installing ATI Catalyst Software
ECHO Please Wait
start /wait %systemdrive%\install\ATI\Setup.exe -s

Just going to go back to this method though

It stinks that I cant test it in VMware :(

Share this post


Link to post
Share on other sites
It stinks that I cant test it in VMware :(

it's the worst thing about catalyst, if card is not present then drivers won't be installed :}

... but an advantage for people using their unattended cds with different machines and hardwares ... :P

Share this post


Link to post
Share on other sites

There are 2 'easy' solutions: (in fact 3)

1. De-attach all harddisks temporarily and use a spare (small) one for testing purposes.

2. Create an extra partition, only for testing. I'd recommend also to use a bootmanager. (so you don't have to edit your boot.ini over and over again)

3. Buy a spare computer B) :w00t::thumbup

Share this post


Link to post
Share on other sites

Well the third is not really an option if I am looking to create a UA cd for this system ;)

I think I might just be trying to do too much. :(

Istarteed creating an XP bootable

That worked

Then an XPSP2 bootable and that worked

Instead of trying to make a UA XPSP2 Bootable I went straight to making a super CD with about 20 appz included a 6KB registry tweak etc etc

Since CDs are cheap (and I even have 1 CDRW) I should have built up to it.

make a driver pack XPSP2 bootable

Then work on incorporating my themes and sounds

then add reg tweaks

then add appz

that why I could better diagnose the errors.

sigh.... If this super DVD does not work I will try it that way LOL

Share this post


Link to post
Share on other sites

why check 4 times for the atiddc.dll file?

this is a lot "cleaner": :P

IF EXIST %SYSTEMROOT%\system32\atiddc.dll (
reg add everything and more..!
and do lots of stuff here
you can even add commands here;)
)

Share this post


Link to post
Share on other sites

@Afterdawn and why not? :P (j/k)

your code is shorter that's ok but doesn't matter if you check it 1 or 4 times ;)

Edited by SiMoNsAyS

Share this post


Link to post
Share on other sites

Well.. because the file may not be there the 3rd or 4th time you'll check it! ;)

I'll bet you like to program like this ;) :

if (boolean1 == true)
  boolean2 = true;
if (boolean1 == false)
  boolean2 = false)

Maybe I'm just a perfectionist.. yes that's it. I am going crazy to make the perfect unattended CD... I spend hours (if not days) to search for a specific registry tweak in order to replace the manual work (which costs me less then minute to perform i guess). I'm nutts! :yes:

But i can't help it! I *must* create perfect unattended CD! Cannot stop anymore... it's tooo late now! :o

Share this post


Link to post
Share on other sites
Well.. because the file may not be there the 3rd or 4th time you'll check it!

I'll bet you like to program like this :

if (boolean1 == true)
  boolean2 = true;
if (boolean1 == false)
  boolean2 = false)

Maybe I'm just a perfectionist.. yes that's it. I am going crazy to make the perfect unattended CD... I spend hours (if not days) to search for a specific registry tweak in order to replace the manual work (which costs me less then minute to perform i guess).  I'm nutts! 

But i can't help it! I *must* create perfect unattended CD! Cannot stop anymore... it's tooo late now!

hehehehe :D:w00t::thumbup

Welcome to my world! :D

Share this post


Link to post
Share on other sites

Hi SiMoN,

Finally with the 5.1 rev, do we need to play the guide or just using the /K switch ??? with a commad line in RunOnceEx like :huh:

REG ADD %KEY%\055 /V 1 /D "%SYSTEMDRIVE%\ATI\wxp-w2k-catalyst-8-09-041221m-020455c.exe /K" /f

Does anyone tested the /K switch working???

Regards

coucou

Share this post


Link to post
Share on other sites

@coucou sorry but you can, the file you're using is a package that contains the main installation. notice after executing the folder ATI on your %systemdrive%.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...