Jump to content

HFSLIP (original thread)


tommyp
 Share

Recommended Posts

what about encpack? (high encryption pack for win 2000)

is the integration of this pack also possible with your method?

another nice integration would be kb888111 (i guess it works)

sry if these questions were already asked, i just have no time to look through 39 pages ...

Link to comment
Share on other sites


With non-English applications like Adobe and such, I do not slipstream foreign applications like that.  Your best bet would be to visit unattended.msfn.org and read up there.  The intent of HFSLIP isn't to support all of your unattended installation needs.
I know... I was just wondering if anyone was aware of similar projects to RyanVM's for Dutch switchless installers.
As far as the rootsupdate goes, if you visit WU and it says you are missing the rootsupdate file, then you'll have the correct download for your localized source.
I'll do that. Thanks.
Link to comment
Share on other sites

what about encpack? (high encryption pack for win 2000)

is the integration of this pack also possible with your method?

another nice integration would be kb888111 (i guess it works)

sry if these questions were already asked, i just have no time to look through 39 pages ...

VCI, welcome to the board. It was a good thing you didn't read through the 39 pages because you are the first to ask. Do you have links for these? Is encpack only for IESP5?

Link to comment
Share on other sites

high encryption package:

http://www.microsoft.com/windows2000/downl...ded/encryption/

http://www.microsoft.com/windows2000/downl...on/download.asp

maybe it was included in sp4 or already earlier, i dont know ;-)

i also don't know if it is just an IE-enhancement (ssl or whatever) or also needed for EFS (encrypted file system)

kb888111:

http://support.microsoft.com/default.aspx?...kb;en-us;888111

this is also included in ryan's vm update package for winxp sp2, i didnt found a link on microsoft to download it ...

just downloaded it from here:

http://support.asus.com/download/download_...ct=3&model=Z91E

direct link:

http://dlsvr01.asus.com/pub/ASUS/nb/Z91E/UAA_XP_050606.zip

this archive contains the fix for almost any language and both xpsp1/sp2/win2ksp4

edit:

okay, i found it how to integrate the high encpack ...

To preinstall and deploy the High Encryption Pack on all computers 
  1. Insert the High Encryption floppy disk into a computer's floppy
     disk drive.
  2. Copy Rsaenhs.dll from the floppy disk to your distribution
     folders in the \\<server>\<share>\i386\$OEM$\$$\System32

http://www.microsoft.com/windows2000/docs/encread-RTM.txt

never thought that microsoft puts useful information in their readme *g*

edit2:

okay ... found rsaenh.dll in the system32 folder

rsaenh.dll file version: 5.0.2195.6611 filesize: 134 928 bytes

dll included in high enc package is: rsaenhs.dll

rsaenhs.dll file version: 5.0.2150.1 filesize: 134 416 bytes

(different filenames? O_o)

hmm ...

Edited by vci
Link to comment
Share on other sites

All links are dead except for the sound driver one (which seems to be sound card specific). See if you can get the microsoft executable hotfix and I'll investigate.

The rsaenh seems to be one not to be worried about. Following the procedure that will be in the upcoming hfslip release will have the 5.0.2195.6611 revision. At least the revision on my machine has 5.0.2195.6611 anyway.

Hope this helps.

TP

Link to comment
Share on other sites

for me every link works quite fine (which browser do you use?) ... and if you downloaded the package i linked directly you would have seen that it is not card specific (or take the first link and scroll down untill you reach kb888111)

upped the kb888111 for w2ksp4 (english):

http://www.antischily.de/files/kb888111w2ksp4.exe

the original package is about 50mb because it contains many languages and all versions for each os ...

edit:

another try:

test this

another

i guess your browser has problems with the additional ... in the link (this board modifies the links so that they dont get to long ... it reduces the length and puts ... to show that it is a link which has been shortened, i guess your browser takes them as they stand here ... i use mozilla 1.7.11 and have no problems with that, just try the 2 links above, they should work)

Edited by vci
Link to comment
Share on other sites

@vci - the high encryption pack has been included as part of service pack 4. It used to be a separate download because it used encryption methods that were copyrighted by some branch of the U.S. government. Under the terms of the copyright, U.S. citizens/resident could get the high encryption pack download, but non-U.S. citizens/residents could not.

As a result, M$ would (as required by law) allow you to download the high encryption pack only after you had certified that you were a U. S. resident/citizen.

The copyright ran out sometime in 2000 I believe. As a result, the encryption method became public property and everybody (M$, Linux, BSDs, UNIXes) was free to incorporate the high encryption algorithms directly into their OS.

I believe WinXP is 128 bit encryption out of the box and Win2k included high encryption commencing from SP2 on.

http://www.microsoft.com/windows2000/downl...sp2/default.asp

@tommyp FDV's fileset is great. Kudoes to him and you. I just wanted to rip out a few more things (like non-English languages, defrag and disk cleanup utilities, easy access) that I never use.

It's not critical to remove them, and I'm not going to cry if I can't get them out using FDV's fileset, I just wanted to see if it was possible. FDV already told me how to get rid of some of this stuff (easy access, defrag and disk cleanup), but I was wondering if he had in his collection of modded .INFs a languague .INF where I could ; the languagues I didn't want.

Link to comment
Share on other sites

thx for this detailed info :thumbup

to fdv'files:

yea, i also tried to nlite them, doenst work:

[nlite scanning for i386 folder]

1. error: nettcpip.inf -> continues

2. error: netmscli.inf -> continues

3. error: sth about sfc.dll, stops responding

tried to copy some other sfc.dll to the i386 folder in advance, and copy the fdv-sfc.dll back when nlite finished scanning, only tried to removed items which are not touched by fdv-files (like languages and other)

but anyway, when processing the files, he also stops responding

would be great if his fileset is compatible ... anyway i didnt manage to make his plain-fileset + hotfixes to work (without any mods!)

win2k setup returns an error and quits ...

Link to comment
Share on other sites

@vci - I meant to say that the download links for the MS 888111 weren't there. I saw the one MSFT link you posted. I guess it was poor penmanship on my part. What does this particular 888111 do? Any benefits? Thanks for posting the DL... I'll digest it for slipstreamibility and let you know. Also, with FDV's fileset. Your best bet would be to either make manual changes to the INF files and either pack them into the FIX folder or in the FDVFILES folder. I'm sure FDV will chime in when he reads this.

Link to comment
Share on other sites

This is maybe a dumb question but I'll take my chances... :D

Does anyone know where to get the "agent" (or whatever it's called) for Windows Update v4?

The regular WU site works with v6 (I have that) but the Catalog is still on 4...

My apologies if this was asked before but I've tried a search for "windows update v4" and couldn't find an answer.

Edited by Tomcat76
Link to comment
Share on other sites

Guys,

First of all thanks for all what you are doing!

However, I'm stumped. I've tried different ways following the guidelines and comments here but I'm getting the following error when trying to install:

"Setup was unable to copy the following file: mpeg2data.ax"

Can anybody tell me what I am doing wrong?

Thanks!

Link to comment
Share on other sites

I thought I could read :blushing:

I've read the entire thread, You guys have done some great work :thumbup

Aparently the directions are not clear enough yet for someone like me. I would be happy to help out with specific step by step instructions for the program once I'm able to make it work for me.

On my second attempt I decided to document the steps I took according to my interpretation of the directions. Hopefully this will help me learn by pointing out where I went wrong and help to develop the manual for this great program.

1)

c:\HFSLIP

Double-click the CMD file to automatically create the folder structure. The program will automatically terminate.

2)

Use XPpro copied from cd, (slipstreamed with sp2 via manual method.)

3)

Copy the i386 directory and WIN51, WIN51IP, Win51ip.sp2, to the SOURCE folder.

4)

Download all the hotfixes for your OS and do not rename them.

Put the Hotfixes into the HF folder

(these are the hotfixes I used)

DECCHECKSetup.EXE

dxsdk_aug2005.exe

dxwebsetup.exe

hmtcdwizard_enu.exe

IE6.0sp1-KB823353-x86-ENU.exe

MP10Setup.exe

NDP1.1sp1-KB886903-X86.exe

wgainstall_9160b6b3929938243b7d18417810677d9b9983b7.exe

WindowsInstaller-KB893803-v2-x86.exe

Windows-KB890830-V1.7-ENU.exe

WindowsXP-KB842773-v2-x86-enu.exe

WindowsXP-KB867282-x86-ENU.exe

WindowsXP-KB873333-x86-ENU.exe

WindowsXP-KB873339-x86-ENU.exe

WindowsXP-KB883939-x86-ENU.exe

WindowsXP-KB885250-x86-ENU.exe

WindowsXP-KB885835-x86-ENU.exe

WindowsXP-KB885836-x86-ENU.exe

WindowsXP-KB886185-x86-enu.exe

WindowsXP-KB887472-x86-enu.exe

WindowsXP-KB887742-x86-ENU.exe

WindowsXP-KB887797-x86-enu.exe

WindowsXP-KB888113-x86-ENU.exe

WindowsXP-KB888302-x86-ENU.exe

WindowsXP-KB890046-x86-ENU.exe

WindowsXP-KB890175-x86-ENU.exe

WindowsXP-KB890859-x86-ENU.exe

WindowsXP-KB890923-x86-ENU.exe

WindowsXP-KB891781-x86-ENU.exe

WindowsXP-KB893066-v2-x86-ENU.exe

WindowsXP-KB893086-x86-ENU.exe

WindowsXP-KB893756-x86-ENU.exe

WindowsXP-KB894391-x86-ENU.exe

WindowsXP-KB896344-v2-x86-ENU.exe

WindowsXP-KB896358-x86-ENU.exe

WindowsXP-KB896422-x86-ENU.exe

WindowsXP-KB896423-x86-ENU.exe

WindowsXP-KB896428-x86-ENU.exe

WindowsXP-KB896727-x86-ENU.exe

WindowsXP-KB898461-x86-ENU.exe

WindowsXP-KB899587-x86-ENU.exe

WindowsXP-KB899588-x86-ENU.exe

WindowsXP-KB899591-x86-ENU.exe

WindowsXP-KB900930-x86-ENU.exe

WindowsXP-KB901214-x86-ENU.exe

WindowsXP-KB903235-x86-ENU.exe

WM9Codecs.exe

5)

Double click the CMD file to slipstream hotfix binaries

-security box poped up for WMP10, I selected "run".

-received error notice...not applicable to system32 or something like

that (it doesn't stay up long enough to write it down)

6)

skiped Nlite the SOURCES folder stuff (for now)

7)

From the SOURCESS folder (which contains only the i386 directory, WIN51,WIN51IP, & Win51ip.sp2) create a bootable cd - I used Nlite to make a bootable iso

8)

Test using MSvirtualPC

RESULTS:

setup loads files and restarts... "press any key to boot from cd..." comes up.

(startup fails) the VM continues trying to restart Windows over and over again

Edited by Outatouch
Link to comment
Share on other sites

hi folks just got back from a few days away, some VERY quick answers

@saugatak - i always had to keep other languages in due to users from other countries, so i never did the research as to which files are which codepages (in other words, which files are which languages). nlite is better for this kind of thing. my fileset started its life long, long ago in 2001 and it was more popular with users from places like italy, germany, russia and such than in english speaking places, so i never went ahead and removed languages.

@vci - my fileset is totally incompatable with nlite. nlite runs a scan to see what OS its dealing with and does some spot checking of other files as well like dlls. since my files are modded, it throws nlite off. compatability is not something nuhi or i ever shot for since we developed parallel projects in different ways. since we both remove bloat, our projects will never work together, because they try to edit the same files.

now, on a related item, you say you were not able to get my "plain-fileset + hotfixes to work." give me some more info and i'll see what's what... because my fileset is (as far as i know) totally compatable with a fully slipstreamed and hfslip'ed win2k. what mods did you have to make? let me know.

i'll be back in a few hours after i get some sleep...

Edited by fdv
Link to comment
Share on other sites

hi folks just got back from a few days away, some VERY quick answers

now, on a related item, you say you were not able to get my "plain-fileset + hotfixes to work." give me some more info and i'll see what's what... because my fileset is (as far as i know) totally compatable with a fully slipstreamed and hfslip'ed win2k. what mods did you have to make? let me know.

i'll be back in a few hours after i get some sleep...

@fdv Im not sure if you are talking to me or not. I d/l the hotfixes inividually from MS. I chose them based on comparisons with the fsfn thread on the subject, what I found on my computer, my update history on WU, and a little bit of research. Based upon this I believe those are the updates for my OS - I could be wrong of course.

Edited by Outatouch
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...