Jump to content

Guide For Compressed Drivers Unattended Install


Recommended Posts

@Lucius Snow

did you follow the testing guide before you do it with the installer???


Yes, i did. However i'm using a multiboot CD so the structure is not exactly the same. Like i explained, here is how i proceed :

My directory is like this :


BOOT1 = regular

BOOT2 = unattended

So ...

1/ I edited the TXTSETUP.SIF in \BOOT2 (and not the one in \Setup\XP\Professional\I386).

2/ I edited the WINNT.SIF in \BOOT2 (it can only be right since there's no else winnt.sif)

3/ The 3 files were copied to \Setup\XP\Professional\I386 (and not in \BOOT2). I also tried in both \I386 and \BOOT2.

Last notice : the 3 files get expanded and copied properly to C:\Windows\System32. But no Driverz folder created. If i run drvz.exe after the installation with the CD ROM still inserted, \Driverz doesn't get created either.

Link to comment
Share on other sites

WOOT updated files!! Will have an answer for you Lucius in about 4-10 hours depending how much time it takes to install and how much time I'll sleep :P

I really hope it works this time else I'll just go back to ol' OemPNPDriverPath blablabla... even if it takes 30MB on my cd

*keeps fingers crossed*

Link to comment
Share on other sites

Thanks serialzs for the updated file. I don't have much time today to test but I'll try. However, regarding our last conclusions about devicepath changed too late during gui setup, I doubt it'll work better than "hybrid method"® :) . As there was a problem with your last drvz.exe, I used a presetup.cmd file instead, which basically did the same things than drvz.exe, but have had no luck with it either...

As turbomcp suggested it, I tested modifying HIVESFT.INF (adding full devicepath) instead of using devpath.exe so that registry value of devicepath is modified before GUI, and it worked, which tend to confirm that whichever method we use (presetup.cmd, drvz.exe...), modifying devicepath after the GUI starts is too late.

I've also done research about my last theory (use devpath in GUI and then find a way to tell windows that registry has been changed so that it use the updated value of devicepath). I've found a message (WM_SETTINGCHANGE), that should notify windows of a change in the system. So I made a little app to broadcast this message to every foreground window and just launched it after devpath in my presetup.cmd. But although the return value is ok (which tells us that the message as been sent), one more time, changes in devicepath are not used. So maybe windows just doesn't listen to this message during setup...

Link to comment
Share on other sites

i hate to be a party ruiner:(

but like other people said i got to a conclusion that this cannot be done after gui starts ,so the only advance i did right now is just to compress and decompress drivers and this little util from serials that scans the directory for me:)

instead of me typing it all and making mistakes

so i dont see anyway this will work even with new version

windows just doesnt look in that value after gui setup starts:(

Link to comment
Share on other sites

So we can use presetup.cmd to decompress files when the setup starts and keep the OemPNPDriverPath path anyhow ?

@ serialzs : Is it possible you publish the code source of your drvz.exe ? Maybe the developers who are hanging around here may be able to find what is going wrong.

Link to comment
Share on other sites

You can use presetup.cmd to decompress drivers to a place referenced by OemPNPDriverPath, but I prefer to start SetDevicePath.exe directly after decompression, which spares me the trouble of keeping OemPNPDriversPath up-to-date.



Link to comment
Share on other sites


Don't get sad, here comes the good comments. THE NEW FILES WORKED PERFECTLY!! I am on WindowsXP SP2 french version, and my drivers were installed, the files stayed in C:\Driverz and everything looks ok! The only thing is that the .1 file who previously were the only ones to stay on the drive, they are still there, but as long as I get all my drivers I don't give a sh*t. Great work!


For all the others, have you tried simply the new files? without all your blablabla about hive and prepcmd and whatever. Cause they are working without even renaming them! Anyway, I hope it works for ya all soon.

btw I tested it only in VirtualPC, I don't know how vmWare works but it looks like soooo much more trouble! Try VirtualPC people, it's 45 days free.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...