Jump to content

Assistance using the unofficial Intel chipset drivers


Recommended Posts

Gigabyte GA-P31-DS3L



GeForce 7600GT

Intel E7200

I've just finished an install of Windows 98SE using the "Slipstreamable" Intel Chipset INF Drivers from;

The Windows (setup /p i) went really well with nothing abnormal happening. 

On boot up the device manager reports only one unknown device (PCI Bus). (Edit: PCI Universal Serial Bus.) I tried uninstalling the device using inf files machine2 and MDHDC but had no luck.

On a previous attempt I had problems with;

Nusb36 - Black screen and freeze but USB devices worked. Tried uninstalling and reinstalling different versions with the same result

Audigy 2 ZS - Drivers installed, sound worked but opening the Creative utility to install VxD drivers gave me the error "No driver installed" and no options to install either VxD or WDM drivers. The sound card is not physically installed right now.

Unofficial NVidia drivers - Broke my shutdown even with the shutdown patch installed

Phantom diskette drive - Even though the floppy drive has been disabled in the bios it still shows in my computer. Sometimes a 3.5 sometimes it's a 5.25. Never shows up in device manager.

So now my question is, where to start? Nothing seems to be quite working perfectly and I am not sure how or what I should be troubleshooting first.

Edited by ryandoesntstress
Link to comment
Share on other sites

I've installed 98SE fine on a similar Gigabyte motherboard I once had (GA-EP45-DS3L).

Forget the Intel Chipset drivers, they are not needed.

Try disabling all devices in BIOS that you will not use - LAN, built-in audio, etc.

Try replacing the HIMEM.SYS with HIMEMX.EXE (put DEVICE=C:\HIMEMX.EXE in config.sys), you can download it here:


Are you using IDE compatibility/legacy mode or the AHCI mode? It's recommended to use the AHCI mode and then install the AHCI driver for full 32-bit disk access and avoid the built-in IDE driver altogether: https://archive.org/details/ahci_win9x
There's also a TRIM utility, so that installing Windows 98SE on a SSD using AHCI mode is safe: http://dottoss.com/files/software/rloew/TRIM.ZIP

Don't use NUSB36, use the older, better version 3.3 from here: http://www.mdgx.com/spx/NUSB.EXE

Try all possible PCI slots for the sound card if you still encounter problems, one might work better than the other.

Installing the Unofficial Service Pack (Main Updates) might help with the shutdown problems with the NVIDIA drivers: http://www.htasoft.com/u98sesp/

As for the fake floppy drive, I think I had the same issue, I just ignored it, couldn't do anything about it.



Link to comment
Share on other sites

on some of my machines I had to install with  setup /p j  to install ACPI, it helped clear up the PCI bus issue.  My P35 chipset desktop works fine with ACPI enabled.  Do you have any ACPI devices showing under System Devices?  Just a suggestion, I would only disable ACPI as a last resort

Link to comment
Share on other sites

On P31/ICH7 chipset the IDE legacy mode works just fine, I didn't use AHCI there.

I installed the INF files after Win98, no slipstream. In device manager I had proper ide controller working in DMA mode.

I installed nUSB 3.3c

The only device I had disabled in BIOS was onboard intel HD audio.

I had some issuses with SB Audigy 2 and sound crackling (all OS I had installed) so I replaced it by Audigy 1 and it works fine. Used Creative driver (according to INF file)

I was lucky to have real floppy. it's sometimes usefull so didn't need to hunt phantom :)

The shutdown probloem with latest nvidia driver was never resolved probalby.

I used a hack: instead regular shutdown I use a batch file that set a flag (some file on disk) and reboot windows instead, then autoexec.bat checked if flag was set and then clear the flag (delete file) and call FDAPM to shutdown machine.


BTW as he has only 512MB RAM no need to himem.sys hacks. But I reccomend to install R.Loew RAM patch and install more RAM.

Edited by xrayer
Link to comment
Share on other sites

The thing is, you now CAN use AHCI mode, it's just an alternative, better to have now more options. It might be faster than IDE legacy mode, not sure, didn't do benchmarks comparing IDE legacy to AHCI mode on 98SE. And it's a necessity for newest motherboards that do not have IDE legacy modes any more like my H110 motherboard.

If the Audigy 2 still causes trouble, I would recommend Audigy 1, SB Live (model SB0100), Aureal Vortex 2, or YAMAHA YMF744.

As for the shutdown problems, I have them on my H110 motherboard, but didn't have them on my Gigabyte board or any older motherboards/laptops, so he shouldn't need to do that in theory. Maybe installing ACPI would actually be better in his case, and could solve the issue.

I recommend using HIMEMX.EXE regardless of how much RAM you have, it solves a lot of issues on newer motherboards, regardless of RAM amount. New motherboards do not really like the built-in HIMEM.SYS (you could also test XMGR.SYS as an alternative to HIMEMX.EXE).

Link to comment
Share on other sites

All the unnecessary devices and ports have been disabled prior to installing Windows. Would disabling more than just the HD audio be causing any issues?

NUSB33 is an easy thing I can try right away. Also alternate PCI slots for the sound card. But should I be focusing on the basics like the right combo of ACPI and ACHI first?

Is HIMEM.EXE compatible with the R.Loew RAM patch?

My motherboard doesn't make it totally clear if I'm using AHCI mode. Currently On-Chip SATA Mode is set to Auto. From my understanding, Enhanced would be equivalent to AHCI Mode, then I should disable PATA IDE Is this correct?



That TRIM utility looks excellent. How often would you run it? I guess it depends on how often files are being moved around the drive, right?

On a previous attempt I installed with p /j and found more unknown devices in my device manager. I assumed more is bad and it would be easier to just focus on the PCI Universal Serial Bus.

No ACPI devices are currently showing under System Devices. There is an ACPI Controller that is identified during boot though.

Maybe floppy can be solved by installing a real one and then disabling the device in Device Manager.

Link to comment
Share on other sites

Yes, you can use HIMEMX.EXE and rloew's RAM Patch together.

You need to select the Enhanced option to enable AHCI. And disable the Primary PCI IDE (unless you have anything connected to the IDE port on the motherboard).

Read the TRIM utility manual for more details about it, I haven't tried it myself.


Link to comment
Share on other sites

SATA Patch is NOT for AHCI mode, those are two different things. Using AHCI mode makes Windows 98 use the old legacy 16-bit disk access, Performance Tab in System control panel will inform you of that. Installing AHCI driver then gives you full protected 32-bit disk access, and Performance Tab will no longer complain. ESDI_506.PDR is not used at all.

SATA Patch is for situations when using IDE legacy mode gives a black screen when 98SE tries to use the ESDI_506.PDR driver or if the motherboard has SATA ports with no options in BIOS to change SATA mode that results in black screen when 98SE tries to use the ESDI_506.PDR driver.

Edited by MrMateczko
Link to comment
Share on other sites

Nusb - Install seemed to go well this time using 3.3 and usb mass storage devices are working. No more unknown PCI Universal Serial Bus!

IE 6.0 SP1 - Tried installing in preparation for U98SESP3 3.64. Got a black screen with no error given on restart just as the Updating System Settings drum progress bar completes. Same again on second attempt. Looks like the software installed because the installer told me it was on my second attempt.

DirectX 9.0c - Installed fine in preparation for U98SESP3. No problems

U98SESP3 3.64 - Black screen after extraction. 

HIMEMX.EXE - Followed the instructions. Copied the .exe to C:\Windows and C:\Windows\Command\EBD and added the line to config.sys. Restarted ok. Tried U98SESP3 again with the same result

Nvidia Manual Drivers - Installed well. Shutdown gave a flashing _. After install of Nvidia shutdown patch I got the protection error.

U98SESP3 3.64 & Nusb - Again just for fun. No black screen after extraction. Main updates installed ok.

At this point the power button works to shutdown the pc with no errors where it did nothing before. A small message box with a blue door and an exit arrow shows up but is gone too quickly to read. Shut down from the start menu still gives me a protection error. I unplugged the system to install the sound card and windows became upset that I didn't shut down properly when I used the hardware button. Maybe is only acts as a sleep or hibernate?

Audigy 2 ZS - Installed some fancy manual VxD drivers that I found from other research and it all worked beautifully. But I was unsure if they were really VxD as it didn't specify in device manager and I was curious to see if the official CD would work. WDM drivers installed after a looong time. Froze on reboot. Installed VxD drivers through the utility and another reboot and another freeze. Eventually it works! Comparing the installed VxD to my manual one from earlier, it's the exact same thing. Next time I will install manually.

Phantom floppy - Still there. I even installed the real thing intending to remove it in device manager but it doesn't show. I'll probably just ignore it for as long as I can.

And that's it! I'm pretty much done besides a for a few other settings an tweaks that shouldn't give me problems. It looks like the only real problem was that Nusb, U98SESP3 and IE6.0 really wanted a graphics driver. 

Link to comment
Share on other sites

Hmm...it seems you might have a problem with MS-DOS prompts from inside Windows (which should not happen!), can you open MS-DOS Prompt from Start Menu fine?

You can try messing around with ACPI/Power options in the BIOS.

Link to comment
Share on other sites

9 hours ago, ryandoesntstress said:

Phantom floppy - Still there. I even installed the real thing intending to remove it in device manager but it doesn't show. I'll probably just ignore it for as long as I can.


Possibly of use:


Link to comment
Share on other sites

Just going through the manual there looks to be a few other settings that should be changed also;

Limit CPUID Max. to 3 - Allows you to determine whether to limit CPUID maximum value. Set this item to Disabled for Windows XP operating system; set this item to Enabled for legacy operating system such as Windows NT4.0. (Default: Disabled). Now set to Enabled

HPET Support - Enables or disables High Precision Event Timer (HPET) for Windows® Vista® operating system. (Default: Enabled). Now set to Disabled

MS-DOS prompts - Definitely doesn't come up smooth. There is a split second after running cmd where there is some distortion or some artifacts appear on screen. I did some testing within Windows and found that Duke Nukum 1 gave a black screen but sounded like it was working in the background. I was able to end the task and get be to the desktop easily. I can also tab away and then back to the game to make everything run fine. Duke Nukem 3D was working without problems. Now when launching cmd in 16-bit colours the colours go out of control and look crazy. No problem launching cmd with 32-bit colours.

Restart in MS-DOS Mode - Windows protection error :(

Phantom Floppy - Legacy USB storage detect was already disabled. But I enabled it and the floppy drive is now gone.

By now I'm getting explorer crashing, active desktop crashing, icons on the desktop are staying selected when they shouldn't be. I've reinstalled Internet Explorer and the U98SESP3 main updates but the issues persist. Tried formatting the disk and starting again with setup /p j and reached approximately the same point. The only device manager ! is a resource conflict with a motherboard resources device. It's still very fussy with shutdowns especially if some new drivers or software has been installed. Restarting in MS-DOS mode will not happen but I can boot into it with F8. Normal shut downs work as expected from both the start menu and the power button. Duke games behave the same way. It feels a bit like my GPU or monitor just doesn't like old fashioned resolutions. Hopefully I can try another monitor tomorrow.

Are changes related to ACPI and AHCI for that matter useful for performance or just to make everything work? If windows supports ACPI and my motherboard supports ACPI, then installing with /p j should be the correct way?

Edited by ryandoesntstress
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...