Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


TheArkive

Aero Glass does what I need, but still getting DWM error message

Recommended Posts

I actually find that Aero Glass does what I was hoping for, which is to modify window titlebars and borders with blur and transparency.  But I'm still getting the "DWM can't be hooked" error message.

I understand that windows updates probably cause this "breakage".

I'm using Aero Glass v1.5.13, on Win 10 v18363.628
Today I ended up installing 2 windows updates:
1) 2020-01 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10 Version 1909 for x64KB4532695
2) 2020-01 Cumulative Update for Windows 10 Version 1909 for x64-based Systems (KB4532695)

I haven't tried Aero Glass recently, nor did I get around to trying it before these updates, so I'm afraid I don't have much else to go on for a comparison.  I just find it odd that I'm getting the functionality that I'm hoping for out of Aero Glass (just titlebar and border transparency - and transparent backgrounds on titlebar captions), but I'm still getting this error.

Is it possible that a future update would be able to selectively enable only certain features so that error messages that don't concern the functions I'm hoping for don't happen?

I'm guessing the part that is broken is more tied to full window transparency?

I apologize if I'm not making sense.  This is one program I'm just not well versed on yet.  I'll see if I canuninstall those updates and reinstall Aero Glass with any better luck.

 

EDIT:  I installed Aero Glass to my D: drive, user has read/write access...

Edited by TheArkive

Share this post


Link to post
Share on other sites

Aero Glass can't function 100% correctly without having accurate information about Desktop Window Manager's internals (exception being the Windows versions from the time of Aero Glass release), so in that case, it'll complain unless symbol files for the actual versions of dwmcore.dll and uDWM.dll libraries are present. Also the symbol file for ApllicationFrame.dll is needed for the extra functionality of restoring classic window frames of UWP apps.

One way to get them is via a script such as this one. The prerequisite is installed Debugging Tools for Windows, which you can install by running Windows SDK installer.

Another is using this PDB Downloader tool. You must browse to the DLL files in C:\Windows\System32 and set save path to C:\AeroGlass\symbols.

If you donate to this project, generate donation.key file for your machine and put it in C:\AeroGlass folder, Aero Glass downloads required symbol files on its own.

Share this post


Link to post
Share on other sites

OK folks, I'm really stuck here.
I'm on Win10 Pro 18363.657

Like many others, my Aero Glass is now broken. I've tried everything I can find to fix it, and nothing is working.

I'm a donator, so it seems that I should just have to put the key in the Aero Glass directory and it will re-download the symbols, but that doesn't do anything.
I've installed the debugger tools and tried to run the cmd posted elsewhere, and I get errors. I tried the VBS script, and it just pops up a black window for a second then goes away, nothing else happens.

What am I missing? My desktop is pretty much useless with these clear headers, and I don't want to just uninstall Aero Glass, since I paid for it and really like the effect when it works.

Any assistance greatly appreciated.

Share this post


Link to post
Share on other sites

Delete c:\AeroGlass\symbols folder and restart your PC. If it does not help, then your Windows installation is broken.

Share this post


Link to post
Share on other sites

Well, that's not good. :(

Folder deleted, system restarted, error persists.

Share this post


Link to post
Share on other sites

Then enable verbose logging and post your debug.log.

Share this post


Link to post
Share on other sites

Sorry, I don't know how to do that.
Seems like maybe I'll just uninstall AG and find something else that works better. Thanks anyway.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...