Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Nomen

NTFS: How to deal with a bad sector? (Ghost)

Recommended Posts

This is not really an XP question as much as it is a general NTFS question, but I figure I'd post it here.  I was trying to Ghost an 80 gb hard drive today, a drive that I try to clone at least once a year, one of several.  This is to create a backup.  The drive is from an NT4 server, and the file system is NTFS.  Normally the clone operation goes smoothly, but this time I kept getting a read error on the source drive at the same set of 4 sectors.  Ghost doesn't say what files are located there, and it stops the clone and exits after telling me about the problem.  I've slaved the drive to a running XP system and have had XP do a file-system check and a surface scan of all 3 partitions on the drive, and it finds nothing wrong.  So I was going to find out what files are using those sectors and copy them off the drive and then delete them.  Thinking that the sectors will become un-allocated and Ghost won't try to access them.

I've found similar questions on stack exchange and superuser.com and one way to find out is to use a utility called nfi.exe - Windows NT File System (NTFS) File Sector Information Utility which is part of Microsoft OEM Support Tools Phase 3 SR2.  So I ran it and found the sectors were used by a file in an RP (restore point?) folder in System Volume Information.  At first I couldn't do much there until I added "all users" full control and then I could mess with those files.  I copied the particular RP folder off the drive and then tried to nuke as much inside the System Volume Information folder that I could (because NT4 doesn't use it - right?).  Strange thing though - I run nfi.exe after deleting the file (the entire RP folder) and it still reports those sectors being used by the file in question even though the file is gone in explorer and a file-search for the file turns up nothing. 

Anyways, short story is that after doing that, Ghost still balks about a read error at the same sectors, so I'm not too impressed at this point and I want to do something to those sectors to make Ghost happy but I don't know what.  Any ideas? 

Share this post


Link to post
Share on other sites

if you have a big enough target drive, use dd to copy all sectors then.

Share this post


Link to post
Share on other sites
5 hours ago, Nomen said:

 I copied the particular RP folder off the drive ...

There are three possibilities (provided that the information you got from the tools you used are correct and that those 4 sectors actually belong to one of the files in that folder):

1) those sectors are actually bad and the copy you made misses them or is corrupted
2) those sectors are intermittently bad and sometimes they are read correctly and sometimes they are not 
3) everything is fine and Ghost is having an hiccup of some kind.

You don't provide enough information, which actual commands did you run?, what were the actual results? Etc., etc.

Technically it wasn't a smart move to "slave" a NT4 NTFS disk (its volumes) to an XP, the filesystem will very likely have been upgraded to a later NTFS version, and some functions on the original NT4 server might not be able to run anymore, see:

Anyway, at this point you can use DMDE on the XP:

https://dmde.com/

to analyze the NTFS and find which sectors are actually occupied by that file, then you can try to recover that file and/or copy the sectors directly.

A CHKDISK /R is the most you can do to "fix" those sectors, if it works, it works, if it doesn't you should IMHO change the disk, using the old one only for experiments.

jaclaz

Share this post


Link to post
Share on other sites
Posted (edited)

After downloading and reading the Ghost 2003 user guide (200 pages!) I see there many command-line arguments, and I think I will be using this one:

-fro Forces Norton Ghost to continue cloning even if the source contains bad clusters.

I would have thought that all options that are configurable at the command prompt would be available in the GUI, but I guess not.

I think I'll also do a SMART check on the drive while slaved in XP and see what that says.

Edit:  Yes I think that when I've tried to use disk-checking tools in NT they seem to do nothing.  This drive has been slaved to XP systems many times over the years for various reasons (like defrag).  The original install dates back to 1998 or 1999 when it was a different (smaller) drive.

edit:  For what it's worth, I found this tid-bit on Symantec's site:  "Ghost 2003 will not support correctly cloning anything above XP. You need GSS 2.0 (ghost 11.0) to clone Vista and GSS 2.5 to clone Vista and 7. It will also not support cloning any drive above 2TB I believe."

Edited by Nomen

Share this post


Link to post
Share on other sites

I looked at the ghost.ini that's on the bootable Ghost floppy and there's a setting for the -fro option and changed it to yes and the clone worked just fine.  I should have found out about that years ago.  The default setting for Ghost requires that the source drive be in perfect shape, and I've been tripped up by that more than once.

 

Share this post


Link to post
Share on other sites

I suggest Repartition Bad Drive. It can isolate the defective cluster preventing access. A lot of disks (that would be worth of garbage) can be saved and still works like a charme.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...