Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Thank You Big Muscle For New Aero Glass Build 1.5.6

Recommended Posts

How did you get it working on 16299.15?

I have the donate version of 1.5.6 so it should grab symbols automatically, but all I get is a message saying that it doesn't work in my version of windows.

(edit: working. It gave me an invalid machine ID, got the correct ones from the debug.log and now I have the symbols)

(edit2: not working after reboot, even with symbols present)

Edited by Lum
Link to post
Share on other sites

Yeah that fixed it (apart from the blur effect). Now if I can just get autohotkey to interact with that popup window, it'll be sorted, but even running as admin doesn't work :(


Link to post
Share on other sites
17 hours ago, Dreamweaver01 said:

Why do you want autohotkey?  You would have to make it hit cancel.
Is it so hard to just click it?

I currently have an autohotkey startup script that launches my apps across 2 virtual desktops and pixel-perfect positions their windows, but the Glass8 windows have thicker borders and the prompt ends up behind them. Also I'm lazy.



Link to post
Share on other sites

You can adjust the thickness of the border by adjusting WindowMetrics in the registry which you may have done already.
I get the lazy part as I'm that too. :cool:


Edited by Dreamweaver01
Link to post
Share on other sites

Yeah, but even with border padding set to 0 (as I have done) it's still there because the border padding on the default Win10 theme is invisible (which is why windows positioning is always screwed on Win10)

But yeah, it's mainly about just automating setting up my environment, so I log in to something already set up, not having to dismiss error messages like it's my dad's old Windows 98 box.

Link to post
Share on other sites

Solved the problem. Added this to my existing AutoHotKey startup script:

Run, schtasks.exe /run /tn "DWMGlassElevate.exe_-1916372974"

which just runs another compiled AutoHotKey script, now as admin, that simply elevates itself further (to TrustedInstaller status) using PowerRun

Run, C:\Scripts\PowerRun_x64.exe C:\Scripts\DWMGlass.exe

which finally kills the dialogue box!

WinWait, dwm.exe,,15
WinClose, dwm.exe

I'm sure there's neater ways to do it, like a single script that check's its own privilege level, but I don't care. This works :). Because it's run first, it means I don't have to hover over each window to correct the initial drawing errors.

Edited by Lum
Link to post
Share on other sites

anybody got modernframe to work on 16299.15? - if i apply the code - regsvr32 c:/aeroglass/DWMGlass.dll it seems to be accepted but nothing changes with the frame - further and i have not fully tested some apps seem not to work/open - calc and calendar being examples

i always add - i may be doing something wrong its a while since i added this to earlier build - so need to readup [maybe]

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...