Jump to content

Final Inquiry About 98SE and KernelEx


Recommended Posts

I'm about to save any useful files I've accumulated with 98SE and wipe the system.
It's not what I want, but I have never been able to use KernelEx successfully with
a modern browser.

The three attached jpegs are from a recent version of K-Meleon, but I get the same
error messages from almost any app that's listed here at MSFN or the KernelEx Wiki.

The first error box is easy to fix. It's always about a missing DLL. Copying the DLL into
the System directory resolves that problem.

The error boxes about a "linked missing export" and "A device attached to this system is
not functioning" seem intractable. Many people have been kind enough to offer suggestions,
but everything I've tried has failed.

I have considered hardware conflicts. The problem with that theory is VLC and GOM Media
Players. Following the advice in the Wiki, they both run fine with KernelEx. I'm also running
a couple of obscure photo editing apps. If hardware was the problem, why do these apps
run with KernelEx?

I recently installed the latest Unofficial 98SE Service Pack (3.53). I was hoping a USP might
update the system enough to resolve all these problems. It didn't work, but it seemed like a
good thing to try. No harm done, I keep plenty of image backups to restore the system.

I learned how to create scripts with these early Windows systems. Automating all sorts of
complex processes is the reason I continued to use 98SE.

The older versions of K-Meleon, SeaMonkey, Opera, etc., no longer render most web pages
properly. Unless I can get a modern browser to work with KernelEx, my copy of 98SE will
be retired.

I've got a USB stick with bootable apps that completely wipe hard disks. If that's what I have
to do, I'll ask a friend. Doing the job myself would be too depressing.




Link to comment
Share on other sites

K Meleon 1.6.0 beta2 or 1.7 alpha run with KernelEX (comp. mode Win2000). Newer versions don't. Maybe someone has found a workaround for newer versions.

Opera 12.02 runs with KernelEX. Newer versions don't. I've spent a lot of time to find a workaround to run newer versions of Opera without success! I'm able to run Opera 12.5 build 1538, but without working plugins.

Link to comment
Share on other sites

Unfortunately, the lack of modern browser functionality (even my old standbys Firefox 3.6 and Opera 10.63 were starting to lose support on modern websites) was what led me to discontinue 98SE on my Internet-connected vintage laptops and move to 2000, which can run stuff like QupZilla 1.8x, Opera 12.18, Firefox 31 ESR, and other more modern browsers using BlackWingCat's KernelEX


I tried to get Opera 12.1x and QupZilla working on 98SE a couple years back to no avail (the latter kept crashing on startup, and the former was missing some DLLs and would not function at all)

Edited by danikayser84
Link to comment
Share on other sites

I suggest making an image of your hard disk before wiping it. Put it in a different computer and use backup software or the Linux dd utility to dump all the data of your hard drive to a file.

Better yet, you could buy another IDE hard drive and swap the old one out and keep the data. Hard drives are extremely cheap these days.

Link to comment
Share on other sites

I have a lot of image backups. I don't know why I saved so many. As long as these images
exist, the system is not gone forever.

Frankly, I was apprehensive posting about this subject. If anyone replied, I was expecting
comments like, "start fresh, perform a clean install."

I've tried and abandoned many browsers. For reasons that are probably not logical, K-Meleon
has always been my favorite.

schwups, I'd like to try one last time with a newer version of K-Meleon. Where can I download
1.6.0 beta2 and 1.7 alpha run? Also, which of the two renders web pages better?

Link to comment
Share on other sites

KM 74_31 runs pretty well. SM 2.32 is another Gecko option that works, but both are sluggish.

Slimboat 1.1.50, Qupzilla, and QTWeb are faster QT4/webkit options. Javascript usually works but ends with an error box (fixable). Qtwebkit4.dll needs to be downgraded to version 4.7.4 for these to work.

BTW, KernelEx 4.5.x and USP3 are incompatible without some manual tweaking. I haven't installed USP3, but have manually updated some system files.

Link to comment
Share on other sites

You're not going to believe this, but I downloaded K-Meleon 75.1 based on a post at CNET.
This person said they got 75.1 up and running with KernelEx set to the XP mode. They included
a link to MS VC++2005 which contains two DLLs not found in 98SE. If you search long enough,
you'll find many posts claiming miracles with KernelEx.

Under "About K-Meleon" here is all the info provided for the last version compatible with 98SE:

Mozilla/5.0 (Windows; U; Win98; en-US; rv: Gecko/20100228 K-Meleon/1.5.4

Right under the listing for version 1.5.4 at the download page it says, "Update to latest Mozilla
code with some bug fixes." If this older version has been updated does that mean all
the problems rendering web pages have been fixed?

Edited by HoppaLong
Link to comment
Share on other sites

:hello:Up to now I wasn 't able to run K Meleon 74+. Sure it is possible. It is at least necessary to add msvcr100.dll (MS VC10) and to use Kexstubs with with some additional API entries:unsure:. Indeed, I have not worked intensely on it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...