Jump to content

Flash drive is listed twice


mike13
 Share

Recommended Posts

Running Windows 10 for a while, but now when I insert a 64 Gig flashdrive, I see it listed twice in File Explorer. I see this:

ADATA UFD  (L:), then I see the five folders that are on this flashdrive, Documents, Downloads, Favorites, Music, and Pictures. Then there is a space, and  then  I see the exact same listing. I know the 5 folders take up over 43 Gig of space, so the folders can't be on the flash drive twice, since the flash drive is only 64 gig. suggestions please.  Mike

Link to comment
Share on other sites


Update.....I tried another flash drive, and that flash drive is also listed twice in File Explorer. I then tried those two flash drives in another computer also running Windows 10. Same result.  I then tried those two flash drives in the wife's computer running windows 8.1  The two flash drives only showed up once as they should. what is the problem with Windows 10 showing the droves twice ? Thanks, Mike

Link to comment
Share on other sites

Update.....I tried another flash drive, and that flash drive is also listed twice in File Explorer. I then tried those two flash drives in another computer also running Windows 10. Same result.  I then tried those two flash drives in the wife's computer running windows 8.1  The two flash drives only showed up once as they should. what is the problem with Windows 10 showing the droves twice ? Thanks, Mike

Just bad engineering....

  • Upvote 2
Link to comment
Share on other sites

It's normal on Windows 10 because removable drivers are listed in This PC and directly in the navigation pane. To change this, open regedit, go to HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace and remove the DelegateFolders key in it, your drivers will normlay listed once ;)
If you use a 64 bits system, do also the same thing in HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace

  • Upvote 1
Link to comment
Share on other sites

MTDirector...Thanks for the reply. I followed your instructions. When I came to Namespace, there were about 25 numeric and alpha items after it. At the botto of those 25 items I did see "DELEGATEFOLDERS", so I deleted it. I did not see any option to Save or anything, so I rebooted the computer. No change, I still see the flash drive listed twice. Any suggestions on what I did wrong ?

Link to comment
Share on other sites

  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...