Jump to content

Windows 10 cold boot fast, restart slow.


Recommended Posts

So, this is my first post in the forum. The reason why I have to sign up here and post this topic is explained on the title. I won't write long post here. The resource for trace log is below. In case you need the <blah blah blah>.cab, I will upload too: https://onedrive.live.com/redir?resid=2EE5EFF21E741320!3950&authkey=!ACNd-yzlSDJLHlE&ithint=file%2ccab

Right there, I saw that there are 2 kids caused the SMSSInit took too long to boot are:

<file name="Unknown (0x0)" totalTime="61130" totalOps="257" totalBytes="12167168" writeTime="0" writeOps="0" writeBytes="0" readTime="61130" readOps="257" readBytes="12167168"/>


<extension name="(none)" totalTime="101917" totalOps="1006" totalBytes="160111104" writeTime="27256" writeOps="98" writeBytes="937984" readTime="74660" readOps="908" readBytes="159173120"/>

Maybe there are some kids running around my laptop that I can't see. So you guys please help me solve this <beep> problem.


EDIT 1: correct typo.

EDIT 2: update .cab link

EDIT 3: All the drivers are installed correctly. Also, ntbtlog.log shows that dxgkrnl.sys first successfully loaded and 4 times more fails. WdFilter one time more failed.


Edited by silencieux.le
Link to comment
Share on other sites

When you say "cold boot"...  Have you disabled Hybrid/Fast Startup?


If not, I don't know if you realize but shutdown / bootup in Windows 8 and newer are by default not real shutdowns / bootups, but rather a hybrid "log off and hibernate" kind of thing.


What most folks don't realize - especially if running any kind of dual boot arrangement - that the Hybrid/Fast Boot logic can cause a lot of problems.  For one thing some parts of the system are not freshly restarted, and for another it's likely the file system will actually be left in a dirty state.


I normally advise people to disable Hybrid / Fast Bootup (it can be done in the Power Options panel), though in your case that would probably make it so that your system would boot up slowly in all cases - which of course you're right to try to diagnose.


A member here, MagicAndre1981, started a thread giving some advise on how to diagnose slow bootup problems here:



You might post there asking him whether he's willing to extend his expertise to Win 10.  He may not see your thread here.



Link to comment
Share on other sites

Well, for cold boot, I mean that I shutdown my laptop completely and then start it again, but yes, fast startup is enabled there.


Yes, I know that with Fast startup enabled, the OS does not really shutdown since Windows 8. This problem did not happen with me since build 10130 and after an upgrade to build 10240, it occurred. Restart takes almost 5 - 6 mins to finish and I don't think it's normal if I disable Fast startup on a normal OS.


I tried to diagnose boot process and get the log above, then I realize that SMSSInit takes too much time to done because 2 entries that I don't know what they are.


Tried this command too:

xbootmgr -trace boot -prepSystem -verboseReadyBoot

The process is completed but nothing changed.

Link to comment
Share on other sites

  • 2 weeks later...

I am having the same issue on a laptop.

When I shutdown and reboot it takes less than 1 min to get to the desktop.

If I restart, it is on the W10 logo wait screen for a LLLLLLLOOOOOOOOOOOGGGGGGGGG



fast start is enabled.

i have run chkdsk /f no chg

I started in diagnostic mode = no chg


Going on 20 minutes for this restart and not there yet..........finally, maybe 30 min


I guess if I disable fast start it will take a long time on a cold boot also.

Obviously then, something is taking a very long time to load.

That something must be a system component.


how to track it down?

Edited by ruggb
Link to comment
Share on other sites

Fast Startup is not enabled when a system restarts. This is by design and cannot be changed. Restarts are expected to last longer. When you shutdown, Fast Startup is enabled so when you turn it back on, you get a fast boot. A restart is different.

Edited by Amigafever
Link to comment
Share on other sites

With Fast Startup it will take longer to close down fully as its got to write the files to DISK for the next Fast Startup.


Even though these files are smaller then the Hibernate Files it still allocates 12GB of SSD space (may be related to 16GB of System Memory) for my system so its a no go for that alone.


If you disable Hibernate you loose Fast Startup anyway but gain SSD space.


IMO on a SDD with a new EFI Mobo/Bios setting set correctly for Fast Boot/etc. that bypasses all junk and posts in 2secs or less you best to disable Fast Startup for more s[pave on your smaller SSD's and faster Shutdowns.

Link to comment
Share on other sites

  • 3 months later...

man.. my problem is the exact opposite. i hard very fast restarts (17-20 secs) but super sloooooooooooooooooooooooooooooooow cold starts (like 25-45 min)... please advise. fast startup is enabled.

Link to comment
Share on other sites

Disable it.  It's no good anyway, because it doesn't give you a true bootup, but rather continues your session from before.


You probably have a driver that's not able to navigate the power state changes.



Edited by NoelC
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...