Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
oerg866

Skype 3.8.0.188 for Windows 98/ME

Recommended Posts

Skype98.PNG
 
 

Skype 3.8.0.188 for Windows 98 / MEInstaller package created by Oerg866(C) Skype Technologies SA(C) Microsoft CorporationAll rights belong to Microsoft Corporation.Original modified Skype 3.8 version by VilkoPLEASE NOTE: After starting Skype for the first time, it may take a few minutes to load the contact list and you may get an error message about your internet connection. This is normal, don't worry.This package was created to give people a chance to connect to the Skype network from old Operating Systems like Windows 98, 98SE and ME.It does not intend to undermine Microsoft Corporation's authority over their Skype service and exists purely for experimental and nostalgic purposes.tl;dr please don't sue me ;_;DISCLAIMER: I'M NOT RESPONSIBLE FOR ANY DAMAGES TO YOUR COMPUTER(S) AND/OR SKYPE ACCOUNT(S) AND ANY OTHER THINGS THAT GO WRONGtl;dr please don't sue me either ;_;

Download

Edited by oerg866

Share this post


Link to post
Share on other sites

What does 3.8 do that the latest 9x one does?

Does it allow Microsoft ID usage?

If not I dont see the point.

Trev

Edit: I just found out that Skype 3.8.118 IS the last official supported version... so What does your version bring?

Edited by trevor89

Share this post


Link to post
Share on other sites

The regular skype verisons prior to 6.2 do not allow you to log in. This one does.

I should clarify:

Vilko managed to reverse engineer and modify the older skype versions to the point where they would run and connect - but not on Windows 98.

I made necessary changes for Windows 98 such as removing the portable launcher that doesn't even work with kernelex and packaging it.

Edited by oerg866

Share this post


Link to post
Share on other sites

Ah, ok, so the official builds of Skype have all been dissabled but this has been 'unlocked'.

Pitty it didnt allow messenger ID to be used. I used Messenger 7.0.820.0 right up till the day it stopped working (sometime last year)

I also tried 7.1, whiched worked with KEX but obviously wanted to upgrade to 2013 (wouldnt log in without doing so) and then broke.

Now Im confined to my phone for IM Conversaions.

Trev

Share this post


Link to post
Share on other sites

I did that once a long time ago, and did think about that last week, however when I tried it wouldnt load...

How do you get it to load?

Trev

Share this post


Link to post
Share on other sites

I downloaded and installed the skype package created by Oerg866, and it is working on my win-98 system with kex. I was able to create a new skype account and send a contact request to someone and it was accepted and I can conduct a skype chat session with them. However, regardless if I try a call to the contact or to the skype test account, I get a message (in big red letters) PROBLEM WITH PLAYBACK DEVICE. Under Tools - Options - Audio Settings, for each of Microphone, Speakers and Ringing, a dropdown box for each of those has 2 choices - Windows default device and C-Media Wave device. Regardless which one I choose - this Playback Device problem exists. I have all inputs in my taskbar speaker/volume control selector un-muted. I do not currently have a microphone plugged in - but I wouldn't expect that would cause this problem. ?

Under Tools - Options - Sounds, the "play this sound" function does not result in any audible sound.

Does the actual program file (skype.exe) require any specific kernelEx setting?

Does the .bat file that invokes skype (or any of the custom .cmd files that are present) require modification to restore audio functions?

Share this post


Link to post
Share on other sites

The previous version of skype that I had (that used to work a year ago before Skype changed something with their contact server) was 3.5.0.239.

Also, I'm blocking ui.skype.com in my Hosts file (I read somewhere that it would help get skype working again). Should I unblock it?

According to this screen capture: http://forums.logitech.com/t5/image/serverpage/image-id/8659i30B1770A931883BB/image-size/original?v=mpbl-1&px=-1 I'm supposed to have a small green "Play" arrow beside the Speaker setting drop-down box. I have no such arrow.

Share this post


Link to post
Share on other sites

Hm, that's odd. It is working for me with a SoundBlaster Live! card.

The package shouldn't require kernelex at all. Try turning off kernelex and see if it works then maybe?

Cheers.

Share this post


Link to post
Share on other sites

When I installed this modified version of skype (3.8.0.188) I chose to install it to c:\program files \skype2\ because I wanted to keep the existing installation (version 3.5.0.239) which was located in c:\program files\skype\.

I just ran the older 3.5.0 version, and it gets hung up trying to login. I can cancel the login but the application comes up and I get the green circle with the checkmark in the system tray. I *can* make a skype test call, and the audio works fine! And in the audio settings, there is no play arrow. In the Sound settings, there is a small play arrow, and I can play any of the selected sounds.

So I closed the old version and ran the modified version directly from the directory where it's installed in (\skype2\.App\). It behaves differently vs when it's launched from the desktop shortcut (SKYPEL.BAT). It logs into my old user-name - and it seems to do that smoothly / automatically. But if I try to "View Account", I get a screen showing a padlock and the message "Loading (old account name)" and then it says "unable to launch web browser". I still get "problem with playback device" when trying to make a test call. I've set the Kex properties for skype.exe to "disable kernelex extensions" but that does nothing. Still get "problem with playback device".

If I start this modified skype with the desktop shortcut (SKYPEL.BAT) it logs in with the new skype username, but when I try "view account" I still get "unable to launch web browser" and making a test call still gives "problem with playback device".

What is known about this modified version of skype (3.8.0.188) and installing it in a non-default directory location, and installing it when a previous version of skype (with all it's settings stored somewhere) still exists?

Share this post


Link to post
Share on other sites

Would the fact that I have this in my registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion

- Version = Windows NT

- VersionNumber = 5.0

- Win XP version number = 5.1.2600

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion

- CurrentVersion = 5.0

- Version=Windows NT

- VersionNumber = 5.0

be causing problems with skype 3.8.0.188 not seeing my audio hardware? Or causing this problem:

If I try to set a picture for my skype profile, and I point skype to, say, the root of E drive and select a .jpg file located there, I get this:

-----------

Cannot create file "E:\profile\pictures\some-picture.jpg"

The system cannot find the path specified.

-----------

If I create the directory "E:\profile" in explorer and then go into that directory, the file "shared.lck" is mysteriously already there - with the current date and timestamp. I then create the sub-directory "pictures" and go back to skype and repeat the profile-picture selection process. I select the same picture (located in e:\) and the picture shows up in the Skype Picture Library (its the only picture there besides the default picture). The new picture is selected, and I press the "apply" button. The skype profile window closes, and an error-window pops up with this message:

--------------

Error

Skype encountered an error accessing stored data. You have been logged out for protect integrity of your data.

[ok]

--------------

Skype interface reverts to login screen, showing "welcome to skype" and under that is "! Failed to mount skype database. Possibly another instance of Skype is using it" - but there is no other such instance running as far as I can tell.

So I exit and restart skype, and it does an auto-logon and I get the green circle with the checkmark in it in the system tray (indicating that I have a working skype connection) and my profile picture is still the default picture.

Share this post


Link to post
Share on other sites

Probably I never had sound with version 3.8 and also 3.6 and 3.7 (PROBLEM WITH PLAYBACK DEVICE), but I'm not absolute sure. I had the probem on different machines, usually with Creative SB PCI128 (Ensoniq ES1371) Sound Card, but also onboard audio devices. The problem didn't exist on XP.

Share this post


Link to post
Share on other sites

> Probably I never had sound with version 3.8 and also 3.6 and 3.7

> (PROBLEM WITH PLAYBACK DEVICE)

So until or unless someone else running Win-98 natively (ie - not in a VM) can run this 3.8.0.18 version of skype with proper audio functionality, it should be considered non-functional for its stated purpose.

Share this post


Link to post
Share on other sites

Thanks, the ol' lady uses it to talk to her brother in Germany. Thank you very much for the contribution. Hope to see a new version in the future if possible. :thumbup

Share this post


Link to post
Share on other sites

> Thank you very much for the contribution.

You don't actually say that you've tried it - and it works...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...