Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
sendscan

F: \ refers to a location that is unavailable

Recommended Posts

Hello Everyone,

 

First of all, I must say I'm french, so I do not have all the right words

I have a problem on my Windows XP Home: On my Computer, I now have icons of drives with white interrogation marks on red circle (see attached file). post-400042-0-37326200-1416904353_thumb.

 

Now when I plug a USB (F:), I get the following error message

 

F: \ refers to a location that is unavailable. This can be a location on a hard drive of this computer or a network. Make sure the disc is inserted correctly or you are connceté (e) to the Internet or home network, and then try again. If you still can not find the information, it may have been moved to a different location.

 

Do you know how to solve this problem ? I hope my explanations are understandable.

 

Thank you very much in advance.

 

CD

Edited by sendscan

Share this post


Link to post
Share on other sites

That seems the effect of using some kind of virtual disk driver that *somehow* let the drive letters "hooked" to non existing devices, BUT it could be also a completely different issue.

 

Open a command prompt.

In it run:

mountvol>c:\mountvol.txt

Post the contents of files C:\mountvol.txt.

 

Before that (if you haven't already done so, do try rebooting, more often then not this kind of drive letter mis-attribution is "volatile" and does not survive a reboot.

 

jaclaz

Share this post


Link to post
Share on other sites

Hello Jaclaz and thank you very much for your answer and your help.

I did try to reboot, but this changes nothing. I still have those 3 icons.

You will find the file mountvol.txt attached

 

mountvol.txt

 

Thanks again!

 

CD

Share this post


Link to post
Share on other sites

Your output appears to be the "help" message given on a syntax error.

My two questions:

1. How long as this been happening?

2. What is the make and model of your USB drives?

Share this post


Link to post
Share on other sites

Hello Tripredacus and thanks for your help.

1.This happens for about a week

2. The models of my USB drive are Emtec 2GB and Kingston DT101 G2 16GB

 

About the mountvol.txt file, I launched cmd.exe then typed mountvol>c:\mountvol.txt and press enter.

 

What did I do wrong ? I tried again and got exactly the same content in the mountvol.txt file.

Edited by sendscan

Share this post


Link to post
Share on other sites

OK my mistake. Mountvol shows help AND volumes, so I think you are fine. It shows that those 3 other drives are not actually present. So the error it gives you is being truthful.

Can you re-run the mountvol command again, but this time with one of the USB drives plugged in?

Share this post


Link to post
Share on other sites

Ok so everything's fine about the command.

 

So here's the mountvol.txt file run with my Emtec 2GB USB drive plugged in:

 

mountvol.txt

 

The icon of the USB drive looks like normal but when I click on it, I got the error message "F: \ refers to a location that is unavailable...etc... "(see emtec.JPG).

 

I hope you have an idea about what to do.

 

Thanks again for your help.

post-400042-0-57196400-1416928690_thumb.

Edited by sendscan

Share this post


Link to post
Share on other sites

There are multiple ways to deal with this.

- digging through the registry such as this (see answer)

http://superuser.com/questions/762352/how-to-get-rid-of-an-extra-drive-in-my-computer-showing-up-with-question-mark

- going into Safe Mode and use Device Manager (showing hidden devices) to remove all disks that are not the HDD, and USB devices and volumes.

- possibly using NirSoft's USBDeview to remove non-present USB devices:

http://www.nirsoft.net/utils/usb_devices_view.html

Note any such work should be done without any USB key or disk connected. Also if you use the Nirsoft tool or Device Manager to take care not to remove USB keyboard or mouse if you have those... as then they stop working until a reset!

These are my ideas, maybe others will have some ideas too.

Share this post


Link to post
Share on other sites

So, the actually assigned letters are actually C:, D:, E::

Des valeurs possibles pour VolumeName ainsi que des points de montage actuels sont :

\\?\Volume{e12fbcc4-7166-11e4-a91e-806d6172696f}\

C:\

\\?\Volume{e12fbcc5-7166-11e4-a91e-806d6172696f}\

D:\

\\?\Volume{e12fbcc6-7166-11e4-a91e-806d6172696f}\

E:\

Open device manager and check that you don't have "strange" devices in it (possibly with a question mark or an exclamation mark)

Open Regedit and check the contents of hive:

HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

delete all keys NOT corresponding to C:, D:, E: or to the corresponding volume ID's in the above.

Do the same for the keys in hive:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2

see if anything changes (you might need to "kill" explorer and restart it or reboot).

If you don't feel confident in doing the above manually you can use drivecleanup:

http://www.uwe-sieber.de/drivetools_e.html#drivecleanup

and the "companion" app devicecleanup:

http://www.uwe-sieber.de/misc_tools.html#devicecleanup

jaclaz

Edited by jaclaz

Share this post


Link to post
Share on other sites

I tried manually then with Cleanup, rebooting each time. Unfortunately there is still those "ghost" drives if I call them like that.

Share this post


Link to post
Share on other sites

I tried manually then with Cleanup, rebooting each time. Unfortunately there is still those "ghost" drives if I call them like that.

 

This may mean that they are *somehow* recreated at boot time.

 

After having run both drive cleanup and devicecleanup, check in Regedit the mentioned hives there should be no traces of *anything* besides C:, D: E: (and related volume ID's).

Then reboot and check if *anything* has been added to them.

If not (and you are still having the "fake" devices), it means that we checked in the "wrong" place.

 

Open a command prompt, follow this KB:

http://support.microsoft.com/kb/315539/en-us

(you have to keep the command window open while accessing device manager)

 

Select one by one the "greyed out" entries under "Disk Drives", right click and uninstall each one, do the same under "Storage Volumes", and under the "USB Controller". (cannot say the exact names in French, they should be Lecteurs de disque, Volumes de stockage, Controleurs de bus USB)

See:

http://www.generation-nt.com/affichage-des-peripheriques-caches-astuce-24581-1.html

 

jaclaz

Share this post


Link to post
Share on other sites

@sendscan:

What about one of those horrible multicard-readers without any card inserted in any of the slots?

Do you perchance have one of those in your machine?

Share this post


Link to post
Share on other sites

Hello Dencorso and thanks for your message. My computer is a laptop and I do not have any multiple card readers.

 

@ Jaclaz : I tried to follow your explanations (not sure I did all well) but it did not change anything.

Thanks anyway for your help.

Share this post


Link to post
Share on other sites

Try re-checking also under CD/DVD drives (i doubt that it can be a floppy).

 

A drive letter can be (ghost or real) assigned to:

  • a floppy
  • a cd/dvd
  • a hard disk volume (internal)
  • a hard disk like or superfloppy external (USB connected)
  • a media card socket (on many laptops these are internal but USB connected)
  • a virtual drive software (i.e. a virtual device)
  • a network share

once the first five will be excluded, only the last two can be the issue, unless I miss something.

 

But you should know if you have installed or run "strange" software when the issue began.

 

On some desktops I have seen (curious as it may be) "ghost" devices (but never that I recall a mass storage device) appear from thin air due to failing/bad PSU's (hardware fault) but I don't think that it can happen on a laptop. :unsure:

 

I will think about some other possible cause but right now I'm stumped. :(

 

jaclaz

Share this post


Link to post
Share on other sites

Jaclaz,

 

I really thank you very much for your help. I did not mention it, but you're talking about "strange software" and it makes me think that I've upgraded my version of Kaspersky Internet security for version 15.0.0 to 15.0.1. I think the problem started at that moment.

I don't know if it is just a coincidence, maybe it is related to the problem. Sorry about not mentionning this before. I didn't think of it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...