Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


MrMaguire

Change Windows 98 SE Default System Font

Recommended Posts

I'm trying to permanently change the default Windows 98 SE system font from MS Sans Serif to Tahoma. I can change everything through the appearance settings, but when I reboot the fonts go back to MS Sans Serif and what looks like Times New Roman, which is odd. Am I missing something here, or is Windows 98 SE not capable of doing this. I'm using Windows 98 SE in Virtual PC 2004 updated using the Auto-Patcher. I've noticed the same behaviour in Windows ME in vmWare also.

 

Windows_98_SE_Derp.png

Edited by MrMaguire

Share this post


Link to post
Share on other sites

Never tried it since it seems irrelevant to me. But this says the same thing you tried *and* seems to indicate *something* having to do with Resolution. :unsure: It seems to have a link to a GUI to change it (but it costs $).

http://discuss.pcmag.com/forums/thread/61841001.aspx

Oh, and you DO have the correct Display Adapter Drivers in your VM's don't you?

And also have the VM Additions (for VPC) installed?

Share this post


Link to post
Share on other sites

If I get this right you use this method (more or less):

http://www.bltt.org/accessibility/win98/win98display_appearance.htm

 

but the results are not "sticky" through reboots? :unsure:

 

Are you saving your settings as "Scheme", but at next reboot the "default scheme" is changed back to the original/previous ?

http://support.microsoft.com/kb/196001/en-us

 

Just in case:
ftp://ftp.pcmag.com/archives/2001/0801/

 

jaclaz

Share this post


Link to post
Share on other sites

@MrMaguire:

 

I *think* that Revolutions Pack 9 automatically replaces the system fonts with Tahoma -- there's a check box in the RP9 config program under the "Misc" tab that says:

  [ ] Don't replace default shell font with Tahoma.
 
Also, under Windows' "Display Properties > Appearance" tab, there is a "Save As..." button which works for me in saving font changes.  (But i'm also using RP9, so i'm not sure if it's a side effect of that.)  Worth a try anyway.  

And i highly recommend Revolutions Pack!  

- Doug B.

P.S.  I'm *not* running on a virtual PC.

Share this post


Link to post
Share on other sites

Thank you all for the help.

 

I was able to get the font change to stick after rebooting! I was previously using the built-in Windows configurator in the display settings. I manually changed every occurance of MS Sans Serif to Tahoma and then saved the scheme as "Windows 98 Tahoma", so it was easy to set it up again after rebooting and losing the settings.

 

I'm pretty sure I have the correct display drivers installed. The drivers in use are what come with the virtual machine add-ons for both Virtual PC and vmWare. I can choose high colour depths and multiple resolutions at least.

 

The DisplaySet tool linked was able to fix the problem. I reset the Tahoma font for each UI value and applied it, now the changed font sticks when I reboot.

Share this post


Link to post
Share on other sites

I think I know what the root of my problem was. When configuring the scheme originally, I selected the font named "Tahoma" from the list, because that's what I wanted. Well, I noticed that when I applied the setting (In this case for the active title bar as an example) and returned to the appearance settings page after closing it, the font field for "Active Title Bar" was blank! I discovered that DisplaySet doesn't set the scheme to use the regular "Tahoma" named font even if you choose it from the drop down menu. What it actually uses is the font named "Tahoma (Western)". Setting Tahoma (Western) in the Windows appearance settings doesn't have the problem mentioned above, and Windows will stick to that change even after a reboot. At this point, if you're lost, I can't blame you. :P Hopefully the screenshots help a little bit.

 

Windows_98_SE_Font_Problem.png

 

After closing the configurator and opening it again. Notice the blank font field. It should say "Tahoma", which is what I selected.

 

Windows_98_SE_Font_Problem_2.png

 

Same thing, but this time selecting "Tahoma (Western)". Windows will not default back to MS Sans Serif or that font that looks like Times New Roman with this setting.

Edited by MrMaguire

Share this post


Link to post
Share on other sites

If you edit win.ini, you will find the section for

 

MS Shell Dlg = {x}

MS Shell Dlg 2 = {x}

 

{x} is usually MS Sans Serif.  Change that to Tahoma or whatever else you like.  It should work.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...