Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Kext: DIY KernelEx extensions

Recommended Posts

LAV 0.63 works absolutely fine here (splitter, audio and video)  so I guess you might be missing some definitions in the kernel32 section of your kstub822.ini, LAVVideo appears to require all this (probably not the best/most optimal definitions  but it works):




Also, you may want to try processing the bundled dlls with jumper's gccfix.exe instead of UPXing them. (The LAV ax files don't require either as the are compiled with MSVC.)

Edited by loblo
Link to post
Share on other sites

Thx Loblo, I did not had the GetNuma-def in my kstub822.ini !! I could install LavFilters but it was not possible to configure mpc-hc to use it. Only the very old mpc used lav filters.

Link to post
Share on other sites

Sure you can as I just did it. They don't play too well together however, I couldn't pause the video and audio was choppy. Unfortunately those bugs/incompatibilities will never be fixed so I'd recommend to use latest/current Zoom Player (v9.41 as of this writing) with LAV as they work flawlessly together. PotPlayer's also an option, although running the latest builds requires editing one import by ordinal from shell32.dll in potplayer.dll (can be done with Detect It Easy).


And in case someone still wouldn't manage to get LAV running, it's also necessary to replace msvcrt.dll by msvcr70.dll.

Link to post
Share on other sites

Maybe on ME it worked but mpc-hc kept using its internal filters no matter what I tried. Only the old played files and actually used lav filters.

However, I hope the gui problem with vlc can be fixed anytime soon.

Link to post
Share on other sites
  • 2 months later...

I've gotten Minetest 0.4.9 (open-source Minecraft clone written in C++) to work on Windows 98 SE. You must add SetConsoleDisplayMode=r1s3 to [Kernel32.dll]. Grab Wldap32.dll from XP and place it in the same directory as minetest.exe. Set compatibility mode to Windows 2000. I tried playing around with minetest.conf, and setting the video driver to direct3d9 seems to be the one with the best performance. The only issue I've found is that the land appears red, which is most likely due to my ancient GeForce2 graphics card lacking the proper shader support. You can disable shaders in the game, but this makes the game run very slowly. I tried to run Minetest 0.4.10, but it crashed upon launch.

Edited by CamTron
Link to post
Share on other sites
  • 1 month later...

Huh? Oh, that's... odd, I'm sure I set it to that yesterday.... I'll try again later. Thanks! ;)


Oh, on the subject, if a game wants d3dx9_43.dll, Can I just rename an older dll or can I just use this dll? I haven't looked at directx-based software in ages....

With Hunting Unlimited, I've found a d3dx9_42.dll file in the game's folder and renamed it to 43. Worked fine after that change.

Link to post
Share on other sites

WinPcap installer fails on Win98SE (NSIS)

I am trying to install "URL Snooper 2.37.01" on Windows 98SE (German language) with KernelEx 4.5.120. The program depends on the WinPcap driver and comes with versions 4.1.3 and 4.0beta2 - the latter is claimed to be compatible for Windows 98. Unfortunately both refuse to install.

Details see here:


The WinPCap website claims the last version supporting Win98SE were WinPcap 3.1 and WinPcap 4.0beta2.


However when I attempt to install the self-extracting EXE of 4.0beta2, its NSIS installer exits with the error requester "This version of Windows is not supported by WinPcap 4.0 beta 2. The installation will be aborted."

When I tried to install version 3.1, the NSIS installer exits with the even stranger error popup "WinPcap 3.1 can be installed on 32-bit x86 systems only. The installation will be aborted" My CPU is an AMD K6-3+, which is definitely 32 bit x86 compatible.

When I debug the WinPcap 4.0beta2 installation process in Dependency Walker, before the popup it throws the error: "GetProcAddress(0xBFF70000 [e:\windows\system\KERNEL32.DLL], "GetUserDefaultUILanguage") called from "h:\download\utilities\videos downladen\winpcap\4.0BETA2-WINPCAP.EXE" at address 0x00405D06 and returned NULL. Error:" Apparently the NSIS installer is incompatible with Windows 98 because the function GetUserDefaultUILanguage in kernel32.dll exists only since Windows 2000. Also KernelEx settings don't seem to change this. So I added in kstub822.ini to the "[Kernel32.dll]" section the following line to simulate it:

[Kernel32.dll]...GetUserDefaultUILanguage=r0407 ; German language (added by =CO=Windler)...I tried this also with "e0", which is apparently supposed to suppress an error flag.[Kernel32.dll]...GetUserDefaultUILanguage=r0407e0 ; German language (added by =CO=Windler)...
But this doesn't do anything. Even DependencyWalker still shows the same "returned NULL" error. Is my entry wrong or simply ignored by the installer?

- Is there a proper way to simulate GetUserDefaultUILanguage with Kext?

Edited by CyberyogiCoWindler
Link to post
Share on other sites

SeaMonkey 2.32 loads with the following two stubs:


SHEnumerateUnreadMailAccountsW=r0x80004001s4 ;SM2.32

SHSetUnreadMailCountW=r0x80004001s3 ;SM2.32

Using it now to post this reply!

[Edit]And now editing the post in FF2 to get the line breaks to appear[/edit]

Edited by jumper
Link to post
Share on other sites

After figuring out with latest import patcher that I also needed to add a bunch of ntdll functions to kstub822.ini I could run SeaMonkey 2.32 too. it's not usable here however unfortunately as in addition to having no working bookmarks, there is no working search engines and launching urls by pasting them in the the address bar doesn't work. Only way I could find to open web pages other than following hyperlinks is by dragging urls on the exe in explorer.  Crashes on many pages too.


I could also run Firefox 35 but it systematically froze on displaying any page.

Edited by loblo
Link to post
Share on other sites

@ jumper. SM2.32 does not start on my systems - I receive an error message from XULRUNNER that XPCOM could not be loaded.


But if I may ask, do you see any chances that the 'bookmark issue' can be fixed ?

Link to post
Share on other sites

 I receive an error message from XULRUNNER that XPCOM could not be loaded.


Check dependencies of xul.dll and add the missing functions not already covered by KernelEx to your kstub822.ini. I had that message too initially and had to add this : 











Link to post
Share on other sites

@ Loblo. I did had added these functions, except the '=f4'. Will try again in a few minutes.  Nope, does not work here.


@ Jumper. Is the following recommended/necessary ? (IP40 mentioned it.)

?DllBlocklist_Initialize@@YAXXZ= ;für SM2.32 ?

Edited by MiKl
Link to post
Share on other sites

Nope, does not work here.


Of course it doesn't, the likeliness you and I have the same missing functions in kstub822.ini is low. You've got to figure out what functions you still have missing and then add them. Also you'll need to set the files in XPSP2 compatibility mode.

Link to post
Share on other sites

Do you mean all these dll replacements that IP40 is suggesting ? For example for XUL.dll:

[Patches needed]
xul.dll=DLLs, Functions

[DLL replacements]


Sorry, I am not a programmer so I have no idea what to do.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...