Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

xpize 5 Release 5


W3bbo
 Share

Recommended Posts

What's New In This Release:

  • Simple Selector for easier customization and fewer risks and user confusion
  • Fixes the issue where almost 25% of the icons weren't being properly patched in Release 4 (whoops!)
  • Lite mode (selected automatically on non-English Windows): stops 128x128 icons from being installed to keep shell32.dll safe
  • Now installs on Polish Windows
  • It's about 100KB smaller than Release 4
  • New stuff:
    • Full Darkside IE8 support
    • New Luna Element bitmaps for Explorer and GINA
    • Cards.dll and Spider.exe
    • Windows Desktop Search 4.x
    • Luna Element shellstyles and Luna Element Black 5.1
    • Royale Lite is back (along with an "XPize 3.2" selection preset for you old-skoolers)
    • And various other resources

Known Issues:

  • It isn't fully localised
  • The sporadic toolbar bitmaps in 7zFM.exe still aren't resolved. I hope to get this fixed by Release 6, which will really be the last release
  • Several people are reporting the Shutdown/Restart dialog is visually messed up when you choose Darkside or Luna Element
  • Uninstallation issues:
    • Cursor scheme isn't restored
    • Visual style isn't perfectly restored
    • TaskSwitchXP isn't uninstalled (but you can do that manually via the start menu)
    • Uninstallation does not prompt you to restart after completing

I'm currently performing final testing before uploading it. Before installing it I strongly recommend uninstalling Release 4 first.

There was a bug in the xpize 5 Release 4 installer that means its Check for Updates functionality doesn't work anymore. People installing Release 4 will not get any notifications of an updated version, which is unfortunate.

Edited by W3bbo
Link to comment
Share on other sites


What's New In This Release:

[*]It's about 100KB smaller than Release 4

Huge improvement! :whistle:

Let me tell, this version was too fast to release :thumbup

u're awesome! :thumbup

Edited by Maxfutur
Link to comment
Share on other sites

What's New In This Release:

[*]It's about 100KB smaller than Release 4

Huge improvement! :whistle:

Let me tell, this version was too fast to release :thumbup

u're awesome! :thumbup

The reason for the long delay between earlier versions was because the framework needed changes being made to it as I developed it in tanden with xpize. Now that the Anolis system is stable only xpize needs changes.

Link to comment
Share on other sites

After choosing what icons, wallpapers, etc. should be installed and clicking Next, an error was encountered and installer has stopped working. (Windows 2003 SP2)

2009-08-14T19:55:33
Unable to load DLL 'srclient.dll': Nie można odnaleźć określonego modułu. (Exception from HRESULT: 0x8007007E)
at Anolis.Core.Native.NativeMethods.SetSystemRestorePoint(RestorePointInfo& pRestorePtSpec, StateManagerStatus& pSMgrStatus)
at Anolis.Core.Utility.SystemRestore.CreateRestorePoint(String description, SystemRestoreType type)
at Anolis.Core.Packages.Package.Execute(PackageExecutionSettings settings)
at Anolis.Installer.Pages.InstallingPage.__bw_DoWork(Object sender, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

"Nie można odnaleźć określonego modułu" = "Couldn't find specified module" or sth like that.

At least I could test the translation I made :P

//Okay, that was my fault - I forgot not to make System Restore Point. Sorry about that.

Edited by yojo2
Link to comment
Share on other sites

Hmm.. I found something strange.

This is Luna Element Screenshot:

Seems the button icons are messed up. This is Xpize 5.5 fresh install. Tried rebuilding the icon cache but nothing changed.

Anyone else see this?

post-1867-1250304445_thumb.jpg

Edited by DJ Specs
Link to comment
Share on other sites

Problems with R5:

* The "< Back" button problem is still there. - Maybe you can do an refresh for the progress bar page (so the it always shows 0% at the beginning), if it is entered, so that there is no confusing undocumented delay anymore.

* There is an unhandled exception, which can be reproduced:

- Click "Next >" until the visual style page appears

- Click "Advanced" for the component page

- Click "< Back" until the very fist page appears again

- Click "Next >" until the component page appears again

- Now click "Simple" => exception occurs

* If under component page no visual style is selected, xpize installes the selected style from simple page anyway.

But it should be possible to select the icons and extras only - with no installation of a visual style.

Additionally: it should be possible to select more than one visual style on component page - xpize should copy all selected visual styles to the "ressources" folder, but install only the one wich was selected on simple page.

Edited by MrBusty
Link to comment
Share on other sites

Suggestion for the preview function for the welcome screens:

I think it would be better to show the welcome screen automtically, if the welcome screen combobox is changed.

The normal desktop preview should be shown again, if any other combobox is changed.

Additionally the preview could be switched back and forth, if the preview image itself is clicked.

What do you think W3bbo?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...