Jump to content

The Solution for Seagate 7200.11 HDDs


Recommended Posts

Jaclaz, just wanted to thank you again,

 

I got this drive fully working after following your advice,

 

Having had the drive sit on a shelf for 4yrs, and various attempts to repair it, I was taking one last shot before I destroyed it.

 

Glad I did now! Nice 1tb of storage back, with some old gems of data I thought were gone forever.

 

Just one final question, how safe is it to use now?

 

I dont think i'll be keeping anything too important on it in the future anyway.

Happy we have another happy bunny:

http://www.msfn.org/board/topic/128727-cant-access-repair-my-pc-option-via-f8-startup/?p=828512

 

Once you have retrieved the data, it's up to you, my advice is in last paragraph of point #5 of the READ ME FIRST:

http://www.msfn.org/board/topic/143880-seagate-barracuda-720011-read-me-first/

 

Basically:

  1. perform manufacturer test
  2. update (if needed) firmware
  3. perform again manufacturer test

If the tests come out successfully then the disk is in theory as reliable as any other disk, in practice it is better to use it only as secondary backup.

If the tests come out with an error simply throw away the disk. 

 

jaclaz

Link to post
Share on other sites
  • 1 month later...

hello
I'm problem with HyperTerminal,, I have connected cable usb/serial + adapter serial/TTL max232 + 3.3v orange power supply and Black GND + TX and RX on HD
 
when I enter the HyperTerminal CTRL+Z It appears only strange symbols,,, the characters in different keyboards,,,
 
I installed the drivers from the cd  USB-SERIAL CH340 (COM3)
 
; CH341SER.INF
; Driver for CH341 (USB=>SERIAL chip) V3.1

 

 

This drive should be PL2303_Prolific ??,, ma I cannt reverse the drivers ...

 

Edited by mcsoba
Link to post
Share on other sites

Please do read the given link posts:

http://www.msfn.org/board/topic/128807-the-solution-for-seagate-720011-hdds/page-153#entry968299

AND the read-me-first (which is here if you haven't found it):

http://www.msfn.org/board/topic/143880-seagate-barracuda-720011-read-me-first/

 

ALL in "ALL devices must be grounded together" means "ALL", it doesn' t mean "some" or "a few" or "a part", how do you say "Todos os dispositivos ..." in Brazil ? ;)

 

 

 

 

more adapter has only one ground output,,,
 

 

If needed think octopus :w00t: :

http://www.msfn.org/board/topic/128807-the-solution-for-seagate-720011-hdds/?p=968346

(which you would have found had you actually read the given link)

 

 

jaclaz

Link to post
Share on other sites
i continues without understanding how to connect the ground ...
Octopus in this case and adapter?
gnd need to plug together on tip adapter or the tip of PSU??
You should draw a schematic for me ...
 
Tk ...
 
 
loopback test I'm trying to do but nothing appears nehum character ....
just when I backboard the ground on rx or tx separate appears strange characters,, hearts,,interrogations ....
when I backboard rx and tx not have any return,,,
this happens only in 5v,,3v not working ...

 

what's wrong with hyperterminal?

Edited by mcsoba
Link to post
Share on other sites

You need to understand the concept of "voltage".

 

Voltage is a "level", or more exactly a electric potential difference.

https://en.wikipedia.org/?title=Voltage

 

Take two common batteries and a multimeter as an example:

-[battery]+-[battery]+

0          1          2

if you measure voltage between 0 and 2 you will read 3 V, and if you measure voltage between 0 and 1 you will read 1.5 V, but if you measure between 1 and 2 you will read 1.5 V as well:

  • between 2 and 0 there are 3V as (1.5+1.5)-0=3 V
  • between 1 and 0 there are +1.5-0=1.5 V
  • between 2 and 1 there are 3-1.5=1.5 V

If you prefer point 2 is at +3 V over ground level (i.e. relative to point 0) and at level +1.5 V relative to point 1.

 

The TTL levels used in this hard disk and converter use very "narrow" intervals, and signals are transmitted at a relatively high speed, so an even minimal difference in the "base level" can lead to mis-communication.

 

The idea is that if ALL the ground or 0 level points of ALL devices involved are connected together, they are ALL at the same level, a so-called equipotential connection or isopotential locus:

https://en.wikipedia.org/wiki/Equipotential

this allows the "peaks" (which are the actual 0's and 1's transmitted) to be at the correct level, because they "share a common base".

 

More in detail, according to specs a "peak" measured between the Tx and Ground between 0.35 V and 0.8 V is a "0", and a "peak" measured between the Tx and Ground  between 2.0 V and 3.3 V is a "1".

 

If the TTL converter sends a "0" by sending an impulse at 0.6 V, but the ground (for whatever reason) is locally at 0.21 volts, a connected device with ground at the proper level of 0 V may "receive" it at 0.6+0.21=0.81 V and fail to "understand" it as being a "0", since these peaks are transmitted at a 38400 baud/rate there is the added complication of transition times (from 0 to the peak and back).

 

When doing a loopback test this is not an issue, as there is no other device connected and of course the Tx and Rx of the converter share a "common base".

 

If the loopback tests do not succeed, you have in your hands a *somehow* defective hardware, if you do the loopback test a the TTL level you have no way to know if the defective part is the USB to RS-232 or the RS-232 to TTL converter, so you should additionally do a loopback test on the RS-232 terminals, pinout and howto can be found here:

http://www.ni.com/tutorial/3450/en/

 

Be careful, the RS-232 has a relatively high voltage level, and if you misplace some connection you can "fry" something.

 

All in all, if you feel not familiar enough with the involved matters, are you sure you don't have a (local of course) friend with some more experience in the field?

There is nothing actually complex *anyone* with a very minimal electric/electronic experience or education can do properly the testing (and the grounding).

 

jaclaz

 

 

 

 

 

Edited by jaclaz
  • Upvote 1
Link to post
Share on other sites
  • 2 months later...
I tried it with other adapters: CA-42 and PL2303HX USB para RS232 TTL

 

AHQYGzR.jpg?1

still not work,,what is wrong? I understand t have connect the 4 ground wires together...

1point PSU - 2point AAC - 3point Adater - 4 point HD em

 


in the form of X ? 4point

as if it were X ?

 


 

and i turn the 2AA 1.5+1.5 .... ok

 

in adapter i turn batery on pin 3.3v or 5v ??
Link to post
Share on other sites

The adapter in your last post is seemingly a USB to TTL converter.

 

Without the specifications it is impossible to know if it works at the 3.3 V (good) TTL level or at the 5 V (bad) TTL level (this has nothing to do with the 3.3 V and 5 V pins that you have on that adapter that are used - if needed - to provide power to the device, the fact that it has a 3.3V power pin may mean that it is the "right" kind).

 

You need NOT a battery in this setup, the adapter is powered by the USB port and the disk drive is powered "normally" by a PC PSU though its power connector.

 

"Still not work" means nothing, last time you had issues with the loopback test, what happens with this other adapter when attempting a loopback?

 

To recap:

  1. loopback test: if it works the adapter works, if it doesn't the adapter is dead (and you need NOT any grounding for the loopback test)
  2. communicating with the drive: if it works good, if it doesn't try exchanging Tx and Rx connections, if the devices are not grounded together you may see "random" or "garbage" characters and you will need effectie grounding together of all devices involved

 

jaclaz

  • Upvote 1
Link to post
Share on other sites

Still i yet not managed ... I do everything correct and hyperterminal not appear nothing .. ctrl+z

think you may be the HD board?? transistor or IC or diode??

 

the pins correct this way??  from HD [. GND TX RX]

 

i tried also with CA-42,,, from DKU the right and connect on the on pin 3.3v or 5V??? 

 

thank ...

Link to post
Share on other sites
  • 1 month later...

Hi everybody.

 

I'm Luca from Italy.

I have this HD:

Maxtor DiamondMax 22 STM3500320AS

S/N: 9QM60RA2

Firmware: MX15

Data Code: 09074

I have this interface:adapt%201.4%20conn.jpg

 

I have powered the interface with a switching power supply @3.3V, connected to my PC (XP) and tried the Hyperterminal communication: the problem is that I had ASCII symbols both if I connect TX and RX together or if I connect TX and GND or TX and GND to the HD pins.

If I try to connect TX, RX and GND to my Hd I have no prompt on Hyperterminal.

 

Can you help me, please?

Thank you.

Link to post
Share on other sites

Wait a minute.

How are you powering the hard disk PCB?

 

The idea of connecting together the Tx and the Rx is to make a "loopback" test, i.e. to make sure that what you type in Hyperterminal is tramsmitted through serial port, converted to TTL on Tx, received as TTL on Rx, converted back to RS232, and ECHOed back to Hyperterminal.

 

If "strange" or "random" ASCII characters appear on Hyperterminal screen as soon as you connect together Tx and Rx it means that *somehow* the converter (or the serial port or the serial port driver) is not functioning correctly.

 

Besides that, the point is whether the adapter converts to "low" TTL level (right) or to TTL-CMOS (higher level and "wrong").

 

It is well possible, IF that converter is of the kind that outputs TTL-CMOS when powered at 5V and TTL when powered at 3.3 V, the switching power supply you are using is accidentally setting it to TTL-CMOS, try using two NEW 1.5 v batteries (in series), that should be enough to have a slightly lower than 3.3 V tension, but enough to operate the converter properly.

 

jaclaz

Link to post
Share on other sites

Hi,

meanwhile I tried using an ATX power supply for both the interface (using the +3.3V orange line) and the HD drive (usind the SATA connector): this way the GND should be the same for both devices. 

 

I had the same result...

What about trying with this? cp2102-micro-descr.jpg

Or this? http://www.bb-elec.com/Products/Serial-Connectivity/Serial-Converters/TTL-Converters/232LPTTL.aspx

Edited by fenestren
Link to post
Share on other sites

The issue with the "dual mode" converters that auto-switch between TTL and TTL/CMOS levels depending on power voltage is that it is possible that the "mechanism" is "triggered" accidentally by the power supply voltage level, a "switching" power supply may well have a slightly higher voltage output than the "label" 3.3 V and the power consumption of just the converter (next to "nothing" in terms of mA) is not enough to "stabilize" the power supply to the right level, the suggested use of two batteries is an easy way to exclude that this is what happens.

The €50 for the B+B converter you linked to is more than on the "high" side, on the "outrageous" side, if you are going to spend that kind of money, you can overpay a converter that at least is stated or "guaranteed" to be "bricked Seagate" compatible, i.e. google for "TTL Seagate ebay" (without double quotes) and you will find several offers for anything between 5-10 Euros (the actual commercial value of the thingy)  and 30-35 €.

 

jaclaz

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...