Jump to content

The Solution for Seagate 7200.11 HDDs

Recommended Posts

Hello, I referred to this program on the video tutorial.




The driver and I have downloaded and installed, thanks for the help
Edited by Brutuz
Link to post
Share on other sites

Look :) I don' t want to seem grumpier than I usually am :w00t::ph34r:, but if you come "here", you get help for what is "here", if you go "there", you may get help for what is "there"


FORGET each and every video tutorial you have found ANYWHERE, you should follow THIS guide:


or the one in first post of this thread, for which I gave you a link to the Spanish translation and ONLY these guides and NOTHING ELSE.


That video was made by the good guys from Greece that sell the kit for a mere 5 (five) times the cost of the components and provide with it a - most probably half-@§§ed :unsure: - program called "FWbugfix" (as stated in the sub-titles of the video, which seems a lot like a "wrap around" *a* terminal program).


If you buy from them for a mere 29.99 US$ the adapter, you will get also that program (which is NOT needed as Hyperterminal or Putty would do nicely).



Link to post
Share on other sites
  • 3 weeks later...

Hi, just wanted to thank everyone who posted info on how to fix the BSY Bug! After several hours, i managed to recover my drive, while i was entering in the cmds to the drive through putty i some how messed up one of the steps and was not able to use some of the normal methods to get back into the drive and ended up getting loops of the following codes.


"F3 T>Ctrl +z                            (After pressing that, i would get different results, etc)



LED:000000CC FAddr: 0025BF67

LED:000000CC FAddr:0000AE9B

LED:000000CC FAddr:0024A051

LED:000000CC FAddr:            53                                (cannot remember the exact code, but it ends in 53)



Eventually, i found a post    http://www.msfn.org/board/topic/129551-unlocking-terminal-of-seagate-es2-in-bsyled000000cc-state/

which, explains how to unlock the drive, however the method said it was for Seagate ES.2 series (ST******NS).

Figuring i had nothing else to lose anymore at this point, i tried the said method on my 7200.11 series (ST******AS) and the trick actually worked! I was able to unlock the drive and than use the normal commands to fix the drive. The PCB on the  7200.11 looks slightly different from the Seagate ES.2, but if you look at the picture from the guys post, you should be able to a similar spot on the PCB of the 7200 and use the short trick on that spot as well.


Sorry if this info has alrady been posted, but hopefully it could help some of the others who are stuck as well. This method worked for me, though i can't gaurantee it will work for everyone.

Link to post
Share on other sites

Hi guys, excellent thread and an excellent help to get me this far


but I have run into a problem...


Trying to fix the BSY state, I have everything hooked up and working,


I get the following




"Rst 0x20M"


I hit Ctrl+Z and get

"ASCII Diag mode"

"F3 T>"


I type /2

F3 2>


I type Z


F3 2>Z

LED:000000CE FAddr:0025DF1F




This is where my problem is, I cannot get any further.


If I type "Z" right away, I get the above message.


If I leave it longer than 20secs without typing, the drive will either power down or constantly loop like;


Rst 0x20M
Rst 0x20M
Rst 0x20M
Rst 0x20M


Any ideas?

Edited by Valo
Link to post
Share on other sites

hello please

I have adapter max232 to ttl http://i.imgur.com/QXY4BKL.jpg

I turn him in Vcc 5v supply on molex pc,, the correct ?
the lights up but nothing happens,,not appear port on pc...
I think I need to convert to USB??
how to convert DB-9 to usb,,which the pin??
from usb  = 1vcc ,, 2D- ,, 3D+ ,, 4gnd 
to DB9 ???
Link to post
Share on other sites



That is a SERIAL (or RS-232) to TTL adapter.


You need a SERIAL port on your computer (better) OR a SERIAL to USB converter, something *like* these:



OR, alternatively,  you need a USB to TTL converter, something *like*:



Please, DO READ the READ-ME-FIRST, FIRST, particularly points #6 and #10 :




Edited by jaclaz
Link to post
Share on other sites
okey thank

i no understand yet ..

then this adapter no will be used for anything ??


or i need connect to RS-232 port adapter female to Direct on PCport male ??? (I already did it but not work)


or need to convert first to usb  the DB9female adapter port???


i not connect directly to the PC adapter??

Edited by mcsoba
Link to post
Share on other sites

Look at it this way. :)


The thing depicted in the image you posted is a translator. :w00t:


It understands Portuguese and translates it in German and viceversa.

The hard disk speaks and understands Portuguese only, the serial (RS-232) speaks and understands German only and the USB speaks and understand  English only.



If your computers speaks German (through a Serial port), that thingy should be able to translate the German to the Portuguese the hard disk understands and back.


If your computer speaks English (through a USB port) you CANNOT connect to it that thingy, and you will need between PC and that another translator (the USB to RS-232 converter) translating from English to German and back OR a different translator that directly understands English (USB) and can translate to Portuguese (TTL) and viceversa.


The hard disk is particularly picky and while it speaks Portuguese (TTL) it only speaks the 3.3V level variant (let's say Brazilian Portuguese) and NOT the 5 V level variant (European Portuguese).


There is no way I can tell from your photo if that RS-232 to TTL adapter is 3.3V or 5V level.

A 3.3V TTL level will SURELY work.

A 5V TTL level will most likely NOT work. 


It is not a very difficult concept, the idea is to communicate and in order to do so you need devices that talk between them a same language,  if you have doubts maybe you can find a friend which is more familiar with the matter (or with English, or both) that may be able to assist you, reading point #6 and following, it is all written there, in an as plain manner as I could manage.



Link to post
Share on other sites
I understand that I have to combine this ...
even missing another converter until the PC port ...
I think myself could fabricate this cable using only one DB9 male to USB, changing the pinout ....
but i discover now this cable must be a professional,,right?
is not so very simple this cable have to buy same,, why has microchip involved for this conversion,,right? http://www.ftdichip
I thought it was just changing the pin DB9 to USB,,,,D+/TX,,,,D-/RX,,,,GND/GND


thank you ...

Link to post
Share on other sites

Please,     READ again point #6 of the READ-ME-FIRST! :realmad:


If - no matter because you do not understand English or you are not familiar with electronics - you have difficulties with it, see if you can find a friend that can help you :).



It is NOT POSSIBLE to convert USB to Serial (nor serial to TTL nor USB to TTL) by simply changing pinouts, they are DIFFERENT communication protocols, additionally using DIFFERENT voltage levels.



Your PC's Serial Port->RS232 to TTL[1] converter->Hard disk 

Your PC's USB port ->USB to TTL[1] converter->Hard disk

Your PC's USB port ->USB to RS232 converter->RS232 to TTL[1] converter->Hard disk



Anything not listed under "GOOD" above.


YOU CANNOT build yourself *anything* until you understand the BASICS of this matter, and if you understand the BASICS of this matter you wouldn't be here asking crazy questions. 


See if you understand better reading this :unsure::





[1] TTL at 3.3 V level AND NOT TTL at 5V level.

Link to post
Share on other sites

Try insulating the "other" set of contacts or try with the PCB completely detached from the drive, see here:




Thanks jaclaz, great to see youre still active on this thread and take the time to reply to noobs like myself.




Tried the motor contacts ,


Got a Spin down fine,


Spin up was tricky, it has to be timed perfectly, tho once I get it up, it wont allow me to type any further commands to continue the process.


Any ideas?


Thanks again




Got it! Drive at least shows in windows under disk management, getting 0mb error, so will have to try repair that next.

Edited by Valo
Link to post
Share on other sites

Jaclaz, just wanted to thank you again,


I got this drive fully working after following your advice,


Having had the drive sit on a shelf for 4yrs, and various attempts to repair it, I was taking one last shot before I destroyed it.


Glad I did now! Nice 1tb of storage back, with some old gems of data I thought were gone forever.


Just one final question, how safe is it to use now?


I dont think i'll be keeping anything too important on it in the future anyway.

Edited by Valo
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...