Jump to content

The Solution for Seagate 7200.11 HDDs

Recommended Posts

hi i reconnected the drive through the computers power supply and still no difference. i either get nothing or garbage. tried several drives too. it cant bee this difficult. loopback works connecting tx to rx. i am using the alldav powered at 5V. settings are 38400,n,8,1. Oh...I am using Vista so I had to find a hacked copy of hyperterminal.

You can try Tera Term since you're using Vista.

Link to comment
Share on other sites

Big thanks to Gradius, fatlip and all the people involved in this project!

Two quick questions here: I have a 7200.11 ST31000340AS, but with SD81 firmware (Freeagent Desktop) instead of SD15 firmware. Is it likely that my SD81 drive will run the same commands as SD15?

I've bought the USB FT232BM DL from the eBay link provided... besides the jumper cabling, will I need a battery, or can I use the power provided by the USB port?

Thanks a ton.

Getting a 3V battery like CR2032 (same type used in PCs) is safer and ain't expensive.

USB2 is just +5V DC @ 100mA, besides, if you short circuit by accident it can fry your USB port.

Link to comment
Share on other sites

OK, got everything but have run into problems.

Successfully does a loopback test.

Driver installed, using the right COM port, tryed using the ground cable on the third pin, have no clue how to turn echo off/on or what or if it effects anything.

If I plug the RX - RX, TX - TX it does the "arrow thing" which is the same result as when doing a loop back test.

If I plug in RX - TX, TX - RX it won't allow me to type.

My theory at this stage is that it may be a power issue (via USB).

Please, please help :wacko:

I wonder how you managed to turn on echo since you need to do some steps to achieve that.

How to turn OFF:

On HyperTerminal select File > Properties > select "Settings" tab, press ASCII Setup, and turn OFF "Echo typed characters locally". Click OK.

That should do. It's always safer and better use a simple CR2032 battery, or two +1.5V AA will do, even two +1.2V AA (rechargeable) also will works (they must be fully recharged before using).

Link to comment
Share on other sites

Thanks again Gradius, please PM me If you've got a paypal account, I'd like to make a donation to you for all your time and effort.


He has, Pete. Check his first post ;)

If appears as "TecTintas", relax, it's me. :blushing:

I didn't changed the name, because PayPal's is too bureaucracy just over a simple name, so I still didn't bothered to change it. :whistle:

Edited by Gradius2
Link to comment
Share on other sites

I'm now waiting for the delievery of a ca-42 cable.

I've got a st31000340AS and fw SD15.

Is it better to upgrade quickly to SD1A if I can reanimate the drive?

Other people have updated to SD1A and their hard discs continue with LBA 0 problem.

Then, they have updated to AD14 for repair the 0GB problem.

It is better than you continue with SD15, because you cannot return to this firmware.

I don't understand why they are doing downgrade :rolleyes:, when a simple cmd like this:

F3 T>m0,2,2,0,0,0,0,22, (enter)

will fix 0 LBA error even with SD1A. :blink:

Link to comment
Share on other sites


Hmmm not too sure, And you will need some more bits of cables etc.

This will definately work and the delivery is quick, and the guy there Rob is really helpfull (in an Electronics type way).


And its at least £10 cheaper.

A nokia 3210 fbus data cable is still the cheapest an easiest option, at around 2 quid and only needing the rx and tx connecting (no gnd or power)

Thanks for the reply...

How about a DCU-65 cable? - I'm sorta' on a time limit for this...

Link to comment
Share on other sites

I have developed programs to automatize the repairing process, to do it more easy.

Some people have probed these programs and them works.

I am colaborating with Fatlip to give a worldwide low cost solution (adapter and torx), there is people that cannot find adapters.

Soldering station aren't neccesary, electronic knowledge neither.

The work is behind and thanks to a lithuanian webpage we have the solution:


Due to some people that only know copy and paste, and later request donations ... I am thinking if I will give the programs or not. :angry:

Well, even if they do a copy & paste, it will do probably nothing with that almost indecipherable and incomplete "guide" at yura.projektas.lt :rolleyes:

It wouldn't appear as hardly now thanks to the guide available on this topic, but before that, the guide @ yura.projektas.lt was very hard to understand and I lost hours to deciphering step-by-step that (no kidding) and confirming the whole process on links I provided on "credits" part. The guy @ yura was so mean that he didn't bothered at all to answer any questions, nor reveal details. If you asked him anything he would just say "if you don't understand, go away!". Of course I didn't need to ask anything in first place. ;)

About the software isn't a hard part, I have a simple VB proggie that I can adapt for Seagate and release the source code under GPL/GNU. :hello:

The lower side is that would me requiere to install VB (ouch!) on my already loaded and full notebook, and using more of my "free" time. :wacko:

Edited by Gradius2
Link to comment
Share on other sites


Personally i wouldnt recommend a usb cable, but there is a few people on here who have successfully used varius usb cables.

Basically as long as it is based on a RS232 or Rs3232 controller or some derivative and you can find the phones pin out then it should work.

The rs232>3.3vTTL in the link will arrive in a day or two tho.

Link to comment
Share on other sites

Hello. I've tried connecting my seagate through a Nokia CA-53, and it keeps coming up as an unknown device under usb controlers tab in device manager. How can i "trick" it into being a com port, if that makes sence :unsure:

Link to comment
Share on other sites

found this on another forum

went ahead and got another DKU-5 off ebay and this time carefully examined it. Here's my findings:

Pin 2 = GND (white) - mine didn't have a Pin 8

Pin 4 = Vout (green)

Pin 6 = Rx (orange)

Pin 7 = Tx (blue)

Even then when I tried minicom it didn't work. After a while I tried screen and it worked perfectly right away.

command: sudo screen /dev/ttyUSB0 115200

So chances are my first cable was fine. Hopefully this will help someone that might have the same problem.

Link to comment
Share on other sites

I have a DKU-5 Compatible, with 4 wire cables.


What is the Guaranteed TX, RX and the GND?

Help-me please.

Waiting for response.

Thanks spellcasterbr, thanks for all.

no one knows, colors are not standard.

A continuity tester/voltmeter and this link will help you.

Good info about indentifing wires and checking the connection is here.

If you don't have a continuity tester/voltemeter i posted a very rogh test for indentify each wire here. Be careful and use at your own risk!

good luck!

PS: for all the people who feel uncomfortable with wires, volts and terminal windows, always remember that seagate seems to offer free data recovery for 7200.11.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...