Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Gradius2

The Solution for Seagate 7200.11 HDDs

Recommended Posts

Hi everybody,

I have same problem with Maxtor DiamondMax22, 500 GB model : STM3500320AS , firmware: MX15 , SN : 9QM2758W ; BIOS dose not recognize disk!

is key of my problem rs232 to ttl , and terminal ? Will I lose my data on disk ?

Thanx anyway !

Share this post


Link to post
Share on other sites

You should get yourself an RS-232 to TTL interface, like described in this topic

and follow the directions; your data is still there and can be retrieved if you

follow everything to the letter.

Just see the first post of this topic and read through the other posts for tips,

tricks and possible convertors you can use to unbrick your drive.

The first steps you'll have to take is to obtain an RS-232 <=> TTL-convertor and

a Torx (T6) screwdriver, but before you do anything: read this topic.

Good luck and if you have any particular question: don't hessitate to ask.

Greetz,

Peter.

Share this post


Link to post
Share on other sites

Hey all,

I am running WindowsXP, and I'm attempting this using the Nokia CA-42 cable. The cable installed correctly and shows up in the device manager as a COM device. I have cut the end off the cable and crimped jumper wires to each of the three leads.

Unfortunately, Hyperterminal won't connect using the com port the cable is set to. At first I got a message saying the port was in use by another program, but I fixed that by uninstalling the software that came with the cable but leaving the driver on the computer. The error message I get reads "Unable to Open ComX. Please check your port settings." Where X is the port number as shown in the device manager. I've tried this with all other "COM" items disabled in BIOS and all of them on (serial and parallel ports). My cable is the only com port listed in device manager.

I have tried:

Changing the port number for the cable in the device manager.

Disabling all non-essential startup and service items using msconfig.

Connecting with the cable leads attached to the drive and unattached (although I think this wouldn't affect my error).

I used a program called "portmon" to log the communication between hyperterminal and my port. Here's the report:

0.16314122 hypertrm.exe IRP_MJ_CREATE Serial2 SUCCESS Options: Open

0.00000381 hypertrm.exe IOCTL_SERIAL_SET_QUEUE_SIZE Serial2 SUCCESS InSize: 8192 OutSize: 8192

0.00000040 hypertrm.exe IOCTL_SERIAL_CONFIG_SIZE Serial2 SUCCESS Size: 0

0.00000034 hypertrm.exe IOCTL_SERIAL_GET_BAUD_RATE Serial2 SUCCESS

0.00000036 hypertrm.exe IOCTL_SERIAL_GET_LINE_CONTROL Serial2 SUCCESS

0.00000043 hypertrm.exe IOCTL_SERIAL_GET_CHARS Serial2 SUCCESS

0.00000044 hypertrm.exe IOCTL_SERIAL_GET_HANDFLOW Serial2 SUCCESS

0.00000030 hypertrm.exe IOCTL_SERIAL_GET_BAUD_RATE Serial2 SUCCESS

0.00000029 hypertrm.exe IOCTL_SERIAL_GET_LINE_CONTROL Serial2 SUCCESS

0.00000029 hypertrm.exe IOCTL_SERIAL_GET_CHARS Serial2 SUCCESS

0.00000030 hypertrm.exe IOCTL_SERIAL_GET_HANDFLOW Serial2 SUCCESS

0.05402632 hypertrm.exe IOCTL_SERIAL_SET_BAUD_RATE Serial2 SUCCESS Rate: 38400

0.00285265 hypertrm.exe IOCTL_SERIAL_SET_RTS Serial2 SUCCESS

0.00299006 hypertrm.exe IOCTL_SERIAL_SET_DTR Serial2 SUCCESS

0.00399649 hypertrm.exe IOCTL_SERIAL_SET_LINE_CONTROL Serial2 SUCCESS StopBits: 1 Parity: MARK WordLength: 8

0.00299053 hypertrm.exe IOCTL_SERIAL_SET_CHAR Serial2 SUCCESS EOF:0 ERR:0 BRK:0 EVT:0 XON:11 XOFF:13

0.00698539 hypertrm.exe IOCTL_SERIAL_SET_HANDFLOW Serial2 SUCCESS Shake:80000001 Replace:80000040 XonLimit:80 XoffLimit:200

0.00000032 hypertrm.exe IOCTL_SERIAL_SET_TIMEOUTS Serial2 CANCELLED RI:10 RM:0 RC:0 WM:0 WC:5000

0.02991895 hypertrm.exe IRP_MJ_CLEANUP Serial2 SUCCESS

0.02508913 hypertrm.exe IRP_MJ_CLOSE Serial2 SUCCESS

Note the cancelled command three lines from the bottom. I have no idea what the information means. I've spent time searching this and other forums for information on my error, but have been unsuccessful. Any ideas would be greatly appreciated!

Share this post


Link to post
Share on other sites

About a week ago I helped another person over e-mail that also tried to install

a CA-42 cable (but he didn't have the phone, so the installer failed).

He has been tinkering along and finally succeeded, here's what he said (in Dutch):

Het is gelukt!!!

Ik heb uiteindelijk in een laatste poging en in een helder moment de juiste manier

gevonden om de kabel te installeren.

(oorzaak: op de installatie cd stond enkel een menu voor de installatie van de Nokia

suite; geen menu item voor de kabel driver.

Na wat zoeken op de cd vond ik uiteindelijk een map met de juiste bestanden).

Ik heb daarna netjes de commando's van Gradius kunnen ingeven en ik kan nu

de HDD terug gebruiken.

Translated to English:

I did it!!!

In a last attempt and in a bright moment I found the right way to install the cable.

(Cause: on the installation CD there was only an installer for the Nokia suite;

there wasn't a menu item to only install the driver for the cable.

After browsing the CD I found a folder with the right files for the driver.

Then I could perfectly perform the commands described by Gradius and am able to

use the HDD again.

I suggest you fully uninstall the Nokia drivers and suite, restart your computer

(in case your COM-port is still left in use) and try to find that folder on the CD

this guy is talking about, to install the drivers manually.

Then try to open a session in HyperTerminal again.

To be on the safe side (and to check whether you're using the correct wires, RX and

TX), do a loopback test first by joining the RX and TX leads together and typing

something on the keyboard while in HyperTerminal: the characters you type should be

echood back on the screen.

Good luck,

Peter.

Share this post


Link to post
Share on other sites

Cool, I'll give it a shot, thanks!

Edited by bigleg

Share this post


Link to post
Share on other sites

Tried manually installing the driver and the result is the same.

The cable driver appears to be installed correctly, it shows up in the device manager under PORTS as "Nokia CA-42 USB (COM2)", but I still get the "Unable to Open COM2. Please Check Your Port Settings" message. I've tried this on two different computers running windows xp.

This is frustrating, I feel like I'm so close to getting all of my data back!

UPDATE: Just noticed my cable doesn't have a "made in" sticker on it. I'm now ordering one that says "made in China".

Edited by bigleg

Share this post


Link to post
Share on other sites

can i use diodes of 3 V for shema of rs232 to ttl ? or diodes must be 2.7 V ?

thanx !

Share this post


Link to post
Share on other sites

can i use diodes of 3 V for shema of rs232 to ttl ? or diodes must be 2.7 V ?

thanx !

Which schematics?

Which diodes?

If you mean the poorman's way depicted here (among tens of others):

http://picprojects.org.uk/projects/simpleSIO/ssio.htm

http://www.uchobby.com/index.php/2007/06/11/ttl-to-rs232-adaptor-explained/

http://techref.massmind.org/techref/io/serial/ttl2rs232.htm

There is ONE diode and it is a 1N4148 or 1N4001, the most "generic" diodes around, that you can replace with almost anything

http://www.epanorama.net/circuits/component_replacements.html

Personally:

  • I wouldn't use a 1N4001 (i.e. any rectifying diode as it may be too slow)
  • if I were you I would buy a pre-made interface or kit (if you have to ask about diodes it means you cannot build one by yourself) you already have a faulty HD, there is not much sense to risk to completely ruining it due to a half-***ed interface

jaclaz

Share this post


Link to post
Share on other sites

these diode ;)

Sure :), they are perfectly UNneeded, they are simply a (better be safe than sorry ;)) protection against surges or wrong connection/return currents, and CUT the TTL voltage to 2.7V.

Compare with this:

http://elisegt.interfree.it/html/nokia.html

Zener diodes DZ1 and DZ2 are VERY important to safety of Your phone. Normally are values of log. 1 about 3.3V and little overcross of this value can damage the phone - so power blast at turning on computer or connecting interface into computer. DZ1 and DZ2 diodes cuts-down this voltage to 2.7V - it is enough to log. 1 and it is hardly under maximal voltage value.

Since the specs for TTL are for 3.3V BUT up to 5 V can be given, the 3V zeners will anyway protect the interface and device from accidents without causing any problem:

http://www.interfacebus.com/voltage_threshold.html

Most of the Commercial interfaces and of the Max232 schemes around don't have them.

jaclaz

Share this post


Link to post
Share on other sites
but I still get the "Unable to Open COM2.

That worries me a bit :unsure:

Normally, a COM-port is only opened when an application (like HyperTerminal) or a service

(like MS ActiveSync or the Nokia Suite) is actively using it; if you would only install

the drivers without any program (or service) using it, you *should* be able to open that

port like any other ("real") COM-port, no matter where the USB-device was made...

Are you sure it's using COM2, since with most desktops, these are already integrated onto

the motherboard and any external attached (USB)-ports get additional numbers (COM3..COMxx).

Please check the settings in the computer's BIOS whether any on-board COM-ports are enabled

or not and play with these settings.

Good luck,

Peter.

Share this post


Link to post
Share on other sites

I'm having a problem applying this fix:

When I plug the sata power into my hdd, the entire system crashes. Am I doing something wrong?

Share this post


Link to post
Share on other sites

Apparently :unsure:

I hope you're not trying to apply power to your drive while it's connected to the SATA-port

to your computer and your computer is turned on? :no:

Because that will most definitively crash your system (unless your motherboard supports hot-

swapping).

First do the fix with only the RS232 <=> TTL convertor connected.

After you've un-bricked it (after carefully following the instructions on the first page of

this topic), you have to power down your computer, connect the drive over SATA, power up your

PC and see if it's recognized in the BIOS.

When it's recognized, see if the BIOS reports it as a 0GB drive.

If it does report as a 0GB drive, do the LBA0 fix (first power off your PC, disconnect SATA

and re-connect the RS232 convertor, then power on your system).

If your BIOS sees it as it should, you will be able to access it again and you can backup

the drive (do this first before you do anything else).

Greetz,

Peter.

Edited by VideoRipper

Share this post


Link to post
Share on other sites

I have two of these drives. I screwed up and used someones post here, which left out the REBOOT AFTER N1 step on the first one.

For the second one I went back to page one and used those steps. Thanks! That drive is fine now.

My question is about the first drive. The mis-step I took was issuing these two commands with no hdd reboot in between.


N1
F3 1>m0,2,2,,,,,22

The disk now detects. I can see it in windows, but in disk management it shows up as an uninitialized drive. Is there anyway I can recover data from it now? What exactly did I do with the F3 1>m0,2,2,,,,,22?

ANY help is appreciated!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...