Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

The Solution for Seagate 7200.11 HDDs


Recommended Posts

hi everybody,

a few days ago my Maxtor 1TB HDD didn't appear in my bootorder and nothing helped to rescue my files. then I found this theard here and a new hope rised in me. So I followed your tutorial but my hyperterminal didn't show me the Command Promt. Instead it brings me a lot of rubbish and confusing symbols (see screenshot below). Do anybody know where the problem is? Did I get an other failure or am I right that my HDD has same failure as here described?


Edited by ceri008
Link to comment
Share on other sites

Instead it brings me a lot of rubbish and confusing symbols (see screenshot below). Do anybody know where the problem is?

Check connections, power and GROUND.

Do loopback tests on your adapters, read here:





Link to comment
Share on other sites

I have just successfully completed this and thought I would add a few comments.

I had huge problems with a soldering iron and in the end used an idea suggested by a nice man in Maplin - use a solder sleeve and shrink it using a soldering iron. Then simply push over the relevant pins. This will keep the pins in contact for this operation - I used the single core breadboard wires that are suggested in the links.

To get power to the USB/RS232/TTL thing I found a spare molex connector and pushed on it a molex to SATA connector (of which I had plenty) and then simply snipped off the end and soldered the breadboard pins (see above) to the end of the wires. This is easy as you can poke the single core wire into the middle of the multistrand power wires.

To get power to the disk drive, I simply plugged it in using the motherboard SATA power connector.

Like some people I got a spin error when I entered the U command - but that was because the PCB wasnt touching the drive - simply tighten the screws and this goes away

Like everyone else I found the you didnt need to remove the PCB completely, just loosed the screws, poke some paper under the disk connectors and then remove it and tighten the screws later

...and then dont forget to upgrade the drive firmware - Seagate's drive detect will take you everywhere you need to go - it eventually upgraded my firmware from SD15 to SD1A

So - all in all not really a problem once I stopped trying to solder everything.

Many many thanks to you all who have made disk recovery such a pleasure

Link to comment
Share on other sites


I managed to un-brick my Seagate 7200.11 drive!!!

A huge thanks goes out to "troter" from Montreal. I called him and he gave me some advice and a couple tweaks in the procedure. He is offering to fix anyone's Seagate Barracuda 7200.11 drive for $30.

He lives in Montreal, Quebec, Canada. You can contact me at troter@gmail.com or 514-488-9970.

Another big thanks to Gradius et al for this post.

I used a CA-42 that I got on ebay for $6 with serial number IL40083821. The loopback test did not work. But, using a previous post and a multimeter, I figured out which wire was the gnd, tx, and rx. I had to switch Tx & Rx wires.

I isolated the data contacts, not the motor contacts with the cardboard. To do this, I had to completely remove the PCB from the drive. And, I cleaned the contacts with a regular eraser.

For the actual procedure:

a) I waited 60 seconds between "/2" and "Z".

B) I did NOT disconnect the power after the SMART command or at any time.

c) Type "F,,22" before the final partition command.

Here's a screenshot:


I live in Ottawa, Ontario, and I'd be more than happy to give someone a hand. You can reach me at danjcampbell***gmail.com. (Replace *** with @).

Good luck, and don't give up!

Link to comment
Share on other sites

I got my data back!

I didnt expect how easy to do it. I used a CA-42 cable that i got from Amazon for less $6, including shipping. I would say this is the simpliest & cheapest way to do it. All you have to do is connect the RX/TX (CA-42 side) - TX/RX (HDD side) and no need to worry about the power supply it is already powered by the USB port. Of course, you still need the HDD Sata power to spin up the motor.

Method from post #1 is the one that worked for me. On my first try, i didnt power off my drive and i got no response after m0,2,2,0,0,0,22 command. I waited for 1 hour and still no response. Getting so nervous of losing my data, i decided to power off/on my drive. Hit CTRL+Z again, got the prompt, entered the m0,2,2,0,0,0,22 command and woohooo, SUCCESS!!!

Thanks to Gradius et al!

Seageate : ST3500320AS

firmware SD15

Link to comment
Share on other sites


Well, today I found myself with my Seagate ST3500620AS and HP12 FW (from a Compaq computer) bricked. My PC wouldn't boot until I disconnected that drive, and I suspected that it was the infamous BSY bug. I checked on Seagate page, and of course it was one of the drives with the buggy FW.

I'm not scared to try new things, and although I knew all the stuff regarding the hyper terminal flashing and everything else, I didn't have the tools or the patience to wait an online purchase...

Pretty lucky I have another drive that's the same model but with SD25 FW removed from a customer PC because it started to show defective sectors. I had downloaded the flash tool and HP13 FW from the HP web site, but as my bios didn't show the drive it was useless.

I tried to swap the circuit board from both drives, but as anyone could expect, none of them worked. But then I realized something really interesting: both drives were recognised in the bios.

Well, I thought, let's try flash the board on the other drive... It worked. Surprise surprise!!! After I swapped again the boards to the original drives, both of them work fine (well, not counting the bad sector problem).

My drive works fine and although I lost some time looking for my old 3.5 Floppy drive and attaching it to my test rig, It's been much faster than anything else...

I hope that it helps anyone!!!


Edited by lapc2000
Link to comment
Share on other sites

Hi all,

I have a set of the ttl adapter and usb-serial cable which I used to fix mine. I don't have any use for it anymore and it's sitting gathering dust, so if anyone wants a set to fix their hard disk, I can sell my set, say for USD10 or equivalent excluding postage. Message me if you are interested. I'm located in KL, Malaysia. Here's a photo of the set, along with 2 cables I salvaged from old PC for connection to the PC power source (use the floppy drive molex adapter) and for connecting to the hard disk TX and RX.

Update: 28/July - sorry the parts are sold. for those who can buy from ebay, try looking there. i bought the key component from ebay, then just get any rs232-usb cable you can get from your local pc shop (cost about RM20 or USD6). a tip, search for "max232" in ebay, e.g.


I bought it from this seller virtualvillage back in Jan 2009. good luck!


Edited by poolcarpet
Link to comment
Share on other sites

So does anyone know why it wouldnt be spining?? it used to spin up

I ran into this same issue. What caused it for me is when the drive was spinning down on my first attempt I lost the terminal connection. Every attempt after that caused the drive to generate the LED:000000CE FAddr:0027CF31 error after entering Z. Not sure what the error means. Maybe that the drive is already stopped?

However, I noticed that just by typing in the Z and not pressing enter would spin the drive down. At that point I just backed spaced the Z out and moved on to the next step. I was able to proceed with out any troubles. I did have to run through the complete process; after my first attempt it was still busy. The error isn't a show stopper, just a pain in the neck. I was able to get access to all of the data on the drive.

This guide saved me big time and I am very grateful. This drive was for a client and they didn't have any backups of the data :angry:

Remember, ALWAYS make a backup!

Link to comment
Share on other sites

Remember, ALWAYS make a backup!

Good advice and important premise.

In my case the hard drive died without warning, after a reboot and normal


I had a 80% back up to 20% without saving.

Are many and varied configurations to keep data safe now.

It is not the same company that have data in a particular data disk.

But the value is the same.

My advice:

Of course back up our data regularly.

If the responsible company is not competent, do not purchase their products.

If this company is a mistake, should be debugged.

And, do not conform to only know computers, occasionally need to catch

a screwdriver and a soldering iron.


Link to comment
Share on other sites

I did it! I am so grateful to Gradius and this board.

I ultimately followed the guide here: http://sites.google.com/site/seagatefix/Home which was created by Brad Garcia with the help of this forum.

This three-month old HP computer belongs to an elderly couple. They were heartbroken about their data loss--pictures of the grandkids, medical records, etc. A couple of hours of research led me to the Seagate brick problem and ultimately, here. HP Support was absolutely appalling, as I expected. They denied knowledge of the problem, even though it is well documented on their site. Why they did not at least contact their larger vendors and at least offer a firmware upgrade is beyond me. These computers were sold knowingly with time-bomb hard drives.

I followed the procedure in the above link almost exactly, with one exception: after entering the F3 1>N1 command, I entered F3 1>/ and then the partition code: F3 T>m0,2,2,0,0,0,0,22 (enter).

Without that extra step, it kept getting stuck at the end. I never got the "User Partition Format Successful" message, even after waiting for more than 20 minutes and trying a few times. That one bit of code I found here saved the day.

It seems like some who are trying to use USB-type connections are having scattered success. I used the RS232 to TTL adapter from AllDav, and actually soldered. I was scared to death. I have never soldered before. Believe me, if I can do it, anyone can. I managed to burn my finger, but it worked perfectly.

Luckily I had an old PIII sitting in the closet to cannibalize wires and such. I did not use a battery. I used molex to SATA for power on the drive and it worked fine. I cannibalized a hard drive enclosure to get power to the RS232 to TTL adapter. I know nothing about electricity, and I had my fingers crossed big time when I turned it all on.

I used Putty instead of Hyperterminal. It worked great.


Again, thanks so much. It felt really good to be able to help these people. Their computer is up and running perfectly!

Edited by J327
Link to comment
Share on other sites

Im running into a bit of trouble. When I do all this, I connect all the wires and connect the circuit to the rs232 and open up HT then put all the settings in. When I hit ctrl+z I get no response. Ive switched the tx and rx around and still nothing. Ive tested the connections and they all come back in good standings. I dont know what im doing wrong or if I have to update something?

Link to comment
Share on other sites

I will be trying to unbrick my HD later using a ca-42 or dku-5 cable...hopefully all goes well. Question though, what's the tx & rx color for these cables? thanks!

Link to comment
Share on other sites

Well, im back again.

Ive got my other problem fixed it was the tx to rx connectors.

But now another problem pops up.

Heres a pic of the error

If someone could help me out, it would be greatly appreciated.

Just post back if you need some more info.


Link to comment
Share on other sites

Today my hdd wouldn't boot :(.

Seems to spin up then just stop doesn't detect at BIOS. I am looking to do this procedure since I don't have any other options.

What I am wondering is I found this and wondering if it is suitable for the connections



USB Function Controller

- USB Specification 2.0 compliant; full-speed (12 Mbps)

- USB suspend states supported via SUSPEND pins

Asynchronous Serial Data BUS (UART)

- All handshaking and modem interface signals

- Data formats supported:

- Data bits: 5, 6, 7, and 8

- Stop bits: 1, 1.5, and 2

- Parity: odd, even, mark, space, no parity

- Baud rates: 300 bps to 1 Mbits

- 576 Byte receive buffer; 640 byte transmit buffer

- Hardware or X-On/X-Off handshaking supported

- Event character support

- Line break transmission

Virtual COM Port Device Drivers

- Works with Existing COM Port PC Applications

- Royalty-Free Distribution License

- Windows Vista/XP/Server 2003/2000/98SE

- Mac OS-X / OS-9

- Linux

A packet which includes:

1X CP2102 USB-RS232 Serial Convert Communication Module

1X Mini USB Cable


It seems to have rx/tx, usb/serial connection and 3.3v/5v.

I am located in Australia and it seems a fairly cheap option as some of the others cost a lot more to post here. (my local shops don't seem to have any parts either :().

Any help would be great

Thanks, Matt

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...