Jump to content

Deleting shortcuts with © symbol


codeblue
 Share

Recommended Posts

Still creating my WPI Cleanup.cmd and am stuck trying to move or delete both shortcuts and folders containing the copyright symbol ©

The folder is SUPER © Version 2008.bld.32 (July 8, 2008)

The files are SUPER ©.lnk and SUPER © Uninstall.lnk

Ideally i would like to rename the folder to SUPER © as its far to long, and delete the two files.

Heres what ive tried:

DEL /Q "%allusersprofile%\Start Menu\SUPER © Uninstall.lnk"
DEL /Q "%allusersprofile%\Start Menu\SUPER ©.lnk"

MOVE /y "C:\Documents and Settings\All Users\Start Menu\Programs\SUPER ©.lnk" "%All%\SUPER ©"
MOVE /y "C:\Documents and Settings\All Users\Start Menu\Programs\SUPER © Uninstall.lnk" "%All%\SUPER ©"

(All=%allusersprofile%\Start Menu\Programs)

None of the above work and i suspect the © symbol it to blame. What makes me think something fishy is going on with the © symbol is that when i use:

MD "%All%\SUPER ©"

...it creates a folder called SUPER ®

So i thought i would be clever and did this:

DEL /Q "%allusersprofile%\Start Menu\SUPER ® Uninstall.lnk"...........but it didnt work!

How can i delete, move etc folders or files with the © symbol in?

Link to comment
Share on other sites


Just use the plain old "c" instead of that symbol. It works in Vista.

If it does not, here is the way to go:

Copy the © symbol in the clipboard.

Create a folder named "ab©de" in c:\

Open a command window, go to c:\

Type "rmdir ab" (no quotes) and then press TAB. TAB will search for all files beginning in "ab" and automatically complete the folder name. See what folder name it finds for the folder "ab©de". That is the way I did it in Vista, and it found "abcde", and I tested that you can replace "©" with "c" for any file/folder.

Good luck.

Link to comment
Share on other sites

An alternative is replacing the '©' with a question mark.

Try that :).

That does not work for folders.

rmdir can't use wildcards

I did try it for both, should of put that it doesn't work for folders.
Link to comment
Share on other sites

I did try it for both, should of put that it doesn't work for folders.

Well, I tried rmdir with a question mark before I posted and i tried it again now. It does not work.

I created a folder called "a©d" in c:\

I opened up the command prompt, went into c: and typed this command:

"rmdir a?d"

This is what I got:

"The filename, directory name, or volume label syntax is incorrect."

But "rmdir acd" works

Link to comment
Share on other sites

That's because when you type the copyright symbol in Windows, you're doing so in UTF-8 encoding, while in DOS, you're dealing with ASCII encoding. So the characters aren't the same.

Link to comment
Share on other sites

The idea I introduced in my attachment earlier definitely works on the posters 'expected' English (UK) system.

Here's another method for deleting your shortcuts, this one should work regardless of your particular language etc.

@For /f "delims=" %%# In ('Dir/b/a-d "SUPER ?*.lnk"') Do @Del/a/f "%%#"

Obviously this takes no account of any other shortcuts beginning with SUPER and followed by a space and at least one other character!

Link to comment
Share on other sites

Thanks all

Heres my new code

MD "%All%\Multimedia\Sound\SUPER ¸"
DEL /Q "%allusersprofile%\Start Menu\SUPER ¸.lnk"
DEL /Q "%allusersprofile%\Start Menu\SUPER ¸ Uninstall.lnk"
MOVE /y "%All%\SUPER ¸.lnk" "%All%\Multimedia\Sound\SUPER ¸"
MOVE /y "%All%\SUPER ¸ Uninstall.lnk" "%All%\Multimedia\Sound\SUPER ¸"
RD /S /Q "%All%\SUPER ¸ Version 2008.bld.32 (July 8, 2008)"

and it works like a charm :thumbup

Makes a folder called SUPER ©

Delete unwanted links

Copies 2 links to the new folder

Delets the unwanted folder.

Thanks ricktendo64 for the link to your post on Ryan's forum. I used Ultra Edit, but could i fond the ANSI to OEM option...Nope! Eventual i did in the File menu you under Conversions :wacko:

Thanks Yzöwl, didnt realize you where giving me the OEM code for the © symbol in your code until i used UltraEdit and found it turned © into ¸

....its all fun and games isn't it!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...