Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Integrating .NET framework


Recommended Posts

Hi,

everytime I try to integrate .NET framework(1.1, 2, 3 and 3.5) I always get the same error when I add it into the Hofixes, Addons, and Update packs section.

How an I supposed to integrate .NET frameworks.

I am using nLite nLite 1.4.5 beta 2 and I am modifying a Windows XP SP2 ENU.

Link to post
Share on other sites

So SP3 has 1.1 framework and 1.1SP1?

I am not sure you can integrate it into installation itself, but there are ways to install it silently during install, but that is not a real integration....

I think XP originally came with .net 1.1 and SP3 probably updates this version with all the latest 1.1 hotfixes, I suppose to 1.1 SP1 or whatever the latest SP version is. The Wikipedia section on the .net framework is probably worth reading.

.Net can't be integrated, just silently installed.

Link to post
Share on other sites
  • 3 weeks later...

... and it's true, it can not be integrated in xp as if slipstreamed, but it has to be installed silently as nlite plugin at T13 phase of windows installation. You can allso use this plugin to install .net 3.5 with updates on to xp after windows was installed, just run exe.

And, this is 32 bit plugin, not x64, and not vista, but xp only.

Link to post
Share on other sites

Ok I verified .. SP3 does not come with updated .NET framework.

That means you have to install

1)1.1 (*latest 1.1 and 1.1 SP1 must be downloaded or updated via Windows update)

2)1.1SP1

3)Security update patch for 1.1SP1

4).NET 2.0 (e.g. required by Adobe acrobat reader and ATI catalyst center)

5) Security update patch for 2.0

6) NET 3.0 (optional) (manually downloaded 3.5 .NET package contains updates from 2.0-3.5)

Regarding WMP.

If you dont install WMP11, your system is ok to go.

If you install WMP11, u need to install WMP11 and 1 security update for WMP11 runtimes.

Regarding IE7,

if IE6 is used, no update is nessesary

if IE7 is used only latest IE7 is nessesary .

Other then that, u need to update root certificates, and WGA tool.

sorry about not pointing out KB%numbers% of required updates.. not much time now/

Edited by Angelico_Payne
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...