Jump to content

nLite - Honey Turbo 9.1


Recommended Posts

  • 2 weeks later...

  • 3 weeks later...
Bear woke up, checked his stash and standing guard.

Changelog and download

This one is basically to catch up with the updates.

Lets see if it has some tiny worms eating the bits.


09.11.2008 - v1.4.9.1

09.04.2008 - v1.4.9 (nlite.exe v1.4.9.1)

09.01.2008 - v1.4.9

07.20.2008 - v1.4.8

07.01.2008 - v1.4.7

06.12.2008 - v1.4.6

Note: I read that some of you think that nLite breaks the floppy F6 method. That is not true, it is a Windows limitation, just disable the OEM Preinstall on the Unattended - General page or integrate the driver.

but we can not integrate ie8 french in my windows xp sp3 the 09.11.2008 - v1.4.9.1 is not complete

Edited by gamehead200
Please read rule 11.
Link to comment
Share on other sites

  • 2 weeks later...

Well, I would think that saying that a piece of software that does such a basic thing is "complete" is rather brave to say the least....

Here are some simple things to improve:

- ability to accept silent installers, like the RVM Integrator

- option to remove the Win98-ME-NT folders inside I386 (see a topic at the RyanVM board

- Literally dozens of more tweaks, like: power management, delete confirmation eliminate (the first delete, when things get into the recycle bin), host of IE8 (in general, IE) tweaks...

- More services for setting their default behaviour

Here is an important conceptual thing to improve in the area of tweaks:

Clearly separate tweaks which are system-like and which are user-like. And one (unusual) step further: ability to tweak the user that becomes the default user (this is what's happening now) and separately the built--in administrator user (optionally, of course)

I am even willing to lend a hand, if I can (I am not a programmer, but there are plenty of non-programming things to do, like in the tweaks area) to put my money where my mouth is.

This is indeed a GREAT piece of software.... and that is exactly the reason why it can never be really complete...


Link to comment
Share on other sites

  • 3 weeks later...
Here are some simple things to improve:

- option to remove the Win98-ME-NT folders inside I386

Definitly NOT true. Did you think about "Manual Installation and Upgrade" - this removes those folders/files.

I am even willing to lend a hand, if I can

Please check out nLite better than you did before posting.

BTW: The topic at RyanVM is over 3 years old exept your post...

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...

Just in case nuhi ever returns to nLite development again, then here's a bug-report for v1.4.9.1:

When removing terminal services, then 'lhmstsc.mui' isn't deleted from dosnet.inf, and hence, there's a file-copy error when installing through a BartPE/winnt32 based install-source.

Workaround for others: Instead of editing dosnet.inf manually afterwards, then Add 'lhmstsc.mui' to nLite's removal file-list, which then deletes the entry from dosnet.inf...

When using nLite in unattended mode from a NT command script, and when nLite has just been installed(with lite framework) and never has been run, then nLite stops alittle after the gui shows, and so i have to call nLite twice in the NT command script i.e. :

"%programfiles%\nLite\nLite" /preset:"%%presets%%\Last Session.ini" /path:"D:\Temp\GRTMPVOL_EN"
"%programfiles%\nLite\nLite" /preset:"%%presets%%\Last Session.ini" /path:"D:\Temp\GRTMPVOL_EN"

Note: This is just on a completely fresh nLite install i.e. nLite may newer have been run before to reproduce this


Lastly, then when disabling the 'component dependency messages', then 'DisableDepCheck' is written into the preset file, but when loading that preset into nLite the next time, then the 'DisableDepCheck' entry is ignored and isn't written into the new 'last session.ini' preset, and so 'component dependency messages' is enabled.

Thanks in advance...

Link to comment
Share on other sites

ho riscontrato diversi bug in nlite

-se carico la sessione mi inserisce due volte gli add-on hotfixes ecc. e se continuo la personalizzazione durante l'installazione mi da diversi errori xp

-ci sono alcune voci che non sono tradotte nella lingua italiana ma sono ancora in lingua inglese e non si sa di che dimensioni sono

-durante l'integrazione degli add-on nlite va in crash e mi da errore dell'exe di nlite

-durante la fase di masterizzazione dell'iso si blocca il programma va in crash e mi da errore dell'exe di nlite

-quando inizia la personalizzazione della versione di xp precisamente durante l'estrazione dei file mi dice che il driver.cab e il svpack.inf sono corrotti ma non è vero questo perchè il file non è stato usato mai e funziona benissimo facendo un'altra prova ovvero cancellando quel file e re-inserendolo la personalizzazione funziona e continua

si può fare qualcosa per sistemare questi odiosi bug ???

translate with google translate

I found several bugs in nLite

-load session if I put twice the add-on hotfixes etc.. and if I continue to customize during the installation gives me several errors xp

-There are some items that are not translated into Italian, but are still in English and do not know which sizes are

-during the integration of add-on nlite crashes and gives me error of nlite exe

-during the burning of the ISO hangs the program crashes and gives me error of nlite exe

-when you start customizing the version of XP specifically during the extraction of the files it tells me that driver.cab and svpack.inf are corrupt, but this is not true because the file has not been used and it works fine never doing another test or deleting that file and re-enter the customization work and continues

you can do something to fix these heinous bug??

Link to comment
Share on other sites

hi! what could be done with this error (please see screenshots & error details copied to notepad)?

error happens when browsing for windows installation files. clicking on continue just leaves nLite hung.

i don't know if this is also the result of the error, but as may be seen here, language likewise defaults to Zulu (not Eng).

in the installation process, tried it full, custom and even compact still with the same result.

restarted the pc, cleaned registry ... tried to uninstall & reinstall ... even downloaded a new installer to no avail.

i have dotnet 1.0, 1.1, 2.0 SP2, 3.0 SP2, 3.5 SP1 installed.

any help to remedy this will be greatly appreciated.

edit: sorry i didn't see this post rightaway, but issue seems still unresolved.

would really appreciate if if someone could help.


edit 2: resolved --- for those who might encounter the same issue, possible workarounds included (aside from those mentioned above), prior to re-running nlite:

deleted the dir that contains windows installation files & copied a fresh source

simplified the path (right from the root)





Edited by Kiki Burgh
Link to comment
Share on other sites

  • 4 weeks later...

Hi folks, and happy new year to nuhi and all nLite enthusiasts around the planet!

Anyway, here's a bug-report to nuhi for just in case he ever returns to nLite development again(me crossing fingers!)...

1) I've read that you(nuhi) previously have added the capability of fixing the checksums of driver-binaries with borked pe-header-checksums, but i still got 26 checksum-related filecopy errors during install, when integrating the Intel 82GL40 Graphics controller driver: 'VGA_Intel_v6.14.10.5002_XPx86'. The files with bad checksums are of the type: '*.LR_' (uncabbed: '*.LRC').

If anyone else needs to integrate this driver, then i have uploaded a fixed version(7.95mb), with only the actual needed files referenced in the two needed INFs(one for graphics and one for HDMI), with the driver files pre-cabbed, so nLite dosen't need to spend time on doing that also: http://www.mediafire.com/?kgxtn2zxd4z

2) When integrating the Intel ICH9M/M-E SATA AHCI Controller textmode-driver: 'SATA_Intel_8.0.0.1039_XPx86_A', then during install there's a filecopy error about iastor.sys not being found. I then copied it manually into I386, reinstalled, and then the error went away...

Thanks in advance.

CU, Martin.

Edited by Martin H
Link to comment
Share on other sites

[Feature Request]

1. If this project is ever restarted, it would be cool if files can be UPXed to further save size of the Windows installation. I'm aware all cannot upx-ed (due to crash etc) but definitely there are many files

2. Another cool thing would be to integrate FlyAkite modifications on CD files itself :)

Does anyone currently have "Safe-list" for Upx-ing CD content?

Does anyone currently know a way to integrate Flyakite without executing main package at first boot or such methods?

Link to comment
Share on other sites

  • 7 months later...

Hello everyone, I'm using nlite (along with UnattendXP, I'll explain) to create an unattanded XP MCE for one of my desktops, a HP A1560N. This model unfortunately REQUIRES the Raid drivers integrated before the hard drive will even get recognized in order to install. I'm also integrating some 3rd party applications (what UnattendXP is for) into the install. Problem is because I'm not computer savy enough to know how to "code" the applications directly into the install, I must use UnattendXP for this. But for some reason with UnattendXP, when I integrate my drivers along with the Raid drivers, and burn the CD, Setup still doesn't recognize my hard drive (only nLite does). For this reason I THEN have to open up nLite and integrate the Raid driver there so Setup will pick up the hdd's.

Now Im not sure what is causing the issue, but with using both programs for this setup, everytime in the XP install once it finishes copying over all the files (right before it goes into the actual XP install screen and everything) I get a BSOD. Now Ive tried multiple combinations with preparing the CD: using UnattendXP JUST for my software then nlite for everything else, using UnattendXP for EVERYTHING then using nlite for just the Raid driver, etc.

I know I'm doing something wrong, cause I doubt one program would be causing a conflict with the other but I most definately could be wrong. If anyone has had this problem and could shed some light on it, PLEASE help me!Also, I apologize if this isnt in the right thread.

NOTE: Is there anyone who is using UnattendXP with the same RAID problem as me and has found a way to manually add the RAID drivers??

Thanks for any information you can send my way!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...