Jump to content

HD pinouts.


Recommended Posts


I recently wasted days trying to get an IDE to USB cable to work. It never did, and during that time the process killed the two disks I bought the bloody cable for. The first death was because after centuries of trying I had the disk balanced on my knee, plugging in this and that in fevered desperation and frustration, and it finally fell off my shaking knee, onto a tiled floor, which killed it. The second drive's death depends on your answers.

The 2nd drive had been used successfully, and long-term, in two machines, both as a master and a slave. It didn't work with the IDE to USB cable, ever. Obviously, throughout the process, I re-installed it in each machine attached to the IDE cable. It worked, it worked, it worked, then it started causing hang ups (98SE and XP).

I tried everything. Then I noticed a gap in the rows of pins on the IDE interface that rang an alarm bell.

So. This drive now has a pin missing which I believe has been pulled out by the aforementioned cable. I need to know if this is the case, and what effects this missing pin might cause.

Upright position. Power cable to the right. From the lower pin-run, from the correct central missing pin, move up, and to the left, one. This pin is missing.

For the "correct, central, missing pin", there is no hole in the plastic. Whereas, the space for my "missing pin" has a hole - no pin. It is the tenth pin from the left of the upper row with the power supply to the right. Well, it would be if there was a pin there.

The connector is a Conceptronics IDE to USB CIDE23U.

Pinout info, gentlemen and ladies, please. Whereas I expect a response from youse lot, I do not expect Conceptronic to get involved, but I'm also posting this because Conceptronics website, and its FAQ files (3), yep, three, honest, three - they didn't even have the imagination to imagine what could imaginably happen, go for a brainstorm with the techies, and invent a few scenes, is laughingly appalling, and I am very, very annoyed. That's Conceptronics, for those with failing ears. Conceptronics, in case you missed it. I've been building machines since 1991, and I cannot prove that they are rubbish (this, "rubbish", was not my first choice of adjective, my vocabulary is much wealthier), and that their equipment has caused this problem. A-A-R-R-G-G-H-H-H. That was me being annoyed.

I am going to bed now. Don't even think of calling me. But do think Conceptronics.

God, but I'm pi**** o** ( how sad that we adults feel obliged to prissily hide our normal, natural, real, and usually acceptable language in these posts in case we offend some 200 year old ex-nun. Christianity, you have a lot to answer for.)

Best regards,


Link to comment
Share on other sites

if you've got a good camera, could you take close up pictures of the pin, the whole, and then the chip on the bottom of the drive, so i can see how it really looks? is the whole pin completely gone off the chip? or is it just broken at the plastic?


thats as solution i know of, i've used it..not something i'd ever want as a permanent fix, but it'll get the job done...i've seen drives with pins broken off and stuck in the IDE cable, but as for the entire pin missing, that could get tricky, but if i see how it looks, i can try to take one of my dummy drives and make a step my step guide. i have dead drives that i don't mind giving a butt-whooping to in order to help someone else, but if the pin is gone from the chip all the way through, it might get a little tricky.

Link to comment
Share on other sites

Actually if I remember correctly, some older drives had a pin missing deliberately. The IDE cable would also have that pinhole blocked so new builders couldnt put the cable in back to front. I dont know if that is still the case with newer drives, but it could explain the "missing" pin.

(I could be right off the track here, but someone will correct me.) :whistle:

Link to comment
Share on other sites


Ta for the replies.

That link is heartening. A fiddler after my own heart. The silver paper's a good idea. I wish I hadn't binned the other drive. I could've plucked a pin, and shoved it into this one with a dose of silver paper beneath it.

The hole in the plastic is actually more of a slot, and the pins are obviously cross-shaped. It is definitely not in the connector, and I've scanned the floor, no joy. I just hope it hasn't fallen onto the one of the mobos. Better give them a shake.

I've checked my other drives, and that pin exists on all, including other Seagates, and the connections on the underside clearly show a path into the rest of the PCB. I've got an old parallel-cable external drive case. I'll hammer a needle in and see what happens - nothing to lose. If it works, I'll leave it there, and I'll let you know.


Link to comment
Share on other sites

Found it!

Just pulled back the rubber cover and the pin fell out. I knew it. So it was that bloody Conceptronics connector. :realmad:

The pin is actually spade-shaped. First thoughts are I'll shove the pin back in and hold my soldering iron on it for a few minutes, see what happens. There's a fair bit of solder on the spade end, so it might flow enough to give a contact. Don't know if I'm going to waste any more time with the Conceptronics connector cable, though.

Still like to know if that pin is important, and what its lack might cause.

God, the time I wasted.

Link to comment
Share on other sites

Sorry, I'm not sure I got it.

Do you need the pinout for a standard IDE/ATAPI connector?

Here it is:






P.S.: Pin may look spade-shaped, but it should be just square (it depends on how you look at it :whistle: )

Edited by jaclaz
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...